Мобильное приложение 1С: Список покупок и анализ расходов

Публикация № 1071075

Управление - Финансовый учет и бюджетирование (FRP)

мобильное приложение android список покупок анализ расходов сканирование штрихкодов встроенной камерой загрузка чеков ФНС Налоговая наименование товара по штрихкоду PUSH

В публикации рассмотрено небольшое домашнее мобильное приложение для составления списка покупок и анализа расходов. В приложении реализованы: работа с штрихкодами (сканирование встроенной камерой), поиск наименования товара по штрихкоду из интернета, загрузка чеков из ФНС по QR-коду, вывод QR-кода ранее загруженного чека и др.

В мобильном приложении всего один документ Заказ, зато реализованы следующие механизмы:
- обмен с центральной базой (подробно описано здесь http://its.1c.ru/db/pubintromobile);
- отправка PUSH-уведомлений (подробно описано здесь http://its.1c.ru/db/pubintromobile);
- сканирование штрихкодов встроенной камерой;
- загрузка наименования товара по штрихкоду из интернета при создании товара (описание сервиса здесь https://barcodes.olegon.ru/);
- получение чека из ФНС по QR-коду (API здесь https://habr.com/ru/post/358966/);
- вывод QR-кода уже загруженных чеков для возможности получить чек на другом устройстве.

Кому интересно, выкладываю куски кода некоторых механизмов.

 

Сканирование штрихкодов встроенной камерой смартфона (объект СредстваМультимедиа)

Модуль формы документа или справочника, где нужно сканировать штрихкод:

// Кнопка Сканировать на форме
&НаКлиенте
Процедура Сканировать(Команда)
	ДополнительныеПараметры = Новый Структура;
	ДополнительныеПараметры.Вставить("Форма", ЭтотОбъект);
	ДополнительныеПараметры.Вставить("ИмяОбработчикаЗакрытияСканирования", "ОбработкаЗакрытияСканирования");
	ПодключаемоеОборудованиеКлиент.ПолучитьШтрихкод(ДополнительныеПараметры);
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаЗакрытияСканирования(ДополнительныеПараметры) Экспорт
	Возврат;
КонецПроцедуры

// Здесь обрабатываем полученный штрихкод, QR-код и т.п.
&НаКлиенте
Процедура ОбработатьПолученныйШтрихкод(ПолученныйШтрихкод, Параметры) Экспорт
	Сообщить(ПолученныйШтрихкод);
КонецПроцедуры

Общий модуль ПодключаемоеОборудованиеКлиент:

Процедура ПолучитьШтрихкод(ДополнительныеПараметры) Экспорт
	ЗаголовокСканирования = НСтр("ru = 'Считайте штрихкод'");
	Если ДополнительныеПараметры.Свойство("ЗаголовокСканирования") Тогда
		ЗаголовокСканирования = ДополнительныеПараметры.ЗаголовокСканирования;
	КонецЕсли;
	#Если МобильноеПриложениеКлиент Тогда
		ОбработчикСканирования = Новый ОписаниеОповещения("ОбработкаСканирования", ПодключаемоеОборудованиеКлиент, ДополнительныеПараметры);
		ОбработчикЗакрытияСканирования = Новый ОписаниеОповещения(ДополнительныеПараметры.ИмяОбработчикаЗакрытияСканирования, 
			ДополнительныеПараметры.Форма, ДополнительныеПараметры);
		СредстваМультимедиа.ПоказатьСканированиеШтрихКодов(ЗаголовокСканирования, ОбработчикСканирования, ОбработчикЗакрытияСканирования);
	#КонецЕсли
КонецПроцедуры

Процедура ОбработкаСканирования(Штрихкод, Результат, Сообщение, ДополнительныеПараметры) Экспорт
	Если НЕ ДополнительныеПараметры.Свойство("ПотоковоеСканирование") Тогда
	#Если МобильноеПриложениеКлиент Тогда
		СредстваМультимедиа.ЗакрытьСканированиеШтрихКодов();
	#КонецЕсли
	КонецЕсли;
	Если Результат = Неопределено Тогда
		Возврат;
	КонецЕсли;
	ДополнительныеПараметры.Форма.ОбработатьПолученныйШтрихкод(Штрихкод, ДополнительныеПараметры);
КонецПроцедуры

 

Загрузка наименования товара по штрихкоду из интернета

Поиск наименований товара по штрихкоду реализован через сервис https://barcodes.olegon.ru/. Сервис возвращает массив имен, я беру первое имя ТекМассив.names[0]. Модуль формы элемента справочника товаров:

&НаКлиенте
Процедура ОбработатьПолученныйШтрихкод(ПолученныйШтрихкод, Параметры) Экспорт
	Объект.Штрихкод = СокрЛП(ПолученныйШтрихкод);
	ssl4 = Новый ЗащищенноеСоединениеOpenSSL( неопределено, неопределено );
	HTTPСоединение = Новый HTTPСоединение("barcodes.olegon.ru", 443,,,,,ssl4,); 
	HTTPЗапрос = Новый HTTPЗапрос("/api/card/name/" + Объект.Штрихкод + "/B644542640852064273024635143606"); 
	Результат =  HTTPСоединение.Получить(HTTPЗапрос);
	Если Результат.КодСостояния = 200 Тогда 
		СтрокаРезультат = Результат.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8);
		ЧтениеJSON = Новый ЧтениеJSON;
		ЧтениеJSON.УстановитьСтроку(СтрокаРезультат);
		ТекМассив = ПрочитатьJSON(ЧтениеJSON);
		ЧтениеJSON.Закрыть();
		Если СтрДлина(Объект.Наименование) = 0 Тогда
			Объект.Наименование = ТекМассив.names[0];
		КонецЕсли;	
	Иначе
		Сообщить("Статус ответа:" + Результат.КодСостояния);
	КонецЕсли;
КонецПроцедуры

 

Получение чека из ФНС по QR-коду

QR-код чека является строкой вида t=20190602T2026&s=1854.00&fn=9282000100073930&i=74555&fp=3968601409&n=1, содержащей дату, сумму, номер фискального накопителя, номер чека, фискальный признак и вид операции. Используя эти данные можно получить сам чек из ФНС. Для получения чека в заголовке HTTP-запроса необходимо указать номер телефона и пароль, которые можно получить при регистрации в мобильном приложении Проверка кассового чека https://play.google.com/store/apps/details?id=ru.fns.billchecker&hl=ru.

&НаКлиенте
Процедура ЗагрузитьЧек(Команда)
	ВидЧека = "1";
	ДатаВремя = "20190602T1150";
	Сумма = "299.00";
	ФН = "8710000101180608";
	ФД = "98325";
	ФП = "309098793";
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Authorization", "Basic " + ЗашифроватьBase64("+79637413216:702187", "US-ASCII"));
	Заголовки.Вставить("Device-Id", "Android");
	Заголовки.Вставить("Device-OS", "Android");
	HTTPСоединение = Новый HTTPСоединение("proverkacheka.nalog.ru", 8888);
	HTTPЗапрос = Новый HTTPЗапрос("/v1/ofds/*/inns/*/fss/" + СокрЛП(ФН) + "/operations/" + СокрЛП(ВидЧека) + "/tickets/" + СокрЛП(ФД) + "?fiscalSign=" + СокрЛП(ФП) + "&date=" + СокрЛП(ДатаВремя) + "&sum=" + СокрЛП(СтрЗаменить(Сумма,".","")), Заголовки); 
	Ответ = HTTPСоединение.Получить(HTTPЗапрос);   
	Если Ответ.КодСостояния = 204 Тогда
		//Сообщить("Чек корректен");
	    ИмяВременногоФайла = ПолучитьИмяВременногоФайла();
		HTTPЗапрос = Новый HTTPЗапрос("/v1/inns/*/kkts/*/fss/" + СокрЛП(ФН) + "/tickets/" + СокрЛП(ФД) + "?fiscalSign=" + СокрЛП(ФП) + "&sendToEmail=no", Заголовки); 
		Ответ = HTTPСоединение.Получить(HTTPЗапрос, ИмяВременногоФайла);
		Если Ответ.КодСостояния = 200 Тогда
			//Сообщить("Чек получен");
			Форма = ПолучитьФорму("Документ.Заказ.Форма.ФормаДокумента");
			ДанныеФормы = Форма.Объект;
			ОбработатьФайлОтвета(ИмяВременногоФайла, ДанныеФормы);
			КопироватьДанныеФормы(ДанныеФормы, Форма.Объект); 
			Форма.Открыть();
		Иначе
			Сообщить("Получение чека: " + Ответ.КодСостояния);
		КонецЕсли;
	Иначе
		Сообщить("Проверка корректности: " + Ответ.КодСостояния);
	КонецЕсли; 
КонецПроцедуры

&НаСервере
Функция ЗашифроватьBase64(Строка, Кодировка) Экспорт
	ИмяВременногоФайла = ПолучитьИмяВременногоФайла();
	ЗаписьТекста = Новый ЗаписьТекста(ИмяВременногоФайла, Кодировка);
    ЗаписьТекста.Записать(Строка);
    ЗаписьТекста.Закрыть();
    Двоичные = Новый ДвоичныеДанные(ИмяВременногоФайла);
    Результат = Base64Строка(Двоичные);
	Если Лев(Результат, 4) = "77u/" Тогда
		Результат = Сред(Результат, 5);
	КонецЕсли; 
	Результат = СтрЗаменить(Результат, Символы.ПС, "");
    УдалитьФайлы(ИмяВременногоФайла);
    Возврат Результат;
КонецФункции

&НаСервере
Процедура ОбработатьФайлОтвета(ИмяФайла, ДанныеФормы)
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.ОткрытьФайл(ИмяФайла, "UTF-8");
	Результат = ПрочитатьJSON(ЧтениеJSON,,"dateTime");
	Организация = Результат.document.receipt.user;
	ИНН = Результат.document.receipt.userInn;
	СтрокиТовары = Результат.document.receipt.items;
		Для каждого СтрокаТовар Из СтрокиТовары Цикл
			Сообщить(СтрокаТовар.name);
			Сообщить(СтрокаТовар.price / 100);
			Сообщить(СтрокаТовар.quantity);
			Сообщить(СтрокаТовар.sum / 100);
		КонецЦикла; 
КонецПроцедуры

 

Вывод QR-кода

Для возможности вывода QR-кода чека строка QR-кода сохраняется в реквизите документа Заказ. Для вывода QR-кода в табличный документ используется типовая компонента 1С КомпонентаПечатиQRКода, которая есть в общих макетах типовых конфигураций 1С. Правда в мобильном приложении компонента не работает, поэтому приходится запрашивать QR-код из центральной базы.

&НаСервере
Функция ПолучитьКартинкуQR(QRКод)
	Макет = ПолучитьОбщийМакет("КомпонентаПечатиQRКода");
	Адрес = ПоместитьВоВременноеХранилище(Макет);
	
	КодВозврата = ПодключитьВнешнююКомпоненту(Адрес, "QRCodeExtensionSymbolicName");
	Если Не КодВозврата Тогда
		Сообщить("Проблема подключения внешней компоненты!");
	КонецЕсли;
	ГенераторQRКода = Новый("AddIn.QRCodeExtensionSymbolicName.QRCodeExtension");	

	ДанныеQRКода = ГенераторQRКода.GenerateQRCode(QRКод, 1, 190);
	
	Если ДанныеQRКода = Неопределено Тогда
		КартинкаQRКода = Новый Картинка();
	Иначе
		КартинкаQRКода = Новый Картинка(ДанныеQRКода);
	КонецЕсли;
	
	Макет = ПолучитьОбщийМакет("Макет");
	Макет.Рисунки.ШК.Картинка = КартинкаQRКода;
	ТабДок = Новый ТабличныйДокумент;
	ТабДок.Вывести(Макет);
	Возврат ТабДок;	
КонецФункции

 

О мобильном приложении

Центральную базу необходимо опубликовать на web-сервере, например http://192.168.103.28/BuyCentr. В центральной базе заполнить узлы плана обмена Мобильные устройства (предопределенный Ц - Центральный, второй К - Константин, третий Н - Николай и т.п.) и константу Ключ доступа отправителя PUSH, например PUSH_SRV_API_KEY_F55C7685_602D_4F06_BD4B_727CFBFAA85F (можно получить здесь https://pushnotifications.1c.com/). Также через консоль заданий можно настроить расписание регламентного задания, которое оповещает сколько денег потрачено сегодня.

Мобильное приложение необходимо собрать в Сборщике приложений, запустить на телефоне, заполнить узлы плана обмена (предопределенный К - Константин, второй  Ц - Центр), константу Адрес центральной базы, например http://192.168.103.28/BuyCentr, константу Код центральной базы - Ц, Номер проекта мобильного приложения, например 797785657074 (можно получить здесь https://pushnotifications.1c.com/), Номер и пароль для проверки чеков, например +79637413216 и 702187 (можно получить зарегистрировавшись в мобильном приложении ФНС https://play.google.com/store/apps/details?id=ru.fns.billchecker&hl=ru).

Проверялось на платформе 1С версии 8.3.14.1630 и мобильной платформе 1С версии 8.3.14.53.

Скачать файлы

Наименование Файл Версия Размер
Мобильное приложение

.cf 477,56Kb
16
.cf 477,56Kb 16 Скачать
Центральная база

.cf 475,87Kb
15
.cf 475,87Kb 15 Скачать
Мобильное приложение для Android

.apk 35,60Mb
7
.apk 35,60Mb 7 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. capitan 1902 06.06.19 17:37 Сейчас в теме
2. coollerinc 133 11.06.19 21:52 Сейчас в теме
3. coollerinc 133 12.06.19 19:32 Сейчас в теме
Частенько веб сервис валится в 202 ошибку, да и сканер на моем телефоне как то сложно распознает на реальных мятых чеках штрихкод. Даже поэксперементировал с стророниим сканером, чуть лучше, но все равно долго.
4. user_gea 14.06.19 11:28 Сейчас в теме
Спасибо за фрагменты кода! Взяты на заметку !
5. Derushev 5 10.04.20 13:52 Сейчас в теме
Спасибо! Но пуши не доходят. Вываливается ошибка: gcm has been deactivated and remove from google api
UPD: Простите, увидел. https://forum.infostart.ru/forum92/topic223641/
6. 1cspec 39 14.02.21 14:55 Сейчас в теме
А сервис "Загрузка наименования товара по штрихкоду из интернета https://barcodes.olegon.ru/" больше не работает?
Оставьте свое сообщение

См. также

Инструкция создание документов Заявка на расход ДС

Финансовый учет и бюджетирование (FRP) Пользователю системы v8 КА2 БУ УУ Абонемент ($m)

Пошаговая инструкция создание документов Заявка на расход ДС

1 стартмани

12.08.2020    2220    2    ITB_Consult    0    

Пример реализации HTML-формы календаря для мобильного приложения

Работа с интерфейсом Мобильная разработка v8::Mobile Абонемент ($m)

Реализация функциональной мобильной формы календаря, которая красиво трансформируется в список задач.

5 стартмани

13.02.2020    4944    17    ingeneerz@gmail.com    2    

Пример простого и приятного внешнего HTML интерфейса для мобильного приложения

Работа с интерфейсом Мобильная разработка v8::Mobile Абонемент ($m)

Реализация простого и приятного внешнего HTML интерфейса для мобильного приложения. Делимся исходниками, чтобы разработчики мобильных приложений разрабатывали больше приятных интерфейсов для приложений.

5 стартмани

05.09.2019    9328    66    Baksheev-Nikita    13    

"Учет активов и обязательств", ред 1.0 (для дома и бизнеса). Управляемое приложение (8.2). Промо

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы Россия УУ Абонемент ($m)

Простой и удобный способ учета доходов, расходов, кредитов, вкладов, наличных и прочих активов.

1 стартмани

03.09.2012    16672    25    Lighthouse    3    

Планирование расхода денежных средств для УНФ 1.6

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 УНФ УУ Абонемент ($m)

Внешняя печатная форма Планирование расхода денежных средств для УНФ 1.6 к документу Планирование расходов денежных средств.

1 стартмани

14.06.2019    4409    1    prime9    0    

Мобильное приложение "Сбор заказов" версия 2.0.1

Мобильная разработка Монитор заказов v8 v8::Mobile 1cv8.cf Украина УУ Абонемент ($m)

Приложение «Сбор заказов» разрабатывалось и разрабатывается для хранения и накопления данных от торговых представителей и автоматического обмена данными с программой учёта на базе платформы 1С:Предприятие. Мобильное приложение написано на технологии мобильной платформы 1С:Предприятие. Механизм обмена данных происходит посредством почтового сервера. В дальнейшем будет реализован механизм непосредственного доступа приложения к учётной системе через прямое интернет-соединение. FTP-соединение не работает как надо, так что будем довольствоваться тем, что есть... :)

4 стартмани

06.06.2019    8196    4    yarsort    10    

Управление задачами (мобильное приложение)

Мобильная разработка v8 1cv8.cf Абонемент ($m)

Конфигурация "Управление задачами" для мобильного приложения.

2 стартмани

29.04.2019    6884    11    noprogrammer    0    

Мои деньги (2.0 beta) Промо

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы Абонемент ($m)

Простая и удобная программа для учета личных финансов. Платформа 8.3.3. Интерфейс Такси.

1 стартмани

15.04.2013    19502    43    nesergey    14    

План продаж для УТ 10.3 / УТ 11

Печатные формы документов Финансовый учет и бюджетирование (FRP) Оптовая торговля Финансовый учет и бюджетирование (FRP) Оптовая торговля v8 v8::ОУ УТ10 УТ11 УУ Абонемент ($m)

Внешние печатные формы: План продаж для УТ 10.3 / УТ 11 к документу План продаж.

1 стартмани

01.03.2019    7117    0    prime9    0    

План продаж по категориям для УТ 11

Печатные формы документов Финансовый учет и бюджетирование (FRP) Оптовая торговля Финансовый учет и бюджетирование (FRP) Оптовая торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

Внешняя печатная форма: План продаж по категориям для УТ 11 к документу План продаж по категориям.

1 стартмани

28.02.2019    6004    0    prime9    0    

Конфигурация "Учет финансов"

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 УУ Абонемент ($m)

Предназначена для учета и планирования личных (а может, и не только личных) финансов. Имеет функцию резервирования денежных средств в разрезе статей. Реализованы все необходимые отчеты, а также диаграммы.

5 стартмани

16.12.2018    6542    2    Aphanas    4    

УЛФин - Бесплатная конфигурация для Управления Личными Финансами Промо

Финансовый учет и бюджетирование (FRP) Дебиторская и кредиторская задолженность Учет доходов и расходов Управленческий учет (прочее) v8 1cv8.cf Домашние учет и финансы УУ Абонемент ($m)

Конфигурация «Управление личными финансами» является развитием проекта «Домашняя бухгалтерия (на базе 1С 8.0)», но уже на платформе 1С:Предприятие 8.1 «Управление Личными Финансами» - это мощный инструмент для учета личных финансов. Благодаря функции планирования и наглядным отчетам – Вы можете не просто учитывать доходы и расходы, а анализировать их изменение, производить сравнительный анализ по периодам и многое другое.

1 стартмани

19.02.2008    51487    6878    z-alexey    529    

Изменение показателей бюджетной сметы (ф. 0501013)

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Печатная форма "Изменение показателей бюджетной сметы (ф. 0501013)" в соответствии с изменениями и дополнениями Приказа Минфина РФ от 20 ноября 2007 г. N 112н от 30 сентября 2016 г., 23 марта 2018 г.

1 стартмани

22.11.2018    6991    1    dp_bs21    0    

Бюджет семьи (конфигурация)

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы УУ Абонемент ($m)

Простая конфигурация на платформе 8.3, позволяющая вести учет семейного бюджета. Бюджет семьи у нас общий, ведется в разрезе "счетов" - например Кредитная карта, кошелек, шкатулка и т.д. Работает на платформе 8.3.13.1513

1 стартмани

19.11.2018    8497    2    vln    10    

Мобильное приложение "Вслух"

Мобильная разработка v8 Обучение, бизнес-тренинг, курсы Россия Абонемент ($m)

Не с кем учить уроки? Говорящий репетитор в твоём мобильном! Обучающее мобильное приложение для детей и слабовидящих.

1 стартмани

16.11.2018    7483    3    RSConsulting    4    

Учет ГСМ в 1С (на примере УПП) Промо

Финансовый учет и бюджетирование (FRP) Учет и отчетность v8 УПП1 Транспорт, автопарки, такси Россия БУ УУ Абонемент ($m)

Не надо бояться того, что документация создана для крупных организаций. Самое главное - это уже работает на практике. Пусть в УПП реализованы более продвинутые методики и конфигурации типа "Бухгалтерия" не имеют достаточных возможностей - не волнуйтесь - спокойно исследуйте собственные проблемы, советуйтесь и дерзайте - все у Вас получится!

1 стартмани

20.10.2011    33294    98    Виктор1905    30    

Интерфейсы мобильных приложений. Примеры

Работа с интерфейсом Мобильная разработка v8::Mobile Абонемент ($m)

Примеры реализаций одних из самых распространенных элементов навигации и пример реализации формы списка.

2 стартмани

17.10.2018    12613    131    Baksheev-Nikita    20    

Анализ затрат по чекам онлайн

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы Россия УУ Абонемент ($m)

Представлена конфигурация, позволяющая загружать чеки онлайн и анализировать расходы в разрезе поставщиков, товаров (категорий товаров), статей затрат. Конфигурация будет полезна тем, кто думает, а стоит ли планировать свои затраты? Используя данную конфигурация можно с минимальной ручной работой проанализировать свои повседневные расходы.

1 стартмани

14.10.2018    8849    3    gzharkoj    2    

Бюджетная смета (форма 0501012) и Изменения бюджетной сметы (форма 0501013) для БГУ 1.0

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 v8::БУ БГУ Россия Госбюджет Абонемент ($m)

Печатные формы Бюджетная смета (форма 0501012) и Изменения бюджетной сметы (форма 0501013) для БГУ 1.0, к документу "Бюджетные данные РБС/ГРБС/ГАИФ" с разделением по годам.

1 стартмани

20.07.2018    9767    25    dendzu    4    

Заявка на расходование денежных средств (печатная форма) для УТ11

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 v8::ОУ УТ11 УУ Абонемент ($m)

Подключаемая печатная форма для документов "Заявка на расходование денежных средств"

1 стартмани

21.06.2018    6434    12    COMPER    0    

Бюджетная смета 0501012 и 0501013 на 2018 год для БГУ 2.0

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Внешняя печатная форма 0501012 и 0501013 для документа "Бюджетные данные". Данные берутся из табличной части ЛБО, сума на текущий год.

1 стартмани

18.05.2018    7100    30    ataman    3    

Изменение показателей бюджетной сметы. БГУ ред. 1.0

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Во вложении 2 печатные формы "Изменение показателей бюджетной сметы" и печатная форма "Бюджетная смета" к документу "Бюджетные данные ПБС/АИФ" для БГУ ред. 1.0.

1 стартмани

01.02.2018    9654    23    alfa_1969    1    

Прототип конфигурации для фундаментального анализа ценных бумаг и финансового анализа

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Финансовые услуги, инвестиции УУ Абонемент ($m)

Прототип конфигурации для расчёта значений произвольных показателей по заданным формулам. Основное назначение - финансовый анализ и фундаментальный анализ ценных бумаг, но, теоретически, может быть использована и для других целей.

1 стартмани

06.01.2018    12040    5    q_i    8    

Подпись в мобильном приложении

Практика программирования Мобильная разработка v8::Mobile 1cv8.cf Абонемент ($m)

Подпись клиента в вашем мобильном приложении.

1 стартмани

04.01.2018    16092    48    onec.developer    7    

Конфигурация для учета личных финансов

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы Россия УУ Абонемент ($m)

Программа для учета личных финансов. Но кто знает может и подойдет для Малого бизнеса. Версия 1.0.1.10 Возможности: 1. Ведение счетов: наличка, карты. 1.1. Возможность в отчетности по остаткам не указывать счет для накоплений. 2. Статьи расходов 3. Статьи доходов. 4. Бюджеты расходов и доходов в разрезе месяцев. Учет финансовых целей.

3 стартмани

26.11.2017    11997    7    ra1ich    9    

Домашний ассистент

Мобильная разработка v8::Mobile Домашние учет и финансы Абонемент ($m)

Полезное в домашнем хозяйстве мобильное приложение для ведения мелких и не очень бытовых ремонтно-строительных работ в разрезе самих работ (проектов), а также расходных материалов. Кроме того, есть возможность пересчитывать все и вся в различные единицы измерения по ОКЕИ и прикреплять фотографии к работам, например, чтобы визуально оценить, как было до ремонта и как стало после. Не опубликовано в store-ах.

1 стартмани

22.09.2017    12404    9    ripreal1    3    

Сeмeйный бюджeт в 1С

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы УУ Абонемент ($m)

Простая программа  "Семейный бюджет"

1 стартмани

26.12.2016    9967    2    1Slash1    30    

Учет заявок водителей(Сервер + моб.приложение 1С)

Мобильная разработка Управление торговлей v8 УУ Абонемент ($m)

Серверная часть и мобильное приложение для учета заявок водителей

1 стартмани

27.11.2016    15843    61    flyer    0    

Заявки на кассовый расход по договору из документа Принятое обязательство по ПД (БГУ ред.1)

Печатные формы документов Банковские операции Финансовый учет и бюджетирование (FRP) Банковские операции Финансовый учет и бюджетирование (FRP) v8 БГУ БУ Госбюджет Абонемент ($m)

Печатная форма предназначена для документа "Принятое обязательство по ПД" и служит для отображения заявок на кассовый расход по договору принятого обязательства.

2 стартмани

17.05.2016    7153    2    m-kos    1    

Внешние печатные формы "Бюджетная смета" и "Изменение показателей бюджетной сметы"

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Для конфигурации «1С:Бухгалтерия государственного учреждения, редакция 1.0.» созданы внешние печатные формы «Бюджетная смета (форма по ОКУД 0501012)» и «Изменение показателей бюджетной сметы (форма по ОКУД 0501013)» для документов «Расходное расписание ПБС» и «Бюджетные данные ПБС/АИФ».

1 стартмани

21.03.2016    15920    60    dp_bs21    3    

Уведомление о лимитах бюджетных обязательств (ф. 0504822) ред. 52н

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 БГУ БУ Госбюджет Абонемент ($m)

Унифицированная форма 0504822 "Уведомление о лимитах бюджетных обязательств" в редакции 52н.

1 стартмани

06.08.2015    10132    11    ekaterinaeon    1    

Учет персональных финансов для Android и 1C

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы УУ Абонемент ($m)

Бюджет Блиц - учет и планирование доходов и расходов с возможностями коллективной работы, автоматического импорта SMS и качественными отчетами на мобильном устройстве и на платформе 1С.

1 стартмани

04.06.2013    16252    29    bme    10