Подключение к сайту и отправка или получение данных по API (POST, GET...) (с описанием кода)

Публикация № 1106730

Обмен - Интеграция с WEB

Обработка оправка отсылка получение API HTTP POST GET JSON PATCH PUT DELETE XML получить сайт данные 1С.

26
Простая обработка по отправке или получение данных с любого сервера главное знать ресурс (выполняемую функцию) и тело запроса.

Стояла задача отправить данные по API на внешний сервер из 1С, задача достаточно тривиальная, но возникли некоторые сложности поскольку у меня никак не выходило отправить данные через POST. После того как была написана данная обработка сразу смог определить проблему.

Тестировалось в УПП 1.3 (8.3.9.2170)

В моем соединении нету пользователя, пароля, не используется защищенное соединение. Если Вам необходимы эти параметры их можно добавить в строке "Все параметры подключения" и вынести поля на форму или написать комментарий я обновлю обработку.

Основной код отправки данных из описанного функционала (у меня использовалось только GET и POST, остальное добавил вдруг кому пригодится):

Процедура ОсновныеДействияФормыPOST(Кнопка)
	ВыполнитьСоединение("POST");	
КонецПроцедуры

Процедура ОсновныеДействияФормыGET(Кнопка)
	ВыполнитьСоединение("GET");
КонецПроцедуры

Процедура ОсновныеДействияФормыPATCH(Кнопка)
	ВыполнитьСоединение("PATCH");
КонецПроцедуры

Процедура ОсновныеДействияФормыPUT(Кнопка)
	ВыполнитьСоединение("PUT");
КонецПроцедуры

Процедура ОсновныеДействияФормыDELETE(Кнопка)
	ВыполнитьСоединение("DELETE");
КонецПроцедуры

Процедура ВыполнитьСоединение(ВидЗапроса)
	
	ЗаголовокHTTP = Новый Соответствие();	
	//Все параметры подключения
	//HTTPСоединение = Новый HTTPСоединение(Сервер,Порт,Пользователь,Пароль,Прокси,Таймаут,ЗащищенноеСоединение,ИспользоватьАутентификациюОС);
	HTTPСоединение = Новый HTTPСоединение(Сервер,Порт,,,,,);
    HTTPЗапрос     = Новый HTTPЗапрос(Ресурс, ЗаголовокHTTP);
	HTTPЗапрос.Заголовки.Вставить("Content-type", ContentType);
	HTTPЗапрос.УстановитьТелоИзСтроки(Тело,"UTF-8");	
	Если ВидЗапроса = "POST" Тогда
		HTTPОтвет = HTTPСоединение.ОтправитьДляОбработки(HTTPЗапрос);
	ИначеЕсли ВидЗапроса = "GET" Тогда
		HTTPОтвет = HTTPСоединение.Получить(HTTPЗапрос);
	ИначеЕсли ВидЗапроса = "PATCH" Тогда
		HTTPОтвет = HTTPСоединение.Изменить(HTTPЗапрос);
	ИначеЕсли ВидЗапроса = "PUT" Тогда
		HTTPОтвет = HTTPСоединение.Записать(HTTPЗапрос);
	ИначеЕсли ВидЗапроса = "DELETE" Тогда
		HTTPОтвет = HTTPСоединение.Удалить(HTTPЗапрос);
	КонецЕсли;
    КодСостояния   = HTTPОтвет.КодСостояния;
    ТекстОтвета    = HTTPОтвет.ПолучитьТелоКакСтроку();
	Ответ = "";
	Ответ = Ответ + "Код состояниия (Status code): " + Символы.ПС;
	Ответ = Ответ + КодСостояния + Символы.ПС +"-----------------------" +Символы.ПС;
	Ответ = Ответ + "Текст ответа (Response text): " + Символы.ПС;
	Ответ = Ответ + ТекстОтвета;
	
КонецПроцедуры

Кнопки "JSON", "XML", "POST=" - показывают пример заполнения тела в данном формате (я их использовал для тестирования отправки своих данных в разных форматах). 

Можете поблагодарить, если Вам помог описанный функционал. 

26

Скачать файлы

Наименование Файл Версия Размер
Подключение к сайту и отправка или получение данных по API (POST, GET...) (с описанием кода):
.epf 9,67Kb
12.08.19
2
.epf 9,67Kb 2 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. webester 28 12.08.19 15:51 Сейчас в теме
Для простых случаев мне нравится использовать вот этот пример с ИТС https://its.1c.ru/db/metod8dev#content:5574:hdoc он покрывает практически весь нужный функционал с анализом ответов сервера и переадресациями.
AllexSoft; +1 Ответить
3. Rustig 1173 14.08.19 15:51 Сейчас в теме
4. webester 28 14.08.19 17:26 Сейчас в теме
(3)Если много работаешь с HTTP запросами посмотри на коннектор https://infostart.ru/public/709325/
5. Rustig 1173 14.08.19 17:28 Сейчас в теме
2. dsdred 1130 13.08.19 15:42 Сейчас в теме
Если ВидЗапроса = "POST" Тогда
HTTPОтвет = HTTPСоединение.ОтправитьДляОбработки(HTTPЗапрос);
ИначеЕсли ВидЗапроса = "GET" Тогда
HTTPОтвет = HTTPСоединение.Получить(HTTPЗапрос);
ИначеЕсли ВидЗапроса = "PATCH" Тогда
HTTPОтвет = HTTPСоединение.Изменить(HTTPЗапрос);
ИначеЕсли ВидЗапроса = "PUT" Тогда
HTTPОтвет = HTTPСоединение.Записать(HTTPЗапрос);
ИначеЕсли ВидЗапроса = "DELETE" Тогда
HTTPОтвет = HTTPСоединение.Удалить(HTTPЗапрос);
КонецЕсли;


Попробуйте заменить на вот это:

HTTPОтвет = HTTPСоединение.ВызватьHTTPМетод(ВидЗапроса,HTTPЗапрос);

Пример: https://infostart.ru/public/886103/
Оставьте свое сообщение