Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Публикация № 1221839

Разработка - Практика программирования

страховые взносы 77 апрель 2020

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

Конфигурация "Учет и отчетность предпринимателя, ред. 1.2" снята с поддержки фирмой 1С. Но некоторые организации ей ещё пользуются.

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

В расчет внесены некоторые упрощения:

1. Начисления каждого работника не должны превышать предельную величину базы страховых взносов и предельную величину базы ФСС;

2. Не учитываются также сотрудники, имеющие льготы по инвалидности.

Вот 4 фрагмента, которые надо изменить в модуле документа НачислениеНалоговСФОТ в процедуре ОбработкаПроведения() (релиз 7.70.290):

1.

Процедура ОбработкаПроведения()
    
    глСообщенияТрассировки = глСоздатьТрассировку("Проведение документа " + глПредставлениеДокумента(ТекущийДокумент()));
     
    НачисленоПоВидамНалогов = глТаблицаДанныхДляРасчетовСБюджетом();
    
    ОблагаетсяУСН = Константа.УСН.Получить(ДатаДок);

    //ПЕВ 08.04.2020
    Если ДатаДок>'01.04.2020' Тогда
        МРОТ=12130;
        Сообщить("МРОТ="+МРОТ);
    КонецЕсли;
    //

    НалогЕСН = глПолучитьНалог("ЕСН_ФБ");

2.

                        Если РезультатПФР_ОПС <> 0 Тогда
                            РазбитьБазуПоВР(БазаПФР_ОПС,БазаОР,БазаЕР);
                            
                            //ПЕВ 08.04.2020
                            Если ДатаДок>'01.04.2020' Тогда
                                База=БазаОР.Итог("База");
                                Если База>Мрот Тогда
                                    ИсчисленоВТекущемМесяце = Окр(СтавкаТарифа * Мрот+0.1*(База-Мрот),2);
								Иначе	
									ИсчисленоВТекущемМесяце = Окр(СтавкаТарифа * База,2);
                                КонецЕсли;
                            КонецЕсли;
                            //
                            
                            Если (ИсчисленоВТекущемМесяце + ИсчисленоВТекущемМесяцеИнвалид) <> 0 Тогда

                                
                            
3.

                Если РезультатФФОМС <> 0 Тогда
                    
                    РазбитьБазуПоВР(БазаФФОМС,БазаОР,БазаЕР);
                    
                    //ПЕВ 08.04.2020
                    Если ДатаДок>'01.04.2020' Тогда
                        База=БазаОР.Итог("База");
                        Если База>Мрот Тогда
                            ИсчисленоВТекущемМесяце = Окр(СтавкаТарифа * Мрот+0.05*(База-Мрот),2);
						Иначе	
							ИсчисленоВТекущемМесяце = Окр(СтавкаТарифа * База,2);
                        КонецЕсли;
                    КонецЕсли;
                    //
                    
                    Если (ИсчисленоВТекущемМесяце + ИсчисленоВТекущемМесяцеИнвалид) <> 0 Тогда

4.

                Если РезультатФСС <> 0 Тогда 
                    
                    РазбитьБазуПоВР(БазаФСС,БазаОР,БазаЕР);
                    
                    //ПЕВ 08.04.2020
                    Если ДатаДок>'01.04.2020' Тогда
                        База=БазаОР.Итог("База");
                        Если База>Мрот Тогда
                            ИсчисленоВТекущемМесяце = Окр(СтавкаТарифа * Мрот,2);
						Иначе	
							ИсчисленоВТекущемМесяце = Окр(СтавкаТарифа * База,2);
                        КонецЕсли;
                    КонецЕсли;
                    //
                    
                    Если (ИсчисленоВТекущемМесяце + ИсчисленоВТекущемМесяцеИнвалид) <> 0 Тогда


В дальнейшем при изменении МРОТ надо будет изменить 1 фрагмент.

    //ПЕВ 08.04.2020
    Если ДатаДок>'01.01.2021' Тогда
        МРОТ=14000;
        Сообщить("МРОТ="+МРОТ);
    ИначеЕсли ДатаДок>'01.04.2020' Тогда
        МРОТ=12130;
        Сообщить("МРОТ="+МРОТ);
    КонецЕсли;
    //

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. pevek 27.04.20 11:15 Сейчас в теме
Для 1С:Предприятие 7.7. Конфигурация "Бухгалтерия + Торговля + Склад + Зарплата + Кадры" есть решение?
3. Юджин58 16 27.04.20 15:28 Сейчас в теме
(2)
Надеюсь 1с выпустит скоро обновление этих конфигураций. Иначе придётся самим доделывать. Две недели ещё есть для ожидания..
4. user1399817 27.04.20 16:18 Сейчас в теме
(3) Если не выпустит 1С, то вы сможете выполнит обновления для 1С 7.7. Бухгалтерский учёт версия 4,5?
6. Юджин58 16 27.04.20 18:10 Сейчас в теме
(4)
В упрощённом виде (без всяких льгот, доп.тарифов, превышений предельных размеров), я уже сделал. Тестирую..
user1399817; +1 Ответить
9. user1399817 27.04.20 18:39 Сейчас в теме
(6)Держите в курсе вашей работы, пожалуйста. Льготы, доп. тарифа не нужны, а вот превышение предельных размеров это да.. Бывает что к концу года и превысит(((
2. user1399817 27.04.20 13:00 Сейчас в теме
Здравствуйте. Для 1С 7.7. Бухгалтерский учёт версия 4,5 есть решение?
33. tasha2024 15.05.20 07:08 Сейчас в теме
5. pentanom 23 27.04.20 16:52 Сейчас в теме
Нужно учесть, что в РСВ-1 внесены соответствующие изменения. Теперь в приложении 3 на каждого сотрудника в разделе 3.2.1 должно быть две строки: НР (до МРОТ) и МС (больше МРОТ).
Прикрепленные файлы:
7. Юджин58 16 27.04.20 18:13 Сейчас в теме
(5)
Регламентированную отчетность навряд ли я буду дорабатывать. Наша бухгалтерия отчетность формирует в НалогоплательщикЮЛ.
8. user1399817 27.04.20 18:29 Сейчас в теме
(7) 2 НДФЛ и 6 НДФЛ понятно в Налогоплатильщике делать можно.. А вот расчёт страховых взносов по-месячно с учётом в 1С как делать. Допустим налоги с ФОТ, соответственно и учёт начисленных и уплаченных страховых взносов. Отсюда и налог на прибыль другой будет, так как 15 процентов высвобождается и на них ляжет 20% прибыль.
10. x_dimon 29.04.20 22:10 Сейчас в теме
Добрый день! А можете сделать внешнюю обработку к ЗИКу 1С семерка, которая бы начисляла страховые взносы по новым правилам с 01.04.2020 и сколько это будет стоить?
11. Юджин58 16 30.04.20 10:17 Сейчас в теме
(10) Доброе утро! 1с 77 ЗИК не смогу доработать, так как совсем с этой конфигурацией не знаком.
28. Юджин58 16 07.05.20 12:00 Сейчас в теме
12. user1399817 04.05.20 12:59 Сейчас в теме
Здравствуйте. Не подскажете, есть ли обновления новые для 1С 7.7.? Со страховыми взносами..
13. pentanom 23 04.05.20 13:11 Сейчас в теме
(12)
Здравствуйте. Не подскажете, есть ли обновления новые для 1С 7.7.? Со страховыми взносами..
Есть 7.70.654 и 20q1008.
14. user1399817 04.05.20 13:18 Сейчас в теме
(13)Не поделитесь? Достаточно установить 7.70.654 или потом поставить ещё 20q1008?
15. pentanom 23 04.05.20 13:35 Сейчас в теме
(14)куда слать ? md достаточно?
16. user1399817 04.05.20 13:42 Сейчас в теме
(15)regionfox*yandex.ru
Вышлите пожалуйста всё что есть. Буду всё устанавливать
17. pentanom 23 04.05.20 13:44 Сейчас в теме
(16)
regionfox*yandex.ru
Звездочка - это собака?
18. user1399817 04.05.20 13:46 Сейчас в теме
19. pentanom 23 04.05.20 13:53 Сейчас в теме
29. kirbox 12.05.20 12:10 Сейчас в теме
(19) можно мне тоже отправить? admin*kirbox.ru
30. Alexus557 13.05.20 15:05 Сейчас в теме
(29) opttrade55*mail.ru Поделитесь пожалуйста!
(19)
31. kirbox 14.05.20 15:22 Сейчас в теме
(30) Мне самому не прислали
20. alyanse 06.05.20 11:58 Сейчас в теме
И все равно не считается. Нужно еще где-то поставить галку.
21. Юджин58 16 06.05.20 15:32 Сейчас в теме
(20)
Констатнта Основной тариф страховых взносов периодическая. Ставьте Для субъектов малого или среднего предпринимательства на 1 апреля 2020 и всё заработает
23. user810819 06.05.20 18:19 Сейчас в теме
(21)
А можете пожалуйста подробнее объяснить как ставить? Вроде в тарифах страховых взносов в списке Для субъектов малого или среднего предпринимательства ПФР стоит 10 % а Ффомс 5. Но считает неправильно. А так же как ее выставлять на 1 апреля? там ведь только год дает ставить с которого дейтсвует

24. user810819 06.05.20 18:26 Сейчас в теме
(21)А можете пожалуйста подробнее объяснить как ставить? Вроде в тарифах страховых взносов в списке Для субъектов малого или среднего предпринимательства ПФР стоит 10 % а Ффомс 5. Но считает неправильно. А так же как ее выставлять на 1 апреля? там ведь только год дает ставить с которого дейтсвует

27. Юджин58 16 07.05.20 08:16 Сейчас в теме
(24) Операции - Константы. Ищете "Основной тариф страховых взносов". Выбираете значение "Для субъектов малого или среднего предпринимательства", если там что-то другое. Затем правой кнопкой мыши на "Для субъектов малого или среднего предпринимательства" выбираете "История значения". Дату меняете на 01.04.20.
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    71314    0    Serginio    108    

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д.

Разработка внешних компонент Практика программирования WEB v7.7 v8 Бесплатно (free)

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    30283    0    Serginio    22    

Экспорт нескольких MXL таблиц в один XLS файл, на отдельные листы. Простой алгоритм

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 Бесплатно (free)

Статья посвящена распространённому вопросу - как сохранить несколько таблиц (отчетов) в формате MXL, с которым работает 1С, на отдельные листы одного Excel файла. Освещается простой алгоритм решения проблемы штатными средствами, без использования внешних модулей и библиотек (не относящихся к 1С и Excel).

23.11.2015    16771    0    etmarket    14    

Универсальный способ сравнения таблиц

Практика программирования v7.7 v8 Бесплатно (free)

На эту тему уже есть статьи, но этот способ нигде не описан. Хотя я его использую с тех пор, как занимаюсь программированием. Его преимущество в простоте и универсальности: можно применять на 1С, SQL, а также в любом другом языке программирования.

05.07.2015    18442    0    json    1    

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция Промо

Практика программирования WEB v7.7 v8 Бесплатно (free)

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    53814    0    Serginio    33    

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    84194    0    shmellevich    38    

Отправка сообщения посредством почтового клиента Lotus Notes

Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Отправка сообщения посредством почтового клиента Lotus Notes из 1С 7,7 и 1с 8

21.08.2014    14159    0    iolko    8    

Полезные функции. Склонение (должность и фамилия подписантов). Любой язык

Практика программирования v7.7 v8 Бесплатно (free)

Уехал директор в командировку, отпуск... , оставил доверенность на хозяйственные операции на другого сотрудника. Все договора и другие документы в обмороке - "подписант" теперь другой, по тексту тоже много правок... Пересмотрел много публикаций, вариантов много, не приглянулось. Сделал свой "Баян" . У меня всего-то крутится пять фигурантов ... Нет простого, наглядного и всепогодного варианта без языкового барьера. Всем процессом управляет пользователь.

03.03.2014    17395    0    kompas-dm    5    

Конвертация данных 2.1 (2.1.3.1) 1С 7.7 - 1С 8.Х передача параметра ПКО

Практика программирования Перенос данных из 1С7.7 в 1C8.X v7.7 v8 КД Бесплатно (free)

Передача параметров по умолчанию доступна только для баз 1С 8.х -1С 8.х. Показан пример, как передать параметры из 1С 7.7 - 1С 8.х

10.12.2012    24630    0    serg_gres    6    

Как избежать авансовых счет-фактур в рамках одного дня

Пользователю системы Бухгалтерский учет Оптовая торговля Оптовая торговля v7.7 v8 1cv8.cf 1cv7.md НУ НДС Бесплатно (free)

Способ устранения появления авансовых счетов фактур при получении выручки ранее проведения документа реализации в рамках одного дня.

30.11.2012    8597    0    bananoed    3    

[Генератор внешних событий] Внешняя компонента для 1С

Практика программирования Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента генерирует внешние события с заданным интервалом и с заданными значениями.

06.03.2009    36672    0    Душелов    81    

[Мониторинг изменения файлов] - ActiveX-компонента для 1С 8.х + ВК для 7.7

Практика программирования Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента следит за изменениями файлов в заданных каталогах, без таймеров и опросов файловой системы. Использует события Windows.

05.03.2009    23167    0    Душелов    53    

[Проверка правописания] - ActiveX-компонента для 1С

Практика программирования Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Компонента проверяет правописание текста. Основана на технологии OpenOffice MySpell. Не требует установленного офиса. В комплекте словари для 5 языков, включая русский (с "ё").

09.02.2009    27438    0    Душелов    66    

Создание документа Word 2007

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Создание документа Word 2007 без установленного Word'а, без внешних компонент, исключительно средствами 1С

09.08.2008    37893    0    Душелов    43    

Объединение справочников и перенос остатков номенклатуры из нескольких баз 1С 7.7 в 1 базу УПП 8.1

Перенос данных из 1С7.7 в 1C8.X Практика программирования v7.7 v8 1cv7.md УПП1 Россия Бесплатно (free)

Объединение справочников и перенос остатков номенклатуры из нескольких баз 1С 7.7 в 1 базу УПП 8.1

11.12.2007    12087    0    danser    3