Как преобразовать Unicode в 1С

Публикация № 142092

Разработка - Практика программирования

21
Ох уж эти вечные проблемы с кодировкой…
Долго искал в инете как преобразователь Unicod. Потом все таки сам написал функцию.

Синтаксис:
ПереобразоватьЮникод()

Параметры:
(обязательный)
Тип: Строка.
Исходная строка.

Возвращаемое значение:
Тип: Строка.
Строка обработанных символов.

Описание:
Возвращает преобразованную строку из формата Unicod.

Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.

 

Функция ПереобразоватьЮникод(Строка)

    
    ГотововаяСтрока = "" ;
    
    МасУкр = Новый Массив(66) ;
    
    МасУкр[0]="А";   МасУкр[1]="Б";  МасУкр[2]="В";  МасУкр[3]="Г";  МасУкр[4]="Ґ";  МасУкр[5]="Д";
    МасУкр[6]="Е";   МасУкр[7]="Є";  МасУкр[8]="Ж";  МасУкр[9]="З";  МасУкр[10]="И"; МасУкр[11]="І";
    МасУкр[12]="Ї";  МасУкр[13]="Й"; МасУкр[14]="К"; МасУкр[15]="Л"; МасУкр[16]="М"; МасУкр[17]="Н";
    МасУкр[18]="О";  МасУкр[19]="П"; МасУкр[20]="Р"; МасУкр[21]="С"; МасУкр[22]="Т"; МасУкр[23]="У";
    МасУкр[24]="Ф";  МасУкр[25]="Х"; МасУкр[26]="Ц"; МасУкр[27]="Ч"; МасУкр[28]="Ш"; МасУкр[29]="Щ";
    МасУкр[30]="Ь";  МасУкр[31]="Ю"; МасУкр[32]="Я";  

    МасУкр[33]="а";  МасУкр[34]="б"; МасУкр[35]="в"; МасУкр[36]="г"; МасУкр[37]="ґ"; МасУкр[38]="д";
    МасУкр[39]="е";  МасУкр[40]="є"; МасУкр[41]="ж"; МасУкр[42]="з"; МасУкр[43]="и"; МасУкр[44]="і";
    МасУкр[45]="ї";  МасУкр[46]="й"; МасУкр[47]="к"; МасУкр[48]="л"; МасУкр[49]="м"; МасУкр[50]="н";
    МасУкр[51]="о";  МасУкр[52]="п"; МасУкр[53]="р"; МасУкр[54]="с"; МасУкр[55]="т"; МасУкр[56]="у";
    МасУкр[57]="ф";  МасУкр[58]="х"; МасУкр[59]="ц"; МасУкр[60]="ч"; МасУкр[61]="ш"; МасУкр[62]="щ";
    МасУкр[63]="ь";  МасУкр[31]="ю"; МасУкр[65]="я";  
        
    
    МасКод = Новый Массив(66) ;
    
    МасКод[0]="0410";   МасКод[1]="0411";  МасКод[2]="0412";  МасКод[3]="0413";  МасКод[4]="0490";  МасКод[5]="0414";
    МасКод[6]="0415";   МасКод[7]="0404";  МасКод[8]="0416";  МасКод[9]="0417";  МасКод[10]="0418"; МасКод[11]="0406";
    МасКод[12]="0407";  МасКод[13]="0419"; МасКод[14]="041A"; МасКод[15]="041B"; МасКод[16]="041C"; МасКод[17]="041D";
    МасКод[18]="041E";  МасКод[19]="041F"; МасКод[20]="0420"; МасКод[21]="0421"; МасКод[22]="0422"; МасКод[23]="0423";
    МасКод[24]="0424";  МасКод[25]="0425"; МасКод[26]="0426"; МасКод[27]="0427"; МасКод[28]="0428"; МасКод[29]="0429";
    МасКод[30]="042C";  МасКод[31]="042E"; МасКод[32]="042F";  

    МасКод[33]="0430";  МасКод[34]="0431"; МасКод[35]="0432"; МасКод[36]="0413"; МасКод[37]="0491"; МасКод[38]="0434";
    МасКод[39]="0435";  МасКод[40]="0454"; МасКод[41]="0436"; МасКод[42]="0437"; МасКод[43]="0438"; МасКод[44]="0456";
    МасКод[45]="0457";  МасКод[46]="0439"; МасКод[47]="043A"; МасКод[48]="043B"; МасКод[49]="043C"; МасКод[50]="043D";
    МасКод[51]="043E";  МасКод[52]="043F"; МасКод[53]="0440"; МасКод[54]="0441"; МасКод[55]="0442"; МасКод[56]="0443";
    МасКод[57]="0444";  МасКод[58]="0445"; МасКод[59]="0446"; МасКод[60]="0447"; МасКод[61]="0448"; МасКод[62]="0449";
    МасКод[63]="044C";  МасКод[31]="044E"; МасКод[65]="044F";  
    
    
    тмпСтрока = "" ;
    Для Счетчик = 1 По СтрДлина(Строка) Цикл      
        Если Лев(Строка, 1) = "\" Тогда
            Если Лев(Строка, 2) = "\u" Тогда
                
                тмпСтрока = Прав(Лев(Строка, 6),4) ;
                Если МасКод.Найти(тмпСтрока) = Неопределено Тогда
                    СтрокаЗамены = Прав(тмпСтрока, 1) ;
                    тмпСтрока = СтрЗаменить(тмпСтрока,СтрокаЗамены,ТРег(СтрокаЗамены)); 
                    Если МасКод.Найти(тмпСтрока) = Неопределено Тогда
                        Сообщить("Код символа не найден: " + тмпСтрока) ;
                    Иначе                      
                        ГотововаяСтрока = ГотововаяСтрока + МасУкр[МасКод.Найти(тмпСтрока)] ;                                   
                    КонецЕсли;
                Иначе
                    ГотововаяСтрока = ГотововаяСтрока + МасУкр[МасКод.Найти(тмпСтрока)] ;               
                КонецЕсли;
                
                Строка = Прав(Строка, (СтрДлина(Строка)-6)) ; 
            Иначе  
                Строка = Прав(Строка, (СтрДлина(Строка)-2)) ;
            КонецЕсли;
        Иначе
            ГотововаяСтрока = ГотововаяСтрока + Лев(Строка, 1) ;
            Строка = Прав(Строка, (СтрДлина(Строка)-1)) ;     
        КонецЕсли;         
    КонецЦикла;   

    Возврат ГотововаяСтрока ;
        
КонецФункции

 

21

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
0. treedo 115 03.07.12 10:11 Сейчас в теме
Ох уж эти вечные проблемы с кодировкой…
Долго искал в инете как преобразователь Unicod. Потом все таки сам написал функцию.



Перейти к публикации

1. Serj1C 477 03.07.12 12:51 Сейчас в теме
А можно было так?
Записать текстовый документ в кодировке Юникод, а потом его прочитать в кодировке Анси?
2. treedo 115 03.07.12 13:49 Сейчас в теме
3. treedo 115 03.07.12 13:54 Сейчас в теме
Способ называеццо: "Против лома, нет ..."
4. alexk-is 6425 03.07.12 16:37 Сейчас в теме
Мне кажется, что следующий код будет работать побыстрее
КлючИЗначение = Соответствие.Получить(тмпСтрока);
Если КлючИЗначение = Неопределено Тогда
    ....
Иначе
    ГотововаяСтрока = ГотововаяСтрока + КлючИЗначение.Значение;               
КонецЕсли;
5. treedo 115 03.07.12 19:58 Сейчас в теме
6. alexk-is 6425 03.07.12 20:42 Сейчас в теме
(5) А здесь написано, что точно будет быстрее. :)
7. slavik27 10 27.06.13 08:23 Сейчас в теме
спасибо, хороший пример, только жалко с русскими символами нет
8. tolick 32 10.11.15 13:24 Сейчас в теме
9. 314r 16.02.16 14:40 Сейчас в теме
Вот вариант с русскими буквами. Вдруг кому-то понадобиться :)

Функция ПреобразоватьЮникод(Строка)
    
    МасКир = Новый Массив(66);
	МасКод = Новый Массив(66);
   
МасКир[0]="А";	МасКод[0]="0410";
МасКир[1]="а";	МасКод[1]="0430";
МасКир[2]="Б";	МасКод[2]="0411";
МасКир[3]="б";	МасКод[3]="0431";
МасКир[4]="В";	МасКод[4]="0412";
МасКир[5]="в";	МасКод[5]="0432";
МасКир[6]="Г";	МасКод[6]="0413";
МасКир[7]="г";	МасКод[7]="0433";
МасКир[8]="Д";	МасКод[8]="0414";
МасКир[9]="д";	МасКод[9]="0434";
МасКир[10]="Е";	МасКод[10]="0415";
МасКир[11]="е";	МасКод[11]="0435";
МасКир[12]="Ё";	МасКод[12]="0401";
МасКир[13]="ё";	МасКод[13]="0451";
МасКир[14]="Ж";	МасКод[14]="0416";
МасКир[15]="ж";	МасКод[15]="0436";
МасКир[16]="З";	МасКод[16]="0417";
МасКир[17]="з";	МасКод[17]="0437";
МасКир[18]="И";	МасКод[18]="0418";
МасКир[19]="и";	МасКод[19]="0438";
МасКир[20]="Й";	МасКод[20]="0419";
МасКир[21]="й";	МасКод[21]="0439";
МасКир[22]="К";	МасКод[22]="041a";
МасКир[23]="к";	МасКод[23]="043a";
МасКир[24]="Л";	МасКод[24]="041b";
МасКир[25]="л";	МасКод[25]="043b";
МасКир[26]="М";	МасКод[26]="041c";
МасКир[27]="м";	МасКод[27]="043c";
МасКир[28]="Н";	МасКод[28]="041d";
МасКир[29]="н";	МасКод[29]="043d";
МасКир[30]="О";	МасКод[30]="041e";
МасКир[31]="о";	МасКод[31]="043e";
МасКир[32]="П";	МасКод[32]="041f";
МасКир[33]="п";	МасКод[33]="043f";
МасКир[34]="Р";	МасКод[34]="0420";
МасКир[35]="р";	МасКод[35]="0440";
МасКир[36]="С";	МасКод[36]="0421";
МасКир[37]="с";	МасКод[37]="0441";
МасКир[38]="Т";	МасКод[38]="0422";
МасКир[39]="т";	МасКод[39]="0442";
МасКир[40]="У";	МасКод[40]="0423";
МасКир[41]="у";	МасКод[41]="0443";
МасКир[42]="Ф";	МасКод[42]="0424";
МасКир[43]="ф";	МасКод[43]="0444";
МасКир[44]="Х";	МасКод[44]="0425";
МасКир[45]="х";	МасКод[45]="0445";
МасКир[46]="Ц";	МасКод[46]="0426";
МасКир[47]="ц";	МасКод[47]="0446";
МасКир[48]="Ч";	МасКод[48]="0427";
МасКир[49]="ч";	МасКод[49]="0447";
МасКир[50]="Ш";	МасКод[50]="0428";
МасКир[51]="ш";	МасКод[51]="0448";
МасКир[52]="Щ";	МасКод[52]="0429";
МасКир[53]="щ";	МасКод[53]="0449";
МасКир[54]="Ъ";	МасКод[54]="042a";
МасКир[55]="ъ";	МасКод[55]="044a";
МасКир[56]="Ы";	МасКод[56]="042b";
МасКир[57]="ы";	МасКод[57]="044b";
МасКир[58]="Ь";	МасКод[58]="042c";
МасКир[59]="ь";	МасКод[59]="044c";
МасКир[60]="Э";	МасКод[60]="042d";
МасКир[61]="э";	МасКод[61]="044d";
МасКир[62]="Ю";	МасКод[62]="042e";
МасКир[63]="ю";	МасКод[63]="044e";
МасКир[64]="Я";	МасКод[64]="042f";
МасКир[65]="я";	МасКод[65]="044f";

	ParsedString = Строка;
	Flag = 1;
	
	Пока (Flag = 1) Цикл
		
	PositionOfUnicodeStart = Найти(ParsedString, "\u");
		
	
		Если PositionOfUnicodeStart > 0 тогда
		UnicodeSymbol = Сред(ParsedString, PositionOfUnicodeStart +2, 4);	
		
		FullUnicodeSymbol = "\u" + UnicodeSymbol;
		
		Index = МасКод.Найти(UnicodeSymbol);
			Если Index = Неопределено тогда
			ParsedString = СтрЗаменить(ParsedString, FullUnicodeSymbol, "?UNICODE?");
			Сообщить("Найден неизвестный символ - " + FullUnicodeSymbol); 
			Иначе
			ParsedString = СтрЗаменить(ParsedString, FullUnicodeSymbol, МасКир[Index]);
			КонецЕсли;
				
		Иначе 
		Flag = 0;
		
		КонецЕсли;
					
	КонецЦикла;
	
	Возврат ParsedString;	
КонецФункции
Показать
AKZARD; PASAHAKA; AskezaMax; itc_Geo; +4 Ответить
12. sevenlis 64 02.03.19 09:15 Сейчас в теме
(9)
А вот то же самое, только через ТЗ и для 7.7
Функция ПреобразоватьИзЮникод(пСтрока) Экспорт
	тзСимв = СоздатьОбъект("ТаблицаЗначений");
	тзСимв.НоваяКолонка("Кир","Строка",1);
	тзСимв.НоваяКолонка("Код","Строка",4);
	
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "А"; 	тзСимв.Код = "0410";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "а"; 	тзСимв.Код = "0430";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Б"; 	тзСимв.Код = "0411";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "б"; 	тзСимв.Код = "0431";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "В"; 	тзСимв.Код = "0412";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "в"; 	тзСимв.Код = "0432";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Г"; 	тзСимв.Код = "0413";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "г"; 	тзСимв.Код = "0433";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Д"; 	тзСимв.Код = "0414";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "д"; 	тзСимв.Код = "0434";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Е"; 	тзСимв.Код = "0415";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "е"; 	тзСимв.Код = "0435";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ё"; 	тзСимв.Код = "0401";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ё"; 	тзСимв.Код = "0451";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ж"; 	тзСимв.Код = "0416";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ж"; 	тзСимв.Код = "0436";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "З"; 	тзСимв.Код = "0417";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "з"; 	тзСимв.Код = "0437";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "И"; 	тзСимв.Код = "0418";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "и"; 	тзСимв.Код = "0438";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Й"; 	тзСимв.Код = "0419";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "й"; 	тзСимв.Код = "0439";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "К"; 	тзСимв.Код = "041a";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "к"; 	тзСимв.Код = "043a";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Л"; 	тзСимв.Код = "041b";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "л"; 	тзСимв.Код = "043b";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "М"; 	тзСимв.Код = "041c";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "м"; 	тзСимв.Код = "043c";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Н"; 	тзСимв.Код = "041d";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "н"; 	тзСимв.Код = "043d";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "О"; 	тзСимв.Код = "041e";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "о"; 	тзСимв.Код = "043e";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "П"; 	тзСимв.Код = "041f";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "п"; 	тзСимв.Код = "043f";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Р"; 	тзСимв.Код = "0420";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "р"; 	тзСимв.Код = "0440";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "С"; 	тзСимв.Код = "0421";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "с"; 	тзСимв.Код = "0441";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Т"; 	тзСимв.Код = "0422";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "т"; 	тзСимв.Код = "0442";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "У"; 	тзСимв.Код = "0423";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "у"; 	тзСимв.Код = "0443";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ф"; 	тзСимв.Код = "0424";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ф"; 	тзСимв.Код = "0444";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Х"; 	тзСимв.Код = "0425";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "х"; 	тзСимв.Код = "0445";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ц"; 	тзСимв.Код = "0426";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ц"; 	тзСимв.Код = "0446";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ч"; 	тзСимв.Код = "0427";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ч"; 	тзСимв.Код = "0447";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ш"; 	тзСимв.Код = "0428";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ш"; 	тзСимв.Код = "0448";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Щ"; 	тзСимв.Код = "0429";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "щ"; 	тзСимв.Код = "0449";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ъ"; 	тзСимв.Код = "042a";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ъ"; 	тзСимв.Код = "044a";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ы"; 	тзСимв.Код = "042b";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ы"; 	тзСимв.Код = "044b";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ь"; 	тзСимв.Код = "042c";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ь"; 	тзСимв.Код = "044c";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Э"; 	тзСимв.Код = "042d";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "э"; 	тзСимв.Код = "044d";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Ю"; 	тзСимв.Код = "042e";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "ю"; 	тзСимв.Код = "044e";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "Я"; 	тзСимв.Код = "042f";
	тзСимв.НоваяСтрока();
	тзСимв.Кир = "я"; 	тзСимв.Код = "044f";
	
	ParsedString = пСтрока;
	
	PositionOfUnicodeStart = Найти(ParsedString, "\u");
	Пока PositionOfUnicodeStart > 0 Цикл
		UnicodeSymbol 			= Сред(ParsedString, PositionOfUnicodeStart + 2, 4);    
		FullUnicodeSymbol 		= "\u" + UnicodeSymbol;
		
		Index = 0; тзСимв.НайтиЗначение(UnicodeSymbol,Index,"Код");
		Если Index = 0 Тогда
			ParsedString = СтрЗаменить(ParsedString, FullUnicodeSymbol, "?");
			Сообщить("Найден неизвестный символ - " + FullUnicodeSymbol); 
		Иначе
			ParsedString = СтрЗаменить(ParsedString, FullUnicodeSymbol, тзСимв.ПолучитьЗначение(Index,"Кир"));
		КонецЕсли;
		
		PositionOfUnicodeStart 	= Найти(ParsedString, "\u");
	КонецЦикла;
	
	Возврат ParsedString;    
КонецФункции

Показать
10. Buben-128 12.09.16 11:26 Сейчас в теме
Во народ жжот ))))
Удаление зубов через противоположный проход - это круто (наверно)!

Если "напрямую", можно так:

//Пример строки с юникодом
//{"NAME":"\u0421\u043a\u0438\u0434\u043a\u0430 \u043e\u0442 \u043c\u0435\u043d\u0435\u0434\u0436\u0435\u0440\u0430 \u041f\u041f - 5%","COUPON":"SL-4IFEJ-S4LCPZB"}

	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(StrJason);
	Пока ЧтениеJSON.Прочитать() Цикл
		Попытка
			Сообщить("Параметр "+ЧтениеJSON.ТекущееЗначение); 
		Исключение			
		КонецПопытки	
	КонецЦикла;
Показать
Alien_job; zadevil; +2 Ответить
11. treedo 115 12.09.16 12:01 Сейчас в теме
(10) Buben-128, Статья писалась когда в платформе не было полноценной реализации JSON. Если ваш код рабочий, он намного эффективней и проще.
13. Alien_job 165 24.06.19 13:56 Сейчас в теме
Оставьте свое сообщение

См. также

Полезные процедуры и функции для программиста 141

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    9118    HostHost    23       

Агрегатные функции СКД, о которых мало кто знает 343

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    13232    ids79    44       

Три костыля. Сказ про фокусы в коде 123

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    9332    YPermitin    68       

Отслеживание выполнения фонового задания 141

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    10697    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 254

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    14358    ids79    30       

Фоновое выполнение кода в 1С - это просто 120

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    11520    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 131

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    13003    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 148

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    11393    ids79    27       

Регистры сведений. За кулисами 129

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    8927    YPermitin    12       

"Меньше копипаста!", или как Вася универсальную процедуру писал 183

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    8143    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы 209

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    21242    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 179

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    12790    dmurk    134       

Регистры накопления. Структура хранения в базе данных 176

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    19239    YPermitin    27       

Выполнение внешней обработки в фоновом задании 149

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    11422    Eret1k    23       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    6253    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    8898    m-rv    16       

О расширениях замолвите слово... 193

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    17925    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 202

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    14085    ellavs    83       

Трюки с внешними источниками данных 166

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    14443    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 166

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    17468    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    13906    ids79    27       

Новый подход к обмену данными EnterpriseData 207

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    23300    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 119

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    20494    ids79    20       

Программное заполнение пользовательских параметров и отборов СКД 136

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    22311    Unk92    19       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 127

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    22394    ids79    40       

Вспомогательные инструкции в коде 1С 106

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    21594    tormozit    100       

Произвольный код в фоновом режиме 165

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    15852    nikita0832    42       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 147

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    23030    Rain88    42       

Повышаем эффективность разработки правил обмена 124

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    20326    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 156

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    25712    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    22281    m-rv    21       

Строим графы средствами 1С (без GraphViz) 43

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    18081    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    12133    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 129

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    26659    avfed@rambler.ru    19       

Минимализмы 3 356

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    37243    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    26633    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    22066    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 737

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    143042    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    23850    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 67

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    22158    unichkin    18       

Разбираемся с настройками компоновки данных 161

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    25241    json    9       

Работа с Excel 298

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    27258    arakelyan    39