Клиентское приложение (Толстый клиент) для сервиса изучения методов платформы 1С:Предприятие 8 (+ конструктор запросов)

Публикация № 192076

Разработка - Практика программирования

Клиентское приложение для работы с веб-сервисом
IT-Решение: Консоль изучения методов платформы 1С:Предприятие 8
в режиме толстый клиент.
Подготовка к аттестации 1С:Специалист on-line!
Тестовые задания по различным видам учета!
Подсказки для оптимального решения!

Уважаемые коллеги!

Представляем вашему вниманию клиентское приложение для бесплатного веб-сервиса "Консоль изучения методов платформы 1С:Предприятие 8" - конфигурацию, разработанную на платформе 8.2 и предназначенную для интерактивного обучения методам и приемам разработки в среде 1С.

Страница сервиса на infostart.ru: //develop.iservice.ru/public/192077/ 


Работа с веб-сервисом возможна с использованием конструктора запросов 1С (аналогично Клиентскому приложению для самоучителя языка запросов 1С 8).

При входе в конфигурацию произоводится аутентификация на веб-сервисе под логином пользователя.

Для регистрации нового пользователя на веб-сервисе необходимо использовать логин: guest, пароль пустой.

Информацию о составе учебной конфигурации, ее объектах и их взаимосвязях можно посмотреть на "Схеме базы данных" (кнопка в левом верхнем углу консоли).

Решение задачи пользователь представляет в поле "Ваше решение". В процессе решения задач для написания запросов может быть использован Конструктор запросов. В поле "Результат" отображается результат проверки решения задачи. Так же в форме основной обработки представлена персональная статистика и общий рейтинг участников (ТОП 100). Все задачи должны решатся последовательно. Переход к следующей задаче, не решив предыдущую, невозможен.

 

Важно! 
Для получения навыков написания простых и сложных запросов рекомендуем воспользоваться бесплатным сервисом Консоль изучения языка запросов 1С:Предприятие 8).

 

Скачать файлы

Наименование Файл Версия Размер
Дистрибутив поставки

.exe 422,36Kb
02.07.13
189
.exe 422,36Kb 189 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. bpc222 2217 27.06.13 18:40 Сейчас в теме
Уважаемые разработчики.

Начал работу новый сервис: Консоль изучения методов платформы 1С:Предприятие 8.
Месяц будет "крутиться" в тестовом режиме, ваши решения будут сохранены.
Задания второго раздела будут опубликованы на днях.
Это клиентское приложение - клиент для сервиса. Его задача - предоставить Вам возможность использования Консоли запросов для разработки прикладных решений.

Ждем Ваших отзывов и предложений. Спасибо.
2. ivanov660 2333 28.06.13 09:01 Сейчас в теме
А что в веб варианте не сделали консоль запросов? Взяли хот-бы Больсунова. Не удобно онлайн сервисом пользоваться, по крайней мере подсказки какие-нибудь выдали?
3. bpc222 2217 28.06.13 09:16 Сейчас в теме
(2) ivanov660,

рассмотрим возможность, спасибо.
4. Egor.ZenNoches 28.06.13 14:55 Сейчас в теме
5. kuza_87 26 01.07.13 08:29 Сейчас в теме
Дошел до 6-го задания. Пишет что неверное решение. Не могу понять где ошибка. Выполнено всё верно
Вот код
ЗапросЦены = Новый Запрос;
ЗапросЦены.Текст =
"ВЫБРАТЬ
| ЦеныНоменклатуры.Номенклатура,
| ЦеныНоменклатуры.Цена,
| ЦеныНоменклатуры.Период КАК Период
|ИЗ
| РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры
|
|УПОРЯДОЧИТЬ ПО
| Период УБЫВ";
ТЗЦены = ЗапросЦены.Выполнить().Выгрузить();

ВыборкаДоков = Документы.Приходнаянакладная.Выбрать();
Пока ВыборкаДоков.Следующий() цикл
Если ВыборкаДоков.Ссылка.Проведен = Ложь Тогда
Док = ВыборкаДоков.Ссылка.ПолучитьОбъект();
НаборЗаписей = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(Док.Ссылка);
НаборЗаписей.Прочитать();
Для Каждого строка из Док.Товары Цикл
НайденнаяСтрока = ТЗЦены.Найти(строка.Номенклатура, "Номенклатура");
Если НайденнаяСтрока = Неопределено Тогда
Движение = НаборЗаписей.Добавить();
Движение.Период = Док.Дата;
Движение.Номенклатура = Строка.Номенклатура;
Движение.Цена = строка.Цена;
ИначеЕсли НайденнаяСтрока<>Неопределено и
НайденнаяСтрока.Цена<>Строка.Цена Тогда
Движение = НаборЗаписей.Добавить();
Если КонецДня(НайденнаяСтрока.Период) = КонецДня(Док.Дата) Тогда
Движение.Период = КонецДня(Док.Дата)+1;
Иначе
Движение.Период = Док.Дата;
КонецЕсли;
Движение.Номенклатура = Строка.Номенклатура;
Движение.Цена = строка.Цена;

КонецЕсли;

КонецЦикла;
НаборЗаписей.Записать();

КонецЕсли;

КонецЦикла;
7. bpc222 2217 01.07.13 09:54 Сейчас в теме
(5) kuza_87,


Одно из условий задания: "Следует учесть, что записывать в регистр нужно лишь изменившиеся на дату документа цены, учитывая периодичность регистра "В пределах дня"

Скажите, Ваше решение удовлетворяет этому условию?
6. kuza_87 26 01.07.13 08:30 Сейчас в теме
Я нигде не усмотрел ошибку
8. kuza_87 26 01.07.13 11:11 Сейчас в теме
Разобрался, извините. Делал спросони)))
11. bpc222 2217 01.07.13 12:55 Сейчас в теме
(8) kuza_87,

Отлично.
не нужно извиняться.
Консоль для этого и предназначена - научиться решать прикладные задачи различного уровня.
9. kuza_87 26 01.07.13 11:39 Сейчас в теме
А в следующем задании что не так? Задание элементарное. Вот текст кода

ВыборкаДоков = Документы.ПриходнаяНакладная.Выбрать();
Пока ВыборкаДоков.Следующий() Цикл
Если ВыборкаДоков.Проведен = Истина Тогда
Док = ВыборкаДоков.ПолучитьОбъект();
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПриходнаяНакладнаяТовары.Номенклатура,
| ПриходнаяНакладнаяТовары.Ссылка КАК Партия,
| ПриходнаяНакладнаяТовары.Количество,
| ПриходнаяНакладнаяТовары.Сумма,
| ПриходнаяНакладнаяТовары.Ссылка.Дата КАК Период
|ИЗ
| Документ.ПриходнаяНакладная.Товары КАК ПриходнаяНакладнаяТовары
|ГДЕ
| ПриходнаяНакладнаяТовары.Ссылка = &Ссылка";

Запрос.УстановитьПараметр("Ссылка", Док.Ссылка);
Результат = Запрос.Выполнить().Выгрузить();

НаборЗаписей = РегистрыНакопления.ОстаткиНоменклатуры.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(Док.Ссылка);
НаборЗаписей.Прочитать();
НаборЗаписей.Загрузить(Результат);

КонецЕсли;
Конеццикла;
12. bpc222 2217 01.07.13 12:58 Сейчас в теме
(9) kuza_87,

1. А где у Вас запись набора?
2. Решите задачу так, как считаете нужным, а затем посмотрите что можно предпринять, чтобы исключить запросы в цикле.
10. kuza_87 26 01.07.13 11:52 Сейчас в теме
13. bpc222 2217 01.07.13 13:02 Сейчас в теме
(10) kuza_87,


и еще... Если Вам все нравится в нашем сервисе, ставьте лайки.
Это очень нам поможет в продвижении публикаций.

Лайкнуть:
- сервис изучения методов платформы: http://infostart.ru/public/192077/?rate=1
- сервис изучения языка запросов 1С: http://infostart.ru/public/184350/?rate=1
- консоль сервиса изучения методов: http://infostart.ru/public/192076/?rate=1
- консоль сервиса изучения запросов: http://infostart.ru/public/188639/?rate=1

Спасибо.
14. kuza_87 26 01.07.13 13:12 Сейчас в теме
Метод "Загрузить" насколько я знаю записывает данные в регистр, т.е потом не нужно писать "Записать"
17. bpc222 2217 01.07.13 13:22 Сейчас в теме
(14) kuza_87,

проверьте это утверждение, а то у меня возникает желание пойти и сжечь все свои сертификаты 1С:Специалист и закусить все это 1С:Экспертом.
15. kuza_87 26 01.07.13 13:13 Сейчас в теме
Так тоже говорит что неверно (лайкну все статьи сегодня)


ВыборкаДоков = Документы.ПриходнаяНакладная.Выбрать();
Пока ВыборкаДоков.Следующий() Цикл
Если ВыборкаДоков.Проведен = Истина Тогда
Док = ВыборкаДоков.ПолучитьОбъект();
НаборЗаписей = РегистрыНакопления.ОстаткиНоменклатуры.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(Док.Ссылка);
НаборЗаписей.Прочитать();

Для Каждого Строка из Док.Товары Цикл

Движение = НаборЗаписей.Добавить();
Движение.период = Док.Дата;
Движение.Партия = Док.Ссылка;
Движение.Номенклатура = Строка.Номенклатура;
Движение.Количество = Строка.Количество;
Движение.Сумма = Строка.Сумма;
КонецЦикла;



НаборЗаписей.Записать();

КонецЕсли;
Конеццикла;
16. bpc222 2217 01.07.13 13:21 Сейчас в теме
(15) kuza_87,

Измерение склад тоже нужно заполнять. Пользуйтесь схемой данных (кнопка сверху слева).
18. kuza_87 26 01.07.13 13:31 Сейчас в теме
я тоже про склад думал. просто в вашей конфигурации у этого документа нету склада
20. bpc222 2217 01.07.13 14:07 Сейчас в теме
(18) kuza_87,


спасибо, исправим.
19. kuza_87 26 01.07.13 13:35 Сейчас в теме
да, проблема была в складе
21. kuza_87 26 02.07.13 11:19 Сейчас в теме
8-е задание пишет что неверно.

ВыборкаДоков = Документы.ПриходнаяНакладная.Выбрать();
Пока ВыборкаДоков.Следующий() Цикл
Если ВыборкаДоков.Проведен Тогда
Док = ВыборкаДоков.Ссылка.ПолучитьОбъект();
НаборЗаписей = РегистрыНакопления.ОстаткиНоменклатуры.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(Док.Ссылка);
НаборЗаписей.Прочитать();

Для Каждого Строка из Док.Товары Цикл
Строка.ЕдиницаИзмерения = Строка.Номенклатура.ОсновнаяЕдиницаизмерения;
Строка.Сумма = Строка.Количество*Строка.Цена;
КонецЦикла;
Док.Записать();
Для Каждого Строка из Док.Товары Цикл
Движение = НаборЗаписей.Добавить();
Движение.Период = Док.Дата;
Движение.Партия = Док.Ссылка;
Движение.Склад = Док.Склад;
Движение.Номенклатура = строка.Номенклатура;
Движение.Количество = (Строка.Количество*Строка.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент);
Движение.Сумма = Строка.Сумма;
КонецЦикла;
НаборЗаписей.Записать();

КонецЕсли;


КонецЦикла;
22. echo77 1176 02.07.13 13:40 Сейчас в теме
В толстом клиенте не работает Сообщить() - это неудобно, т.к. других способов отладки результата нет.
В веб-клиенте Сообщить() работает.

Почему требуется расширение для работы с файлами при нажатии на гиперссылки в правой части окна программы?
23. adapter 550 04.09.13 17:34 Сейчас в теме
Идея хороша, но вот реализация..... Скачал толстого клиента а там только cf. А почему нет базы с данными? заполненными спр, регистрами сведений? Хотел дать практиканту потренироваться, а в таком виде теперь вряд ли. Надо бы добавить данные и кнопку "выполнить запрос" чтобы сначала хотя бы посмотреть что выдается а потом уже жать "проверить"
25. bpc222 2217 05.09.13 05:16 Сейчас в теме
(23) adapter,

Даже не знаю, что Вам ответить.
26. adapter 550 05.09.13 09:42 Сейчас в теме
(25) промахнулся с публикацией, камент относился к "самоучитель языка запросов", очень они похожи, даже файлы для скачивания одинаково называются

вот повторил там http://infostart.ru/public/184350/#comm

хотя сейчас посмотрел "изучении методов платформы" та же проблема - только cf без данных. почему бы не заполнить справочники, регистры и раздавать dt ?
27. bpc222 2217 05.09.13 11:47 Сейчас в теме
(26) adapter,

Уважаемый, adapter. ПРОБЛЕМЫ нет. Есть описанная функциональность и представленная.

>почему бы не заполнить справочники, регистры и раздавать dt?
Извините, что вопросом на вопрос: зачем?

Вам чем текущая реализация-то не нравится? Если Вас не устраивает надпись на кнопке "Проверить", то можно ее залепить жвачкой на мониторе.
24. adapter 550 04.09.13 21:08 Сейчас в теме
28. dtripleh 05.03.15 10:54 Сейчас в теме
Не могу решить 6 задачу, уже много времени с ней бьюсь.
Вот мой код:
Запрос = Новый Запрос; 
Запрос.Текст = 
"ВЫБРАТЬ 
|	ЦеныНоменклатуры.Номенклатура, 
|	ЦеныНоменклатуры.Цена, 
|	НачалоПериода(ЦеныНоменклатуры.Период,День) КАК Период 
|ИЗ 
|	РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры 
| 
|УПОРЯДОЧИТЬ ПО 
|	Период УБЫВ"; 
Цены = Запрос.Выполнить().Выгрузить(); 

ВыборкаДоков = Документы.Приходнаянакладная.Выбрать(); 
Пока ВыборкаДоков.Следующий() цикл 
	Если НЕ ВыборкаДоков.Ссылка.Проведен Тогда 
		ДокОбъект = ВыборкаДоков.Ссылка.ПолучитьОбъект(); 
		НаборЗаписей = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей(); 
		НаборЗаписей.Отбор.Регистратор.Установить(ДокОбъект.Ссылка); 
		НаборЗаписей.Прочитать(); 
		Для Каждого СтрокаТЧ из ДокОбъект.Товары Цикл 
			НайденныеСтроки = Цены.НайтиСтроки(Новый Структура("Номенклатура, Период", СтрокаТЧ.Номенклатура, НачалоДня(ДокОбъект.Дата)));
			Если НайденныеСтроки.Количество() = 0 Тогда 
				Движение = НаборЗаписей.Добавить(); 
				Движение.Период = ДокОбъект.Дата; 
				Движение.Номенклатура = СтрокаТЧ.Номенклатура; 
				Движение.Цена = СтрокаТЧ.Цена; 
			Иначе
				НайденнаяСтрока = НайденныеСтроки[0];
				Если НайденнаяСтрока.Цена <> СтрокаТЧ.Цена Тогда 
					Движение = НаборЗаписей.Добавить();
					Движение.Период = ДокОбъект.Дата + 24*60*60; 
					Движение.Номенклатура = СтрокаТЧ.Номенклатура; 
					Движение.Цена = СтрокаТЧ.Цена;
				КонецЕсли;	
			КонецЕсли; 
		КонецЦикла; 
		НаборЗаписей.Записать();	
	КонецЕсли; 
КонецЦикла;
Показать

Подскажите пожалуйста решение
29. user592024_rzane 07.07.16 11:39 Сейчас в теме
Добрый день.

Вот такая ошибка. Подскажите как можно решить?
Прикрепленные файлы:
30. bpc222 2217 07.07.16 14:49 Сейчас в теме
(29) user592024_rzane,

Убедитесь в том, что ваше подключение к сети Интернет не ограничено
31. user592024_rzane 07.07.16 14:59 Сейчас в теме
(30) у нас прокси-сервер. Подскажите как в таком случае подключиться.
32. lenafV 16.02.17 08:36 Сейчас в теме
Не могу понять в чем проблема в решении 6 задачи....
Код прикладываю:

Запрос = Новый Запрос; 

Запрос.Текст = 
"ВЫБРАТЬ 
|	 ЦеныНоменклатурыСрезПоследних.Номенклатура, 
|    ЦеныНоменклатурыСрезПоследних.Цена, 
|    НАЧАЛОПЕРИОДА(ЦеныНоменклатурыСрезПоследних.Период, ДЕНЬ) КАК Период 
|ИЗ 
|    РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних
| 
|УПОРЯДОЧИТЬ ПО 
|    Период УБЫВ";

ТЗЦены = Запрос.Выполнить().Выгрузить(); 

ВыборкаДоков = Документы.Приходнаянакладная.Выбрать(); 

Пока ВыборкаДоков.Следующий() цикл
	
	Если НЕ ВыборкаДоков.Ссылка.Проведен Тогда
		
        ДокОбъект = ВыборкаДоков.Ссылка.ПолучитьОбъект(); 
		
        НаборЗаписей = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей(); 
        НаборЗаписей.Отбор.Регистратор.Установить(ДокОбъект.Ссылка); 
        НаборЗаписей.Прочитать();
		
		Для Каждого СтрокаТЧ из ДокОбъект.Товары Цикл 
			
            НайденныеСтроки = ТЗЦены.НайтиСтроки(Новый Структура("Номенклатура, Период", СтрокаТЧ.Номенклатура, НачалоДня(ДокОбъект.Дата)));

            Если НайденныеСтроки.Количество() = 0 Тогда 
				Движение = НаборЗаписей.Добавить(); 
				Движение.Период = ДокОбъект.Дата;
				Движение.Регистратор = ДокОбъект.Ссылка;
				Движение.Номенклатура = СтрокаТЧ.Номенклатура; 
				Движение.Цена = СтрокаТЧ.Цена;        
				
			ИначеЕсли НайденныеСтроки.Количество() > 0 Тогда
				
                НайденнаяСтрока = НайденныеСтроки[0];
				
				Если НайденнаяСтрока.Цена <> СтрокаТЧ.Цена Тогда 
                    Движение = НаборЗаписей.Добавить();
                    Движение.Период = ДокОбъект.Дата;
					Движение.Регистратор = ДокОбъект.Ссылка;
                    Движение.Номенклатура = СтрокаТЧ.Номенклатура; 
                    Движение.Цена = СтрокаТЧ.Цена;    
				КонецЕсли;  
				
			КонецЕсли;
			
		КонецЦикла;
		
        НаборЗаписей.Записать();
		
	КонецЕсли;
	
КонецЦикла;
Показать


Подскажите пожалуйста в чем моя ошибка? Спасибо!
34. imh9305 19 19.04.17 23:33 Сейчас в теме
идея хорошая. на запросах хорошо рука набивается. но почему же не доделали так же, как и самоучитель запросов?
35. bpc222 2217 25.04.17 07:24 Сейчас в теме
(34)
но почему же не доделали так же, как и самоучитель запросов?


Добрый день, не понял :)

Что значит "не доделали"? И почему "как"... это и есть клиентское приложение от самоучителя... что-то не работает у Вас?
36. imh9305 19 25.04.17 09:15 Сейчас в теме
(35)добрый день! в запросах и в скд у вас есть подсказки и решения, ну и заданий много.
37. goodron 10.01.19 12:51 Сейчас в теме
Добрый день!

если возможно, залейте "Дистрибутив поставки" на yandex.disk, а то у меня 0 (ноль) SM

Спасибо!
38. user822247 29.12.19 20:14 Сейчас в теме
Здравствуйте

подскажите пожалуйста что делать если не получается подключится к веб сервису в окошке авторизации
Ошибка - "" подключение к веб сервису не выполнено, измените настройки консоли"
39. bpc222 2217 10.01.20 10:34 Сейчас в теме
(38)
подключение к веб сервису не выполнено

Судя по ошибке, веб-сервис не был вам доступен. Возможно, по причине ограничений доступа в сети Интернет.
40. dmitry888 4 21.09.20 11:31 Сейчас в теме
пришлите пожалуйста решение этого задания:
Найдите пары моделей PC, имеющих одинаковые частота процессора и объем памяти. В результате каждая пара указывается только один раз, т.е. (i,j), но не (j,i), Порядок вывода: модель с большим номером, модель с меньшим номером, размер диска и объем памяти модели с большим номером.
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    21106    5    m-rv    88    

Интерактивная справка по объектам 1С (автономное расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Ведётся интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    6520    30    sapervodichka    33    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    25460    22    Stepa86    46    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    17900    11    RonX01    10    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    22076    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    38579    56    dsdred    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    28580    26    informa1555    26    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    30835    86    m-rv    57    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    48839    17    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    31593    11    SITR-utyos    13    

Заполняем по шаблону (по умолчанию)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    28662    19    mvxyz    17    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    27376    54    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    46856    12    swimdog    42    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    28167    71    vasvl123    9    

Макет в СКД - пример всех возможных типовых вариантов

Практика программирования Инструментарий разработчика v8 v8::СКД 1cv8.cf Абонемент ($m)

Макет СКД: наглядное представление того, что, как и куда выводится при типовых настройках.

1 стартмани

09.11.2017    22229    76    freelancer    4    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    33155    132    PLAstic    59    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    23125    21    sasha777666    63    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    52090    35    ildarovich    41    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    132177    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    31858    113    romasna    49    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    29862    127    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    22726    105    Alxby    23    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    21412    96    igel9780    22    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    26517    16    Anton64    22    

Оптимизация запросов 1С:Предприятие – от теории к практике

Практика программирования Математика и алгоритмы v8 Бесплатно (free)

Я давно отметил достаточно серьезный интерес сообщества к вопросам оптимизации и повышения производительности высоконагруженных систем. Общаясь с различными специалистами, обслуживающими малые и большие предприятия (торговые и производственные), я пришел к выводу, что вопросы повышения производительности интересны почти всем, вне зависимости от того, какую конфигурацию они обслуживают – большую или маленькую, измененную или без значительных изменений. В связи с этим я пришел к выводу, что стоит посвятить данный материал вопросам оптимизации запросов, поскольку именно запросы являются основным инструментом извлечения данных из системы.

07.10.2016    38824    bpc222    20    

Загрузка файлов на сервер с прогрессом и докачкой

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    13563    53    mrstomak    21    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    37013    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    27203    137    Stepa86    15    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    48529    36    Demanoidos    60    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    28636    77    ZhokhovM    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    58118    10    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    62500    184    rozer    65    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    59692    19    arakelyan    19