Печатаем ОнЛайн чеки из 1С в Windows и Linux, на ПК и RaspberryPI. Атол, Штрих-М. Из файлов (csv), WebAPI, FTP, Ajax.

Публикация № 872959

Администрирование - Администрирование данных 1С

В последнее время появилось множество программ, которые позволяют организовать печать кассовых чеков на ОнЛайн кассах путем выгрузки файла-задания. Но вот беда: все они заточены на работу в ОС Windows... Мы расширяем эти границы и предлагаем печать чеков на любом ФР Атол или Штрих-М в ОС Windows, Linux (Debian, Ubuntu, Mint, RedHat, CentOS), а так же на микро-ПК RaspberryPI!

Программа Кассовый сервер позволяет решить массу задач, связанных с печатью чеков на ОнЛайн кассах:

  • печать на одной кассе с нескольких рабочих мест кассиров
  • работа с несколькими ККМ, подключенными к одному ПК
  • ускорение печати чека из терминальной RDP-сессии
  • организация ультра-бюджетного кассового узла на базе RasbperryPI (не нужны лицензии Windows, Office, антивирусы и лицензии на терминальные подключения (FreeNX)). 

Программа полностью соответствует требованиям ФФД 1.0 и 1.05.
Полностью кроссплатформенная. Имеются готовые сборки для разных ОС.
Универсальное и очень простое API, которое не зависит от ОС или используемой ККМ.
 

Для облегчения изучения API имеется встроенный конструктор запросов. Вводите параметры и выбираете команду - в нижней части экрана пишется строка-команда, которая тут же исполняется на ККМ.

Программа проста в настройке оборудования. Для настройки связи с ККМ имеется конфигуратор


 

Кассовый сервер можно использовать как самостоятельное рабочее место кассира:  имеется встроенное рабочее место кассира, позволяющее пробить любой чек.

 

Касса всегда под контролем. А все операции протоколируются:

 

Так же для действующих и потенциальных клиентов действует техподдержка. Помогаем настроить ККМ, программу. Консультируем по вопросам интеграции...

Пример генерации самого простого чека 1С 7.7
 

Функция глПреобразоватьСтрокуВУТФ8(Стр) Экспорт
    Длина=СтрДлина(Стр);
    Итог="";
    Для Н=1 По Длина Цикл
        Знак=Сред(Стр,Н,1);
        Код=КодСимв(Знак);
        Если Код<128 Тогда
            Итог=Итог+Знак;
        Иначе
            Если (Код>=КодСимв("А"))И(Код<=КодСимв("п")) Тогда
                Итог=Итог+Симв(208)+Симв(144+Код-КодСимв("А"));
            ИначеЕсли (Код>=КодСимв("р"))И(Код<=КодСимв("я")) Тогда
                Итог=Итог+Симв(209)+Симв(128+Код-КодСимв("р"));
            ИначеЕсли (Знак="ё") Тогда
                Итог=Итог+Симв(209)+Симв(145);
            ИначеЕсли (Знак="Ё") Тогда
                Итог=Итог+Симв(208)+Симв(129);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    Возврат Итог;
КонецФункции

Процедура ПечатьККМ()
	Если ЧерезИП=1 Тогда
		АвтоВремяТекущее();
		Записать();
        Ф = СоздатьОбъект("Текст");  
		Если СокрЛП(Автор.login)="GlManager" Тогда
			Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("B;0;ГЛАВНЫЙ_КАССИР;"));
		Иначе
			Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("B;0;"+Автор+";"));
		КонецЕсли;
		ИтогСумма=0;
		ВыбратьСтроки();
		Пока ПолучитьСтроку() = 1 Цикл 
			Если Товар.ВидТовара=Перечисление.ВидыТоваров.Услуга Тогда
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+Товар.Наименование+";"+(Цена*100)+";"+(Количество*1000)+";6;1;0"));
			Иначе
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+Товар.Наименование+";"+(Цена*100)+";"+(Количество*1000)+";6;0;0"));
			КонецЕсли;
			ИтогСумма	= ИтогСумма + Сумма;
        КонецЦикла;
		Если СокрЛП(Контрагент.Наименование)="Клиент пластик" Тогда
			Ф.ДобавитьСтроку("tmde;0;"+(ИтогСумма*100)+";0;0;6;0;0;0");
		Иначе
			Ф.ДобавитьСтроку("tmde;"+(ИтогСумма*100)+";0;0;0;6;0;0;0");
		КонецЕсли;
		Ф.Записать("D:\KKM\check"+НомерДок+".txt");
	КонецЕсли;
КонецПроцедуры 



Пример генерации чека, с указанием ФИО кассира, разбивкой по СНО (УСНО доходы  и ЕНВД), отправкой электрочека на почту или телефон.  1С 7.7

        Ф = СоздатьОбъект("Текст");  
		ИтогСумма=0;
		ДопСумма=0;
		Флаг=0;
		ДопЧек=СоздатьОбъект("Текст");
		ДопЧек.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("B;"+?(ВидОперации = Перечисление.ВидыОперацийЧекККМ.Чек,0,1)+";"+Автор+";"));
		ВыбратьСтроки();
		Пока ПолучитьСтроку() = 1 Цикл 
			Ц=Окр(Сумма/Количество,2,1);
			//Сообщить(Сумма+","+Количество+","+Ц);
			Если Номенклатура.ВидНоменклатуры = Перечисление.ВидыНоменклатуры.Услуга Тогда
				Если Флаг=0 Тогда 
					Ф.ДобавитьСтроку("set_tlv;1055;1;2;");  // УСНО Доходы
					Флаг=2;
				ИначеЕсли Флаг=8 Тогда
					Если ДопСумма=0 Тогда ДопЧек.ДобавитьСтроку("set_tlv;1055;1;2;"); КонецЕсли;  // УСНО Доходы
					ДопЧек.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;2;"));
					ДопСумма	= ДопСумма + (Ц*Количество);
					Продолжить;
				КонецЕсли;
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;2;"));
			Иначе
				Если Флаг=0 Тогда 
					Ф.ДобавитьСтроку("set_tlv;1055;1;8;");  // ЕНВД
					Флаг=8;
				ИначеЕсли Флаг=2 Тогда
					Если ДопСумма=0 Тогда ДопЧек.ДобавитьСтроку("set_tlv;1055;1;8;"); КонецЕсли;  // ЕНВД
					ДопЧек.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;1;"));
					ДопСумма	= ДопСумма + (Ц*Количество);
					Продолжить;
				КонецЕсли;
				Ф.ДобавитьСтроку(глПреобразоватьСтрокуВУТФ8("SMDE;"+СтрЗаменить (Номенклатура.Наименование, """", "'")+";"+(Ц*100)+";"+(Количество*1000)+";6;1;"));
			КонецЕсли;
			ИтогСумма	= ИтогСумма + (Ц*Количество);
		КонецЦикла;

		Если ПустоеЗначение(Контрагент)=0 Тогда
			Д="";
			Если Контрагент.ОтправкаЧека=Перечисление.ОтправкаЧека.ТелефоныФизЛица Тогда
				Д=СокрЛП(Контрагент.ЮрФизЛицо.Телефоны);
			ИначеЕсли Контрагент.ОтправкаЧека=Перечисление.ОтправкаЧека.ЭлПочта Тогда
			    Д=СокрЛП(Контрагент.ЭлПочта);
			КонецЕсли;
		КонецЕсли;
		Если ПустоеЗначение(Д)=0 Тогда 
			Ф.ДобавитьСтроку("set_tlv;1008;5;"+Д+";");
		КонецЕсли;
		
		Если ПлатежнаяКарта=1 Тогда
			Ф.ДобавитьСтроку("tmde;0;"+(ИтогСумма*100)+";0;0;6;0;0;0;");
		Иначе
			Ф.ДобавитьСтроку("tmde;"+(Макс(Получено,ИтогСумма)*100)+";0;0;0;6;0;0;0;");
		КонецЕсли;
		Ф.Записать("C:\RndItSoft\Checks\"+НомерДок+".txt");
		
		Если ДопСумма>0 Тогда
			Если ПустоеЗначение(Д)=0 Тогда 
				ДопЧек.ДобавитьСтроку("set_tlv;1008;5;"+Д+";");
			КонецЕсли;
			
			Если ПлатежнаяКарта=1 Тогда
				ДопЧек.ДобавитьСтроку("tmde;0;"+(ДопСумма*100)+";0;0;6;0;0;0;");
			Иначе
				ДопЧек.ДобавитьСтроку("tmde;"+(Макс(Получено-ИтогСумма,ДопСумма)*100)+";0;0;0;6;0;0;0;");
			КонецЕсли;
			ДопЧек.Записать("C:\RndItSoft\Checks\"+НомерДок+"_2.txt");
			
        КонецЕсли;

Работа с Кассовым сервером из Web-приложения.  Печать чека из PHP
 

/**
 * Class Sale
 */
class Sale{

    /**
     * Печать чека
     * @param int $id id из sale
     */
    static function CheckKKM($id=0){

        $buf="B;".(isset($_REQUEST['returnsale'])?"1":"0").";".(User::comment()?User::comment():"Колесников Д.Г.").";\n";
        $add_summ=$summ=0;
        if(!($sale=DB::Select("sale",($id>0?"id=".intval($id):"user='".$_SESSION['user']['id']."' ORDER by time DESC"))) )fb_err("Нет доступной операции для печати чека!");
        // todo нельзя пробить чек на несегодняшнюю продажу
        $id=$sale['id'];
        $add_chek='';
        $flag=0;
        // $sale['visa'] - эта часть оплачена платиком, остальное наличными
        $query=DB::sql("SELECT * FROM `".self::db_prefix."sale2` WHERE sale='".$id."'");
        while(($data = DB::fetch_assoc($query))){
            $tovar=Tovar::GetTovar($data['tovar'],1); if(!$tovar)fb_err("Нет товара № ".$data['tovar']);
            if($tovar['type']==TYPE_TOVAR){
                if($flag==0){  $buf .= "set_tlv;1055;1;8;\n";  $flag=8; } // ЕНВД
                elseif($flag!=8){
                    $add_chek.= "SMDE;" .$tovar['name'].";".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;0;\n";
                    $add_summ+=$data['summ'];
                    continue;
                }
                $buf .= "SMDE;" .$tovar['name'].";".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;0;\n";
            }else{
                if($flag==0){  $buf .= "set_tlv;1055;1;2;\n"; $flag=2; } // УСНО Доходы
                elseif($flag!=2){
                    $add_chek.= "SMDE;" .$tovar['name'].";".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;1;\n";
                    $add_summ+=$data['summ'];
                    continue;
                }
                $buf .= "SMDE;Загар в солярии;".intval(($data['summ']/$data['kol'])*100).";".intval($data['kol']*1000).";6;1;\n";
            }
            $summ+=$data['summ'];
        }
        if($summ>0){
            $sale_visa=min($sale['visa'],$summ);
            $buf.="tmde;".(($summ-$sale_visa)*100).";".($sale_visa*100).";0;0;6;0;0;0;"/*.";\n"*/;
            // если сегодня это первый чек, открыть смену
            if(!DB::Select("sale","`services`&2 and time>='".date("Y-m-d")."'")){
                $buf="open_session;\n".$buf;
            }
            self::CmdKKM($buf,$id);
            DB::sql("UPDATE `" . db_prefix . "sale` SET `services`=`services`|".(isset($_REQUEST['returnsale'])?"4":"2")." WHERE id=" . $id);
            if($add_summ>0){ // второй чек по другой СНО
                $buf="B;".(isset($_REQUEST['returnsale'])?"1":"0").";".(User::comment()?User::comment():"Колесников Д.Г.").";\n".
                    "set_tlv;1055;1;".($flag==8?2:8).";\n" . $add_chek;
                $sale_visa=min($sale['visa'],$summ);
                $buf.="tmde;".(($summ-$sale_visa)*100).";".($sale_visa*100).";0;0;6;0;0;0;"/*.";\n"*/;
                self::CmdKKM($buf,$id.'_2');
            }
        }
    }


    /**
     * Отправить команду в KKM
     * @param string $format =
     *  open_session;
     *  X;
     *  Z;
     *  g; анулировать последний открытый чек
     */
    static function CmdKKM($format='x',$id='')
    {
        $format.=";\n";
        file_put_contents('C:\RndItSoft\Checks\chek'.$id.'.txt', Convert::win2utf($format));
        file_put_contents($_SERVER['DOCUMENT_ROOT'].'/log/chek.log', $format."\n\n", FILE_APPEND);
    }

}

 

Причины купить

Решение актуальных проблем с печатью чеков, в том числе из старых конфигураций и проблемных RDP-сессий.
Полное соответствие ФФД 1.0 1.05 и большей части 1.1
Возможность получить результат исполнения команды (например, фискальный признак или фискальный номер документа).
Возможность организовать работу с одной ККМ разных кассиров (даже территориально в разных офисах).
Возможность отключить печать чека (только электрочек).
 

Достоинства

Единственный кассовый сервер, работающий в разных операционных системах и предоставляющий такой широкий набор функций.

Простота интеграции и предсказуемость результата работы.

Встроенный анализатор нештатных ситуаций.

Возможность адаптации ПО под требования заказчика (отдельная опция).

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Скачать файлы

Наименование Файл Версия Размер
Руководство по установке и настройке.
.pdf 1,46Mb
23.07.18
26
.pdf 1,46Mb 26 Скачать бесплатно
Руководство программиста: описание API (FileAPI, AjaxAPI, WebAPI)
.pdf 1 003,49Kb
23.07.18
14
.pdf 1 003,49Kb 14 Скачать бесплатно
26.07.2018
5.18.07.04 0 1300 руб.

Моментальная
доставка

26.07.2018
5.18.06.20 0 1300 руб.

Моментальная
доставка

26.07.2018
5.18.07.04 0 1300 руб.

Моментальная
доставка

26.07.2018
0 500 руб.

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. capitan 1630 27.07.18 10:11 Сейчас в теме
Первый раз вижу чтобы руководство по настройке стоило стартмани
Видимо очень крутая обработка )
2. Техподдержка 27.07.18 15:27
(1)Здравствуйте. Конечно же бесплатно. Просто в соответствии с правилами добавления программ в ИнфоСтарт до момента подписания договора любое размещаемое вложение должно иметь минимальную цену в 1 стартмани.

Стоимость изменена на "Бесплатно".
3. obmanOZ 22 02.01.19 22:10 Сейчас в теме
Добрый день! Подскажите, организована ли поддержка НДС 20% на кассе Штрих онлайн?
Оставьте свое сообщение

См. также

Загрузка из Excel в 1С8 "одним нажатием": номенклатура, заказы, прайсы, УПД, ТОРГ-12, накладные, счета, цены, реализации, поступления и т.д. (УТ10-11.х, БП2-3.х, УПП1.3, ERP2.х, КА1.1-2.х, Розница1-2.х, УНФ1.х, УТП2.х, Альфа-Авто 5.х, Автосервис 1.х) Промо

Загрузка и выгрузка в Excel Обработка документов Оптовая торговля Оптовая торговля v8 v8::УФ 1cv8.cf БУ УУ Платные (руб)

Универсальная обработка для загрузки документов из Excel в 1С. Не требует указания параметров (номера колонок, номер первой строки таблицы и т.д.) и предварительной настройки. Просто выбираете файл Excel, документ 1С и нажимаете кнопку "Загрузить". Обработка сама находит таблицу в файле Excel, необходимые для загрузки данные в ней (номенклатура, количество, НДС, цена, сумма) и загружает ее в 1С. Вместе с номенклатурой может найти контрагента, номер и дату документа, штрих-коды, серии ГТД, страну и т.д. Распознает документы ЛЮБОЙ ФОРМЫ (УПД, ТОРГ-12, заказ, установку цен и т.д.). Не требует MS Office. Для поиска таблиц используются методы эвристического поиска. Загружает только то, что нужно, т.е. пропускает повторы шапки таблицы, заголовки, промежуточные итоги, подписи и т.д. Работает во всех основных конфигурациях 1С8. При покупке обработки вы получите 1 месяц бесплатной тех.поддержки.

3000 руб.

09.11.2016    102326    571    513    

Групповое создание актов сверок

Обработка документов Дебиторская и кредиторская задолженность v8 v8::БУ БП3.0 БУ Платные (руб)

Обработка предназначена для создания актов сверки и отправки их по электронной почте. Разработка велась на 1С:Предприятие 8.3 (8.3.15.1830). проверялась на Бухгалтерия предприятия 3.0 (3.0.71.83) и 3.0.76.77

1500 руб.

24.04.2020    2290    2    6    

Автоматическое формирование счетов, актов и счетов-фактур в "1С:Управление торговлей 11".

Документооборот и делопроизводство Обработка документов v8 v8::ОУ УТ11 Россия БУ УУ Платные (руб)

Автоматическое массовое создание заказов и актов в "1С:Управление торговлей 11" позволяет сократить затраты времени на ввод однотипных документов для списка контрагентов. Если у Вас список клиентов, которым Вы ежемесячно выставляете закрывающие документы (счет, акт, счет-фактура), то с помощью данного решения Вы сократите время работы во много раз. Обработка для группового создания актов в "1С:Управоение торговлей ред.11" автоматизирует процесс составляения документов и экономит Ваше ценное время.

2500 руб.

09.04.2020    1481    1    0    

Загрузчик из личного кабинета "Такском-касса" по API 1.3 в "1С:Бухгалтерию предприятия 3.0"

Обработка документов Обработка справочников Кассовые операции Розничная торговля WEB v8 v8::БУ БП3.0 Россия БУ Платные (руб)

Расширение для загрузки информации о кассовых сменах из личного кабинета «Такском-касса». Автозагрузка: смены, чеки, проданная номенклатура. Автоматическое создание документов «Отчет о розничных продажах», «Поступление наличных», «Операция по платежной карте».

7000 руб.

17.03.2020    2578    2    6    

Загрузка документов поступления в 1С из Контур.Диадок

Обработка документов Внешние источники данных v8::БУ БП3.0 Россия БУ Платные (руб)

Кто получает документы через Контур.ДиаДок и набивает их вручную в 1С, тот наверняка хотел бы автоматизировать этот процесс. Поддержка конфигураций: Бухгалтерии 3, Управление производственным предприятием, редакция 1.3, 1С:Комплексная автоматизация 2

2500 руб.

11.02.2020    5489    22    57    

QKkmServer - Печать 54-ФЗ чеков без проблем! Менеджмент касс. Мониторинг ФН. Все теги ФФД, в том числе маркировка и честный знак (1162)

ККМ Россия Платные (руб)

QKkmServer - это облачная очередь печати чеков в соответствии с 54-ФЗ. Кассовый модуль может быть установлен на любой ОС: Windows / Linux / RaspberryPI и управлять любой онлайн-кассой из семейства АТОЛ, Штрих-М, РР Электро, PayOnline, Казначей и т.п.. Система автоматически отслеживает технические показатели ККМ, ведёт статистику печати документов, уведомляет администратора системы о неполадках. Для управления очередью предоставляется удобный RestAPI с заданиями в JSON. Можно использовать одну ККМ для обслуживания нескольких баз / магазинов одного юрлица. Так же наше решение позволит забыть о проблеме медленной печати из терминального режима RDP-сессий. Можно полностью отключить печать как чеков так и отчетов (в том числе и для АТОЛа!) - прекрасный вариант для интернет-магазинов, когда все чеки -- электронные.

2000 руб.

26.11.2019    3510    0    7    

Удаление организаций из информационных баз 1С

Чистка базы v8 v8::УФ 1cv8.cf Россия Платные (руб)

Обработка предназначена для удаления организаций из любых информационных баз 1С, имеющих в своем составе справочник "Организации". Работает на обычных и управляемых формах, на базах любого формата и размера. Обработка проверялась на следующих типовых релизах 1С: БП 2.0.66.84, БП 3.0.71.77, БГУ 1.0.59.3, БГУ 2.0.65.17, УТ 10.3.55.3, УТ 11.4.10.57, ЗУП 3.1.11.106, ЗГУ 3.1.11.106, КА 2.4.9.98, УПП 1.3.126.1, УНФ 1.6.18.168, но должна работать и на более старых, так как обработке нужен только справочник "Организации".

3000 руб.

20.11.2019    3214    5    10    

Видеокурс "Администратор 1С" v: 2.2 Промо

Администрирование данных 1С Платные (руб)

Вход в профессию Администратор 1С - с зарплатой от 60 000 рублей! Вы станете настоящим техническим специалистом по IT инфраструктуре 1С Предприятия, научитесь правильно устанавливать, настраивать обслуживать 1С Предприятие и все сопутствующее программное обеспечение.

3200 руб.

03.04.2017    40443    124    22    

Множественный поиск текста в обработках и конфигурациях

Поиск данных Россия Платные (руб)

Приложение быстро ищет сразу несколько слов и показывает, в каком контексте они используются, без установленной 1С.

1000 руб.

13.11.2019    2395    0    3    

Загрузка картинок/изображений в номенклатуру УТ 11 (Управление торговлей 11), Розница 2.2 по артикулам.

Обработка справочников v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика Россия Платные (руб)

Загрузка картинок/изображений в номенклатуру конфигурации Управление торговлей 11 (УТ 11), Розница 2.2 по артикулам. Способ хранения как в томе. так и в базе. Можно загружать по несколько картинок в одну карточку. Возможно игнорировать дефисы в артикулах при сопоставлении файлов с номенклатурой. Есть вспомогательная команда для удаления лишних пробелов в артикулах номенклатуры и команда установки/снятия пометок удаления выбранных присоединенных файлов. Можно просмотреть все присоединенные файлы в базе, увидеть их пометки на удаление, поменяь их значение. Создавалась и тестировалась на файловой базе. Платформа 8.3.14, 8.3.15, конфигурация Управление торговлей, редакция 11.4.7.150 - 11.4.10.62, конфигурация Розница 2.2.12.30 (скорее всего будет работать и на более ранних и более поздних версиях, при необходимости можно скорректировать). При платном скачивании сделаю для вашей версии (Возможно адаптировать для Комплексной автоматизации). Возможны доработки под вас.

2500 руб.

01.11.2019    5137    9    1    

Быстрая свертка базы 1С средствами SQL

Свертка базы Администрирование СУБД v8 БП3.0 УТ11 Платные (руб)

Сверните базу данных 1С:Предприятие 8.3 в 10-20 раз быстрее! (для клиент-серверного варианта работы)

25000 руб.

28.10.2019    4748    2    0    

Программа групповой печати чеков ККМ Атол и Штрих из текстового файла, поддержка 54-ФЗ от 01.07.19 Промо

Пакетная печать ККМ Кассовые операции Кассовые операции Россия БУ Платные (руб)

Предназначена для групповой печати чеков. Что печатать в теле чека описано в текстовом файле с разделителем запятая (CSV) Подходит для любого языка программирования который умеет записывать в текстовый файл

1000 руб.

26.07.2019    6973    10    0    

Загрузка табелей рабочего времени из файлов Excel

Зарплата Обработка документов Учет рабочего времени Загрузка и выгрузка в Excel v8 v8::СПР ЗУП3.x Россия БУ Платные (руб)

Обработка по загрузке в типовой документ «Табель» конфигурации ЗУП 3.1 данных из файлов MS Excel, согласно шаблону.

1400 руб.

18.10.2019    5972    5    0    

1СПАРК Риски. Проверка благонадежности контрагентов.

Обработка документов Обработка справочников v8 УНФ БП3.0 Россия Платные (руб)

«1СПАРК Риски» дает пользователям программ 1С возможность управлять налоговыми рисками и комплексно оценивать благонадежность контрагентов. Сервис предназначен для руководителей предприятий и лиц, принимающих бизнес-решения, бухгалтеров, менеджеров подразделений материального снабжения, менеджеров по продажам, специалистов финансовых служб и др.

3000 руб.

15.10.2019    5355    4    1    

Загрузка заказов по электронной почте для конфигураций: Управление торговлей 11, Управление торговлей 10.3

Обработка документов Оптовая торговля Загрузка и выгрузка в Excel v8 v8::БУ v8::ОУ УТ11 УУ Платные (руб)

Обработка позволяет автоматически загружать заказы, поступающие на электронную почту организации.

2500 руб.

10.10.2019    5165    5    2    

Номенклатура (Расширенная форма списка) и Корзина для УТ11, ERP и КА2 [Расширение] Промо

Рабочее место Обработка справочников Оптовая торговля Розничная торговля Учет ТМЦ Ценообразование, анализ цен Оптовая торговля Розничная торговля Учет ТМЦ Ценообразование, анализ цен v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Платные (руб)

Красивая, функциональная и удобная форма справочника Номенклатура. В общем списке отображаются остатки и цены по каждой позиции. Подбор товаров в документы через корзину. Входит в Топ платных разработок по УТ, ERP и КА.

5000 руб.

26.04.2016    80767    559    280    

SALE! 15%

Набор эмуляторов торгового оборудования

ККМ Ридер магнитных карт Сканер штрих-кода Терминал сбора данных Весы v8 Россия Платные (руб)

Эмуляторы: электронные весы, весы с печатью этикеток в режиме "OFFLINE", дисплей покупателя, терминал сбора данных, ККТ, принтер чеков, сканер штрихкода, считыватель магнитных карт, RFID считыватель, эквайринговый терминал, принтер этикеток. Поддержка требований к разработке драйверов подключаемого оборудования от 2.1 до 3.2

1500 руб.

02.10.2019    9234    29    15    

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Платные (руб)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая). Принимаются пожелания пользователей на доработку данного функционала (писать в комментариях).

3000 руб.

24.09.2019    7792    2    6    

1С:Контрагент. Автозаполнение реквизитов контрагентов по ИНН.

Обработка справочников v8 УНФ ERP2 БП3.0 УТ11 КА2 Россия Платные (руб)

Сервис "1С- Контрагент" - сервис получения реквизитов контрагента по ИНН или по наименованию в Информационной базе. Заполнение данных по контрагенту (наименование, учредитель, коды контролирующих органов, юридический адрес и телефон компании) с одной кнопки как из справочника, так и из документа учетной системы.

4800 руб.

13.09.2019    6653    9    3    

Загрузка номенклатуры c картинками и сопутствующими данными в базу и любые документы из xls,xlsx,xlsm,ods,ots,csv для УТ 10.3, БП 2.0, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6, Розница 2 Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Ценообразование, анализ цен Ценообразование, прайсы Учет ТМЦ Ценообразование, анализ цен v8 БП2.0 УТ10 Розница УНФ ERP2 БП3.0 УТ11 КА2 БУ УУ Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру, с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. И загрузка номенклатуры с данными в ЛЮБОЙ документ из конфигурации, в том числе нескольких видов цен в один документ.! И конечно - подробная справка с картинками и практическими примерами. (Обновление от 20.04.2020, версия 5.11 - 5.20, 4.28)

7990 руб.

20.11.2015    81866    243    196    

Создание документов "Реализация товаров и услуг" и "Приобретение товаров и услуг" на заданную сумму с учетом остатков в конфигурациях "УТ 11.4", "1С:КА 2.4" и "1С:ERP УП 2.4" (расширение конфигурации)

Оптовая торговля Учет ТМЦ Обработка документов Оптовая торговля Учет ТМЦ v8 v8::ОУ УТ11 Россия БУ УУ Платные (руб)

В расширении "Создание документов "Реализация товаров и услуг" и "Приобретение товаров и услуг" на заданную сумму с учетом остатков в конфигурациях "УТ 11.4", "1С:КА 2.4" и "1С:ERP УП 2.4"" реализован дополнительный функционал по созданию документов "Реализация товаров и услуг " и "Приобретение товаров и услуг" на заданную сумму с учетом остатков без снятия конфигурации с поддержки фирмой 1с

4000 руб.

05.09.2019    10872    3    0    

Мониторинг баз и серверов 1С

Журнал регистрации Статистика базы данных Производительность и оптимизация (HighLoad) Администрирование СУБД Технологический журнал v8 Платные (руб)

В сферу обязанностей при работе с клиентами входит контроль работы баз данных и серверов 1С. Нужно понимать что происходит в базах, есть ли ошибки, зависания у пользователей и фоновых задач, блокировки или какое-то необычное поведение системы, получение информации о причинах возникновения проблем и их оперативное устранение и т.д. В качестве источников информации использую консоль кластеров 1С, технологический журнал 1С, журналы регистрации базы 1С. Для автоматизации части операций мониторинга и анализа создал инструмент на основе 1С.

7500 руб.

28.08.2019    7171    4    2    

Путевой лист грузового автомобиля в 1С:Бухгалтерии 3.0

Обработка документов Печатные формы документов Учет рабочего времени Учет рабочего времени v8 v8::БУ БП3.0 Россия БУ Платные (руб)

Вам необходимо заполнить и распечатать путевой лист грузового автомобиля в "1С:Бухгалтерия 3.0"? Мы предлагаем решение, с помощью которого Вы сможете не только внести всю информацию путевого листа и распечатать, но и повторно использовать ранее введенные данные спустся любое время - данные путевого листа сохраняются в "1С:Бухгалтерия 3.0" Помимо сведения о водителе и транспорте можно внести информацию о прицепах и много другое.

2500 руб.

23.08.2019    6587    5    2    

Универсальная обработка создания связанных документов (универсальный "ввод на основании") Промо

Универсальные обработки Обработка документов v8 v8::УФ 1cv8.cf УНФ БП3.0 УТ11 ЗУП3.x Платные (руб)

Универсальная внешняя обработка призвана предоставить пользователю механизм, позволяющий быстро, в удобной и понятной форме настроить в программе функционал по созданию и заполнению новых документов на основании данных других документов (и не только), т.е. возможность настраивать типовой механизм "ввода на основании" для заполнения создаваемых документов по своим правилам.

1000 руб.

02.04.2017    22103    33    13    

Массовое перемещение товаров на складах. УТ 11.4

Учет ТМЦ Обработка документов Учет ТМЦ v8 v8::ОУ УТ11 УУ Платные (руб)

Если Вы устали тратить бесчисленное количество времени на перемещение товаров между складами, то эта разработка для Вас! Она позволяет увидеть необходимую информацию о наличии остатков на различных складах, продажах за период, ценах, а также создавать массовые перемещения нажатием одной кнопки!

1500 руб.

29.07.2019    8650    7    9    

Автоматическое заполнение бизнес-регионов партнеров для УТ 11, КА 2 (расширение)

Оптовая торговля Обработка справочников Оптовая торговля v8 v8::ОУ УТ11 Россия УУ Платные (руб)

Данное расширение автоматически заполняет бизнес-регион партнера при записи на основании КПП или индекса из адреса. Присутствует возможность сохранить имеющиеся бизнес-регионы партнеров, а также перезаполнить или очистить их при первичном заполнении. Возможен выбор региона по умолчанию для партнера без КПП или адреса (например, если вы не указываете адреса физ. лиц и знаете, что они из Вашего региона).

1500 руб.

29.04.2019    5434    6    2    

Алгоритм перехода на учет без серий для программного продукта "Управление торговлей" редакция 11. (УТ 11 без серий, удаление серий в УТ 11, обработка для удаления серий в УТ 11, переход на учет без серий)

Обработка документов Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::ОУ УТ11 Россия УУ Платные (руб)

Если вы начали работать в программном продукте Управление Торговлей, редакция 11 и включили механизм учёта серий, то перейти обратно в учёт без серий будет не так-то просто. Сложность заключается в том, что нужно очистить серии в табличной части документа, например, Реализация Товаров и услуг. Предлагаем алгоритм перехода на учет без серий для программного продукта «Управление торговлей» редакция 11.

1000 руб.

09.04.2019    8271    8    8    

Загрузка товаров, остатков и цен. Розница 2.2, 2.3

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Розничная торговля Учет ТМЦ Розничная торговля Учет ТМЦ v8 v8::УФ Розница Россия УУ Платные (руб)

Загрузка товаров, остатков и цен из макета табличного документа (из эксель "вручную") + макет ценника со штрихкодом. Розница 2.2.

1600 руб.

08.04.2019    11551    19    4    

Как свернуть базу УТ 10.3

Свертка базы v8 v8::ОУ УТ10 Россия УУ Платные (руб)

Как свернуть УТ 10.3. Цель свертки - свернуть остатки по товарам и по взаиморасчетам с контрагентами.

2000 руб.

04.04.2019    13593    79    15    

Создание Реализаций (акты, накладные) из Поступлений на расчетный счет для БП 3.0 и 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК

Обработка документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 v8::БУ БП3.0 Энергетика и ЖКХ БУ Платные (руб)

Внешняя обработка для массового создания документов Реализации из Поступлений на расчетный счет. Заполняется указанной в настройках номенклатурой. В зависимости от вида номенклатуры создается Реализация услуг: Акт или Реализация товаров: Накладная. Проверено на БП 3.0.68.66 и 1С:Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК 3.0.68.1.

1900 руб.

29.03.2019    5409    3    0    

Множественные свойства элемента справочника в УТ 11.3 и 11.4, УНФ для выгрузки на сайт в Битрикс Промо

Обработка справочников WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 v8::ОУ УТ11 УУ Платные (руб)

Расширение для возможности ввода в УТ и УНФ множественных свойств и выгрузки их на сайт Битрикс.

1000 руб.

29.11.2017    28207    120    44    

Быстрый поиск дублей с четким/нечетким поиском по любому сочетанию реквизитов/реквизитов таб. частей с отбором и быстрой заменой значений в ЛЮБЫХ базах 8.1-8.3 (УТ 10.3, БП 2, ЗУП 2.5, КА 1.1, УТ 11, БП 3, УНФ 1.6, КА 2, ЗУП 3 и т.д.) Промо

Чистка базы Поиск данных Универсальные обработки Обработка справочников Обработка документов v8 v8::УФ 1cv8.cf Платные (руб)

Данные обработки помогут Вам легко и, главное, быстро (в 5 раз и более быстрее штатной обработки 1С), выполнить поиск дублирующих данных в Ваших базах 1С на платформах 8.1-8.3. Это позволит уменьшить объем лишней информации в справочниках и документах, планах видов характеристик и др., упростит работу с данными пользователям. А так же можно, одним нажатием, узнать в каких ссылочных объектах есть вообще дубли! Понятное расположение команд и настроек, в сочетании с описанием и справкой, еще упростят процесс. Если что-то будет неясно по работе с обработками – я готов Вам помочь. А так же обновления Вы получаете бесплатно в течение года с момента приобретения данных обработок! Данные обработки входят в ТОП-100 продаж за все время, что является залогом популярности, надежности в работе, и признанием других покупателей. (Обновление от 23.08.2019, версия 6.20, 6.30)

3990 руб.

14.05.2012    105059    302    217    

Пометка на удаление номенклатуры, которой нет на остатках и не было в оборотах за определенное время (кол-во месяцев), и перенос ее в указанную папку Промо

Обработка справочников v8 УТ10 Россия УУ Платные (руб)

Данная обработка определяет неликвидную номенклатуру, метит её на удаление и переносит её в указанную папку, что облегчает работу операторов организации для аналитики и многих процессов, связанных с товаром.

1900 руб.

03.06.2020    333    0    2