Резервное копирование чеков во внешние файлы и их восстановление

Публикация № 95529

Администрирование - Администрирование данных 1С - Архивирование (backup)

Решение проблемы восстановления потерянных кассовых чеков после восстановления поврежденной базы розницы.

В сети розничных торговых точек установили неудачные фискальные регистраторы. При сбоях по питанию, иногда ведет базу. А после ее восстановления оказывается, что несколько последних чеков, пробитых через фискальник, в базе 1С потеряны. В базе ведется партионный учет товара, поэтому списать что попало для "выравнивания" продаж нельзя, нужно списывать только то, что реально продано. Естественно, что часто вспомнить не получается. Делать ревизию накладно. Поэтому, нужна профилактика. Нам с Павлом Григорьевым пришла мысль делать резервную копию чека перед отправкой на фискальный регистратор во внешний файл. При запуске 1С очищаем каталог от чеков, пролежавших более 30 дней. В случае потери чеков запускается процедура, которая показывает список чеков, находящихся в специалном каталоге, позволяет выбрать один из них и импортировать в интерфейс кассира. Пробивать его или нет решать кассиру. Ниже привожу текст функций и процедур.

Сохранение объектов 1С во внешний файл *.xml  и его последующее восстановление на примере резервного копирования каждого чека.

 

Процедура СохранитьЧек()

            КаталогНаДиске = Новый Файл(мВременнаяПапка+"\Чеки");

    Если  Не КаталогНаДиске.Существует() Тогда

                СоздатьКаталог(мВременнаяПапка+"\Чеки");

    КонецЕсли;

           

// XML сериализация текущего объекта

            ЗаписьXML = Новый ЗаписьXML;

            ЗаписьXML.ОткрытьФайл(мВременнаяПапка+"\Чеки\"+Формат( ТекущаяДата(),"ДФ=ddMMyyyyHHmmss")+".xml", "UTF-16");

            ЗаписатьXML(ЗаписьXML, ЭтотОбъект);

            ЗаписьXML.Закрыть();

КонецПроцедуры

 

 

Процедура КнопкаВосстановитьЧекНажатие(Элемент)

            Если РольДоступна("ПолныеПрава") Тогда

                        Режим = РежимДиалогаВыбораФайла.Открытие;

                        ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);

                        ДиалогОткрытияФайла.ПолноеИмяФайла = "";

                        Фильтр = "XML(*.xml)|*.xml";

                        ДиалогОткрытияФайла.Фильтр = Фильтр;

                        ДиалогОткрытияФайла.МножественныйВыбор = Ложь;

                        ДиалогОткрытияФайла.Заголовок = "Выберите файл";

        ДиалогОткрытияФайла.Каталог=мВременнаяПапка;

                        Если ДиалогОткрытияФайла.Выбрать() Тогда

                                  

                                   ФайлНаДиске = Новый Файл(ДиалогОткрытияФайла.ПолноеИмяФайла);

                                   Если ФайлНаДиске.Существует() Тогда

                                              

                                               ЧтениеXML = Новый ЧтениеXML;

                                               ЧтениеXML.ОткрытьФайл(ДиалогОткрытияФайла.ПолноеИмяФайла);

                                               Пока ВозможностьЧтенияXML(ЧтениеXML) Цикл

                                                           Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента

                                                                       И   ЧтениеXML.Имя     = "DocumentObject.ЧекККМ" Тогда

                                                                       Попытка

                                                                                  ДокументОбъект = ПрочитатьXML(ЧтениеXML);

                                                                       Исключение

                                                                                  Результат = Неопределено;

                                                                       КонецПопытки;

                                                           КонецЕсли;

                                               КонецЦикла;

                                               ЧтениеXML.Закрыть();

                                              

                                   КонецЕсли;

                        Иначе

                                   Предупреждение("Файл не выбран!");

                        КонецЕсли;

            КонецЕсли;  

КонецПроцедуры


 

Процедура ДействияФормыДействиеЗакрытиеЧека(Кнопка)

            //…………………                

СохранитьЧек();

            //………………….

КонецПроцедуры

 

 

 

// Процедура выполняется перед нначалом работы системы

//

Процедура ПриНачалеРаботыСистемы()

            //………………………………………

            Если Не РольДоступна("РМК") Тогда

            //………………………………………        

            Иначе

                        Расш="*.xml";

                        НайденныеФайлы = Новый Массив;

                        НайденныеФайлы = НайтиФайлы(РаботаСФайлами.ПолучитьИмяКаталога()+"\Чеки", Расш);

                       

                        Для Каждого ТекСтрока Из НайденныеФайлы Цикл

                                   Если  ТекСтрока.ПолучитьВремяИзменения()<ДобавитьМесяц(ТекущаяДата(),-1) Тогда

                                               Сообщить("Удаление архивных чеков"+ТекСтрока.ПолноеИмя);

                                               УдалитьФайлы(ТекСтрока.ПолноеИмя);

                                   КонецЕсли;  

                        КонецЦикла;

                       

            КонецЕсли;

 

 

КонецПроцедуры

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Angeros 25.10.11 06:47 Сейчас в теме
А смысл их хранить?! Отчет по продажам выгрузить в главную базу и дело с концом. Максимум 1/2 дня.
2. elizarovs 76 25.10.11 06:54 Сейчас в теме
(1) Я же пишу: "Базу повело. После исправления потеряна информация о последних продажах". Нет этой информации в отчете о продажах, поскольку и чеков нет! Тем более нет Сменного Отчета о Розничных Продажах. За полгода на фирме такое раза 3 было. В основном, при сбоях по питанию на точках, где сдохли бесперебойники.
Оставьте свое сообщение

См. также

Тонкая настройка ежедневного резервного копирования базы данных 1С средствами SQL ver. 2014 (SP3) - 12.0.6024.0 (X64)

Статья Системный администратор Программист Нет файла v8 Россия MS SQL Бесплатно (free) Архивирование (backup)

Хочу вам предложить небольшой пример, как можно реализовать резервное копирование 1С-ых баз данных средствами SQL. Данный материал не претендует на пулитцеровскую премию. Но возможно кому-то будет интересно узнать, что-то новенькое. Данный материал для резервного копирования только одной базы данных. А именно, если у вас 20-ть баз, то вам придется создавать 20-ть планов обслуживания для каждой базы индивидуально. (Слава разработчикам SQL, они разрешили копировать блоки из одного плана в другой, вам остается только произвести небольшую настройку для каждого скопированного блока - некоторые настройки блоков сбрасываются и выставляются значением по умолчанию и остаются неактивными)

07.10.2019    6203    DrZombi    49       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Настройка резервного копирования (резервирования) баз данных 1С: Предприятие на MS SQL Server

Статья Системный администратор Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Архивирование (backup)

Настройка резервного копирования (резервирования) баз данных на "бюджетной" версии 1С Предприятие под MS SQL Server. Используется пример MS SQL Server 2008 R2 под Windows. Для малых и средних предприятий, исключая производственные и торговые, так как тестирование на них не проводилось.

30.10.2018    9936    unclevad    16       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Резервное копирование "онлайн" клиент-серверных баз в dt (не отключая пользователей)

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) Архивирование (backup)

Как реализовать резервное копирование клиент-серверных баз 1с в формат dt, не отключая пользователей. Рассматривается способ, делающий резервирование наименее заметным для пользователей и серверного оборудования.

03.10.2017    21480    konstanta_online    80       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

Рекомендации по организации резервного копирования для систем с Windows Server / Windows SQL Server

Статья Системный администратор Нет файла v8 Windows Бесплатно (free) Архивирование (backup)

В данной статье мы рассмотрим работу с резервными копиями базы данных 1С, а также некоторые приемы, оптимизирующие работу с резервными копиями.

10.10.2016    16906    Zebar    12       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Как я восстанавливал разрушенную базу

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Архивирование (backup) Распределенная БД (УРИБ, УРБД) Тестирование и исправление

УТ10.3 на Платформе 8.2 на базе MSSQL была разрушена после попытки её восстановить после неудачного динамического обновления. Таблица Config целевой базы была заменена на содержимое таблицы Config от другой рабочей базы. Но на самом деле конфигурации у них существенно отличались, поэтому после таких действий целевая база рухнула окончательно. Что же делать?

21.08.2015    26496    METAL    25       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Просто и сердито. Архивирование (backup) типовых конфигураций 1С 8.2, 8.3

Статья Системный администратор Нет файла v8 1cv8.cf Windows Бесплатно (free) Архивирование (backup)

После эксплуатации различных "бесплатных" обработок и скриптов решил написать свой cmd-файл для ежедневного архивирования баз 1С. Работает на конфигурациях, где есть процедуры "ЗавершитьРаботуПользователей" и "РазрешитьРаботуПользователей" (т.е. во всех типовых, в нетиповые данные модули можно скопировать из типовых). Сохраняет файлы как локально так и на удаленном файловом сервере. Автоматически удаляет старые архивы и копирует на удалённый сервер отсутствующие. Расписание задается установкой соответствующего задания (запуска cmd-файла по времени) в планировщике задач Windows. Для борьбы с зависшими сеансами, рекомендуется настроить в режиме конфигуратора параметры информационной базы: "Время засыпания пассивного сеанса" и "Время завершения спящего сеанса".

18.06.2015    16170    Prelude    14       

Как выгрузить базу средствами 1С, не выгоняя пользователей. Делаем невозможное.

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Архивирование (backup) Администрирование данных 1С

В 1С:Предприятии 8.2 есть ограничение на выгрузку базы в формате DT. Выгрузить базу можно, только если в ней нет активных пользователей. В этой статье поделюсь способом, как обойти это ограничение и сделать невозможное.

16.09.2013    45238    yurega    54       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Восстановление SQL базы 1С 8.2. после неудачного сохранения конфигурации

Статья Системный администратор Программист Нет файла v8 Россия Windows Бесплатно (free) Архивирование (backup) Администрирование данных 1С

При динамическом обновлении, в процессе сохранения конфигурации, вылетела база 1С и отказалась заходить в режим Конфигуратора, выдавая сообщение "Внимание!!! При обновлении данных, после последней реструктуризации, произошла ошибка. Повторить обновление?", если ответить утвердительно, то появлялось сообщение "Обнаружена незавершенная операция сохранения конфигурации. Для продолжения работы необходимо завершить операцию.", после чего Конфигуратор закрывался.

18.07.2013    34172    lord_soth    45       

Скрипт - выгонялка пользователей + резервная копия базы.

Инструменты и обработки Системный администратор Компонента, плагин (dll, vbs,..) v8 1cv8.cf Windows Бесплатно (free) Архивирование (backup)

В Клиент-серверном режиме работы базы часто возникает необходимость выгонять пользователей чтобы сделать обновление, резервные копии и т.п. Для ленивых, которым неудобно всех выгонять "руками" или ждать окончания рабочего дня, предлагается простой скрипт, который всё сделает за вас.

26.02.2013    23161    tystik    11       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Резервное копирование 1С средствами MS SQL.

Статья Системный администратор Нет файла v8 1cv8.cf Windows Бесплатно (free) Архивирование (backup)

В этой статье описано самое обычное резервное копирование ИБ 1С при помощи инструментов MS SQL Server 2008 R2, объяснено почему следует делать именно так, а не иначе, и развеяно несколько мифов.

17.02.2013    238076    speshuric    79       

Хранение удаленных документов в отдельной базе. Часть 1.

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Архивирование (backup) Администрирование данных 1С

Резервное хранение данных. Пример работы с внешними источниками данных. Работа с файлами. Подписка на событие. Работа с XML файлами. Сериализатор XDTO.

12.12.2012    14676    egorovntn    10       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Восстановление файловой версии базы данных *.1CD после ошибки динамического обновления.

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Сервисные утилиты Архивирование (backup) Администрирование данных 1С Тестирование и исправление

Восстановление работоспособности файл-серверной базы данных (файл *.1CD) после критической ошибки, возникшей в результате динамического обновления с последующим предупреждением "Внимание!!! При обновлении данных, после последней реструктуризации, произошла ошибка. Повторить обновление?".

02.10.2012    48663    djserega    74       

Автоматическое регулярное разворачивание оперативных бэкапов (совсем просто) в MS SQL 2008

Статья Системный администратор Нет файла v7.7 v8 1cv8.cf 1cv7.md Россия Windows Бесплатно (free) Архивирование (backup)

В работе регулярно возникает необходимость протестировать поведение программы на копии рабочей базы с актуальными данными

10.08.2012    16756    sergiobargio1    6       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Регулярные оперативные копии рабочих баз 1С с помощью MS SQL 2008

Статья Системный администратор Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Архивирование (backup) Администрирование данных 1С

В течение дня необходимо производить отладку "допилов" на свежих копия рабочих баз. Также необходимы актуальные копии и для экспериментов, в том числе и пользователям. На этом замечательном ресурсе есть много полезных публикаций с различными вариантами, как это сделать. В одном из них предлагается использовать инструмент мгновенных снимков баз, которые возможно выполнить только в версии Express Edition. В этом посте очень простой вариант, не требующий дорогостоящей версии MS SQL

01.08.2012    17834    sergiobargio1    8       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Автоматизация создания резервных копий в MS SQL Express Server

Статья Системный администратор Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Архивирование (backup)

В версии Microsoft SQL Server 2005/2008/2008R2 Express Edition серверах нет стандартных средств создания резервных копий баз данных по расписанию. Восполнить этот пробел поможет простое решение

18.06.2012    28338    LexSeIch    4       

Восстановление SQL базы 1С 8.2. рухнувшей во время сохранения конфигурации.

Статья Системный администратор Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Тестирование и исправление Архивирование (backup)

При обновлении конфигурации вылетела 1С. После чего наотрез отказалась входить в базу. При этом в конфигураторе выдавалось сообщение "Внимание!!! При обновлении данных, после последней реструктуризации, произошла критическая ошибка. Повторить обновление?" Потом выходило сообщение "Обнаружена незавершённая операция сохранения конфигурации. Для продолжения необходимо завершить операцию". Горела кнопка Ок - на этом работоспособность конфигуратора и базы заканчивалась.

08.02.2012    124132    VanDiesel1    134       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Бэкап 1С:Предприятие 8.х

Статья Системный администратор Нет файла v8 1cv8.cf Россия Бесплатно (free) Архивирование (backup)

Рекомендации по резервному копированию. Бесплатные программы для бэкапа Egida Backup, Effector saver 3, xStarter.

09.11.2011    24719    sinjevla    10       

Архивное копирование 1С8 автоматически и ежедневно

Статья Системный администратор Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Архивирование (backup)

Выложил ввиду "молодости и горячести" ХД и критики со стороны, дабы не спотыкаться в дальнейшем =)

19.04.2011    6557    AActor    15       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Скрипт удобного восстановления базы MSSQL при дифференциальном резервировании

Статья Системный администратор Нет файла v7.7 v8 1cv8.cf 1cv7.md Россия Windows Бесплатно (free) Архивирование (backup)

Если у Вас база на MSSQL и Вы пользуетесь разностными бекапами, то, скорее всего, столкнулись с тем, что поднять базу/копию базы из имеющихся резервных файлов не столь удобно, как того хотелось бы. В этой статье приведен скрипт по теме.

20.01.2011    28613    Ivon    12       

1С и Postgres: Бэкап

Статья Системный администратор Нет файла v8 1cv8.cf Россия Бесплатно (free) Архивирование (backup)

Для начала пару слов о том, зачем и когда он нужен. Ни для кого не секрет, что сервер это не просто компьютер, а надежный компьютер! Поэтому, если он не сломался в первую неделю после запуска, то не сломается еще очень долго. И поэтому у вас всегда есть возможность какое-то время оставаться вовсе без резервной копии

17.12.2010    21504    alexcid    5