Отладка расчета себестоимости в ERP - просмотр изменений временных таблиц

Публикация № 1291127

Разработка - Практика программирования

Расчет себестоимости Управление предприятием 2 ERP

Как уследить за изменениями в сотне временных таблиц на различных этапах выполнения расчета себестоимости. Тестировалось на 1С:ERP Агропромышленный комплекс 2 (2.4.12.75)

Перед прочтением рекомендую ознакомиться с выжимкой из описания типовых методов  расчета в этой статье: //develop.iservice.ru/1c/articles/658048/

Для отладки расчета себестоимости будет очень удобно использовать методы сравнения данных в МВТ. Поясню. Весь расчет себестоимости - это формирование и перезапись временных таблиц. Их около 50 штук. Для того чтобы понимать, какие ВТ на каком этапе формируются, и какие данные в них меняются, я написал два метода и положил их в общий модуль.

На протяжении расчета во все методы передаётся структура ПараметрыРасчета, содержащая МенеджерВременныхТаблиц. Именно в нём и меняются ВТ, формируемые в разных этапах расчета. 
 

Функция ПолучитьОписаниеТаблицМВТ(МВТ, Параметры = Неопределено, ИмяПараметра = "") Экспорт
    
    ТаблицыМВТ = Новый ТаблицаЗначений;
    ТаблицыМВТ.Колонки.Добавить("Имя", Новый ОписаниеТипов("Строка"));
    ТаблицыМВТ.Колонки.Добавить("КоличествоЗаписей", Новый ОписаниеТипов("Число"));
    ТаблицыМВТ.Колонки.Добавить("ТЗ");
    
    
    Для Каждого цВТ Из МВТ.Таблицы Цикл
        
        новСтрока = ТаблицыМВТ.Добавить();
        новСтрока.Имя = цВТ.ПолноеИмя;
        
        ТЗ = цВТ.ПолучитьДанные().Выгрузить();
        
        новСтрока.КоличествоЗаписей = ТЗ.Количество();
        новСтрока.ТЗ = ТЗ;
        
    КонецЦикла;
    
    ТаблицыМВТ.Сортировать("Имя");
    
    
    Если Параметры <> Неопределено И Не ПустаяСтрока(ИмяПараметра) Тогда
        Параметры.Вставить(ИмяПараметра, ТаблицыМВТ);
    КонецЕсли;
    
    
    Возврат ТаблицыМВТ;
    
КонецФункции
Функция СравнитьОписанияВТ(Описание1, Описание2, ТолькоОтличия = Истина) Экспорт
    
    ОтличияОписаний = Новый ТаблицаЗначений;
    ОтличияОписаний.Колонки.Добавить("Имя", Новый ОписаниеТипов("Строка"));
    ОтличияОписаний.Колонки.Добавить("КоличествоЗаписей1", Новый ОписаниеТипов("Число"));
    ОтличияОписаний.Колонки.Добавить("КоличествоЗаписей2", Новый ОписаниеТипов("Число"));
    ОтличияОписаний.Колонки.Добавить("ЕстьВОписании1", Новый ОписаниеТипов("Булево"));
    ОтличияОписаний.Колонки.Добавить("ЕстьВОписании2", Новый ОписаниеТипов("Булево"));
    ОтличияОписаний.Колонки.Добавить("ДанныеОтличаются", Новый ОписаниеТипов("Булево"));
    ОтличияОписаний.Колонки.Добавить("ТЗ1");
    ОтличияОписаний.Колонки.Добавить("ТЗ2");
    
    Для Каждого цСтрокаОписания1 Из Описание1 Цикл
        
        новСтрока = ОтличияОписаний.Добавить();
        новСтрока.Имя = цСтрокаОписания1.Имя;
        новСтрока.ТЗ1 = цСтрокаОписания1.ТЗ;
        новСтрока.КоличествоЗаписей1 = цСтрокаОписания1.ТЗ.Количество();;
        новСтрока.ЕстьВОписании1 = Истина;
        
        СтрокиВ2Описании = Описание2.НайтиСтроки(Новый Структура("Имя", цСтрокаОписания1.Имя));
        
        Если СтрокиВ2Описании.Количество() = 0 Тогда
            новСтрока.ДанныеОтличаются = Истина;
        Иначе
            
            новСтрока.ЕстьВОписании2 = Истина;
            новСтрока.ТЗ2 = СтрокиВ2Описании[0].ТЗ;
            новСтрока.КоличествоЗаписей2 = новСтрока.ТЗ2.Количество();;
            
            
            Если новСтрока.КоличествоЗаписей1 <> новСтрока.КоличествоЗаписей2 Тогда
                новСтрока.ДанныеОтличаются = Истина;
                Продолжить;
            КонецЕсли;
            
            
            Для Каждого цКолонкаТЗ1 Из новСтрока.ТЗ1.Колонки Цикл
                Если новСтрока.ТЗ2.Колонки.Найти(цКолонкаТЗ1.Имя) = Неопределено Тогда
                    новСтрока.ДанныеОтличаются = Истина;
                    прервать;
                КонецЕсли;
            КонецЦикла;
            
            Для Каждого цКолонкаТЗ2 Из новСтрока.ТЗ2.Колонки Цикл
                Если новСтрока.ТЗ1.Колонки.Найти(цКолонкаТЗ2.Имя) = Неопределено Тогда
                    новСтрока.ДанныеОтличаются = Истина;
                    прервать;
                КонецЕсли;
            КонецЦикла;
            
            Если Не новСтрока.ДанныеОтличаются Тогда
                новСтрока.ДанныеОтличаются = Не ОбщегоНазначения.КоллекцииИдентичны(новСтрока.ТЗ1, новСтрока.ТЗ2);
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЦикла;
    
    Для Каждого цСтрокаОписания2 Из Описание2 Цикл
        
        СтрокиВОписании = ОтличияОписаний.НайтиСтроки(Новый Структура("Имя", цСтрокаОписания2.Имя));
        
        Если СтрокиВОписании.Количество() = 0 Тогда
            новСтрока = ОтличияОписаний.Добавить();
            новСтрока.Имя = цСтрокаОписания2.Имя;
            новСтрока.ТЗ2 = цСтрокаОписания2.ТЗ;
            новСтрока.КоличествоЗаписей2 = цСтрокаОписания2.ТЗ.Количество();;
            новСтрока.ЕстьВОписании2 = Истина;
            новСтрока.ДанныеОтличаются = Истина;
        КонецЕсли;
        
    КонецЦикла;
    
    Если ТолькоОтличия Тогда
        ОтличияОписаний = ОтличияОписаний.Скопировать(Новый Структура("ДанныеОтличаются", Истина));
    КонецЕсли;
    
    ОтличияОписаний.Сортировать("Имя");
    
    Возврат ОтличияОписаний;
    
КонецФункции

Первый метод читает все ВТ из менеджера и возвращает таблицу значений с колонками:

  • Имя (имя временной таблицы), 
  • КоличествоЗаписей, 
  • ТЗ (непосредственно данные из временной таблицы).

Кроме того, этот метод может положить сформированную таблицу с описанием ВТ в любую структуру с произвольным ключом (параметры метода: Параметры, ИмяПараметра). Таким образом мы можем на любом этапе расчета создать "слепок" содержимого менеджера ВТ и положить его, например, в структуру "ПараметрыРасчета".

Второй метод позволяет сравнивать слепки, получившиеся в результате работы первого метода. В результате сравнения возвращается таблица, содержащая поля:

  • Имя (имя временной таблицы), 
  • КоличествоЗаписей1, 
  • КоличествоЗаписей2, 
  • ТЗ1 (непосредственно данные из таблицы первого слепка).
  • ТЗ2 (непосредственно данные из таблицы второго слепка).
  • ЕстьВОписании1 (признак того, что ВТ присутствует в первом слепке)
  • ЕстьВОписании1 (признак того, что ВТ присутствует во втором слепке)
  • ДанныеОтличаются (признак того, что Данные в таблицах с одинаковым именем отличаются - по количеству записей, или по значению полей, или по наличию таблиц)

Как этим пользоваться.
1. Запускаем расчет. Можно накидать внешнюю обработку для запуска

&НаСервере
Процедура ЗапуститьРасчетССНаСервере()
    ПараметрыЗапуска = Новый Структура;
    ПараметрыЗапуска.Вставить("АвтоматическоеТестирование", Ложь);
    ПараметрыЗапуска.Вставить("ВыполняетсяЗакрытиеМесяца", Ложь);
    ПараметрыЗапуска.Вставить("Дата", НачалоМесяца(Период));
    ПараметрыЗапуска.Вставить("МассивОрганизаций", ОбщегоНазначенияКлиентСервер.ЗначениеВМассиве(Организация));
    ПараметрыЗапуска.Вставить("МестоВызоваРасчета", "РасчетСебестоимостиКорректировкаСтоимости.Выполнить_РасчетПартийИСебестоимости");
        
    СхемаРасчета = РасчетСебестоимостиПрикладныеАлгоритмы.СхемаРасчетаПартий(ПараметрыЗапуска.Дата, ПараметрыЗапуска.МассивОрганизаций);
    Если СхемаРасчета.Количество() = 0 Тогда
        новСтрока = СхемаРасчета.Добавить();
        новстрока.Дата = КонецМесяца(ПараметрыЗапуска.Дата);
        новстрока.ИзмененоДокументов = 1;
        новстрока.Организации = ПараметрыЗапуска.МассивОрганизаций;
    КонецЕсли;
    ПараметрыЗапуска.Вставить("СхемаРасчета", СхемаРасчета);
    
    РасчетСебестоимости.РассчитатьВсе(ПараметрыЗапуска);

КонецПроцедуры


Обработка во вложении, там она ещё перепроводит проблемный документ перед расчетом.
2. Тормозим отладку перед интересующим нас методом.
3. В табло пишем:

НашОбщийМодуль.ПолучитьОписаниеТаблицМВТ(ПараметрыРасчета.МенеджерВременныхТаблиц, ПараметрыРасчета, "ТаблицыПередВыполнениемЭтапа")


4. После того как выражение вычислилось, в структуре ПараметрыЗапуска появились данные с ключом "ТаблицыПередВыполнениемЭтапа", комментим (или удаляем из табло) выражение из пункта №3, чтобы данные не перезаписались при следующих шагах
5. Выполняем интересующий нас этап и кладём его данные в структуру с новым ключом. Для этого опять пишем выражение в табло:

НашОбщийМодуль.ПолучитьОписаниеТаблицМВТ(ПараметрыРасчета.МенеджерВременныхТаблиц, ПараметрыРасчета, "ТаблицыПослеВыполненияЭтапа")


6. Сравниваем эти описания, выполняя в табло код: 

НашОбщийМодуль.СравнитьОписанияВТ(ПараметрыРасчета.ТаблицыПередВыполнениемЭтапа, ПараметрыРасчета.ТаблицыПослеВыполненияЭтапа)


В результате имеем Таблицу, содержащую отличия. Открыть её можно прямо из табло, нажав F2.
Также можно вместо этапов 5,6 просто идти по коду, вычисляя в табло выражение:
 

НашОбщийМодуль.СравнитьОписанияВТ(ПараметрыРасчета.ТаблицыПередВыполнениемЭтапа, НашОбщийМодуль.ПолучитьОписаниеТаблицМВТ(ПараметрыРасчета.МенеджерВременныхТаблиц))

Таким образом можно на любом этапе понять, какие ВТ сформировались или изменились.

Скачать файлы

Наименование Файл Версия Размер
Обработка для запуска расчета себестоимости с перепроведением проблемного документа

.epf 6,81Kb
12
.epf 6,81Kb 12 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Markdown-editor в 1С (с сохранением в HTML) Промо

Универсальные обработки Прочие инструменты разработчика v8::УФ 1cv8.cf Абонемент ($m)

В этой обработке вы пишете свой текст, используя синтаксис Markdown, а на выходе получаете чистый HTML-код, избавленный от JS-библиотеки, которая его сформировала. Совместим с Webkit и IE.

1 стартмани

04.07.2019    10400    18    riposte    6    

БГУ 1. Закрытие счетов группы 109

Бухгалтерский учет Закрытие периода v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Полезно для ЦБ и учреждений с учётом по ИФО. Формирует "Закрытие производственных счетов", формирует и заполняет "Списание затрат по услугам". Есть функция отмены проведения и перезаполнения.

1 стартмани

16.02.2021    1285    1    strig_85    0    

Тестовое задание на вакансию "Программист 1С" №6

Практика программирования v8 v8::БУ БП3.0 Абонемент ($m)

Выполненное тестовое задание на вакансию программист-стажер в крупный франч. Тестировалось на платформе 8.3.13.1513 и конфигурации БП 3.0.61.47.

1 стартмани

23.01.2021    1843    0    Sungang    0    

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    5980    21    huxuxuya    11    

Помощник по закрытию месяца для УТ 11.3 Промо

Закрытие периода Обработка документов Закрытие периода Закрытие периода v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    28316    11    Zalipaka    1    

Перенос движений документа из архивной базы при закрытии квартала

Закрытие периода Перенос данных из 1C8 в 1C8 v8::БУ 8.3.14 БП3.0 Россия БУ Абонемент ($m)

Решение проблемы изменения проводок у документа в закрытом квартале.

2 стартмани

03.11.2020    2036    2    Kref    3    

Автоматизированное заполнение документа "Списание НДС" по остаткам регистра "НДС Предъявленный" (счет 19) для БП 3.0

Закрытие периода Обработка документов v8 v8::БУ БП3.0 Россия БУ НУ НДС Абонемент ($m)

Доработка позволяет одним нажатием заполнить документ "Списание НДС" всеми документами с входным НДС, т.е. остатками по регистру "НДС предъявленный" (счет 19).

2 стартмани

03.10.2020    3264    15    vakrikun    10    

Интерактивная справка по объектам 1С (подключаемое расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Пополняется интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    11874    69    sapervodichka    43    

Закрытие месяца за выбранный период скопом для Бухгалтерии 3.0

Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Часто бывает ситуация - бухгалтера залезли в прошлый период, надо все перезакрыть и срочно. Если 1, 3 месяца - не проблема, а вот если год и более напряжно - вот для этих случаев я и сделала данную обработку.

2 стартмани

10.09.2020    1930    18    lenna1c    0    

Распределение косвенных затрат для Бухгалтерии редакции 3.0

Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка предназначена для распределения 25 и 26 счетов пропорционально суммам реализации по номенклатурным группам.

10 стартмани

25.05.2020    2950    5    vitalbasl    3    

БП 3.0, Закрытие месяца, Отключение проверок операций прошлых периодов

Закрытие периода v8 v8::БУ БП3.0 БУ Абонемент ($m)

Расширение конфигурации, отключающее ошибки прошлых периодов, которые блокируют закрытие текущего месяца. Например, "Нарушена последовательность регламентных операций" и т.д.

1 стартмани

13.05.2020    10105    27    sapervodichka    15    

Корректировка остатков регистров бухгалтерии (обычные и управляемые формы) Промо

Свертка базы Универсальные обработки Закрытие периода Чистка базы v8::БУ v8::УФ 1cv8.cf БУ НУ Абонемент ($m)

Внешняя обработка, предназначенная для удобного исправления остатков по регистрам бухгалтерии (Хозрасчетный, Налоговый или любой другой) посредством автоматизации ввода корректировочного документа ("Операция", "Корректировка записей регистров"), приводящего регистр в нужное состояние остатков от текущего. Удобна для массовых правок остатков по бухгалтерскому и налоговому учету на какую-то дату (обычно перед реорганизацией учета, сверткой базы и т.п.)

2 стартмани

03.06.2017    36049    217    stvorl    28    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    32421    27    Stepa86    46    

Простое закрытие затратных счетов для Бухгалтерии 3.0

Закрытие периода Закрытие периода Закрытие периода v8::БУ v8::УФ БП3.0 БУ Абонемент ($m)

Позволяет получить суммы затрат за период и с отборами и закрыть их на выбранный счет и аналитику, тестировалось на 1С:Предприятие 8.3 (8.3.13.1690) Бухгалтерия предприятия, редакция 3.0 (3.0.70.39)

5 стартмани

29.07.2019    5287    9    MikeStav    6    

Списание (корректировка) задолженности контрагентов УНФ 1.6

Закрытие периода Дебиторская и кредиторская задолженность Обработка документов Дебиторская и кредиторская задолженность v8 УНФ Украина БУ Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    28690    19    DMon    1    

Редактирование (установка) даты окончания действия счетов ЕПСБУ в БГУ

Закрытие периода Закрытие периода Закрытие периода v8 v8::БУ БГУ Государственные, бюджетные структуры БУ Абонемент ($m)

При обновлении «1С:Бухгалтерия государственного учреждения, редакция 1.0» (1С:БГУ) на версию 1.0.56.7 не произошла установка даты окончания действия 31.12.2018 у счетов, которые прекратили свое действие в 2018 году. К сожалению, это заметили несколько релизов спустя и вернуться, чтобы разобраться в причинах некорректного обновления, возможности не было. В связи с этим, создана обработка, с помощью которой можно установить дату окончания действия выбранных счетов.

1 стартмани

18.07.2019    8090    28    delta    2    

Решение проблем учета материалов в эксплуатации. УПП, РАУЗ

Учет ТМЦ Практика программирования Учет ТМЦ Разработка v8 v8::БУ УПП1 Россия БУ Абонемент ($m)

Если в вашей организации в течение одного месяца могут происходить несколько перемещений одного и того же материала в эксплуатации между физическими лицами, то УПП с РАУЗ неверно распределяет погашенную стоимость. Эта публикация поможет исправить проблему.

1 стартмани

04.07.2019    5055    21    AnRyb    4    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    25269    7    m-rv    91    

Дозакрытие месяца по статьям затрат

Закрытие периода Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Обработка "дозакрывает" счета 20,23,25,26 в разрезе статей затрат.

1 стартмани

30.05.2019    6671    26    Mihasya    15    

Автоматический зачет доплаты НДС 2% в 2019 году, по авансам полученным ранее 2019 года, при отгрузках в 2019 году

Закрытие периода Оптовая торговля Оптовая торговля v8::БУ БП3.0 Россия БУ НДС Абонемент ($m)

При частичной отгрузке в 2019 году 1С БП 3 в зачет возьмет полученный аванс в 2018 году без учета доплаты НДС 2% в 2019, возникнут расхождения между счетами 62.02 и 76.АВ Работа обработки проверялась на релизе 3.0.68.58.

5 стартмани

20.03.2019    4210    0    detro    0    

Закрытие долгов по зарплате в БП 3.0

Закрытие периода Зарплата Зарплата v8::БУ v8::УФ БП3.0 Россия БУ Абонемент ($m)

Обработка закрытия долгов зарплаты по регистрам.

2 стартмани

20.03.2019    6075    58    dipolm    7    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    34258    92    m-rv    58    

Управление последовательностью документов (обработка для БП 3.0)

Обработка документов Универсальные обработки Закрытие периода Рабочее место v8::БУ БП3.0 УХ БУ Абонемент ($m)

Наиболее универсальная и удобная обработка по управлению последовательностью документов в конфигурациях на базе "1С:Бухгалтерия 3.0". Быстрое отображение, гибкие динамические отборы, изменение состояний документов, удаление из последовательности, групповые действия, удобная навигация по периодам.

2 стартмани

14.01.2019    11028    58    mbreaker    0    

Инструменты бухгалтера: Групповое закрытие месяцев

Закрытие периода Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Помощник группового закрытия позволяет закрывать последовательно сразу несколько месяцев в Бухгалтерии 3.0.

1 стартмани

12.12.2018    7850    36    Bazil    5    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    25539    13    RocKeR_13    16    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    32307    20    mvxyz    17    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    48443    66    dsdred    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    33311    31    informa1555    30    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    60444    24    kalyaka    16