Как увидеть пароли, сохраненные в базе 1С

Публикация № 1437988 11.05.21

Администрирование - Информационная безопасность - Пароли

Обработка сохраненный пароль вспомнить настройки обмен интернет магазин Бухгалтерия Розница

Обработка, позволяющая посмотреть пароли и прочие данные скрываемые звёздочками на формах настройки.

При миграции с одной базы на другую, после конвертации данных или простом переносе остатков и начале работы в новой БД, часто возникает вопрос переноса настроек обмена с интернет магазином и т.п.

И если открыв параллельно формы настроек в обоих базах мы без труда через Ctrl+C Ctrl+V можем перенести адреса, логины и прочие настройки  то с полями "Паролей" возникает загвоздка: "Звёздочки" не копируются :(

И приходится искать: кто-же из сотрудников клиента записал N лет назад заветные "12345б" на клочёк бумажки и не потерял её, или того кто хотя бы знает контакты контакты Веб Мастера настраивавшего Сайт и т.п. и т.д. и далеко не всегда эти поиски заканчиваются результатом. И тогда приходится вооружаться отладчиком и ... ну как минимум не интересно тратить время (если это не первый подобный случай в вашей практике :)

Я не очень люблю тратить свое время попусту, поэтому вспомнив слова из МФ "Ноги Крылья Хвост!", что  "Лучше день потерять, а потом за пять минут долететь" (С)

Погуглив пару моментов...  В общем  набросал обработку. т.к. применение у нее разовое и подключать её в "Доп. отчеты и обработки" ни какого смыла нет, то и никаких "сведений" в модуле на заполнял, открывается через Файл - Открыть и ладно.

У кого острая нехватка Стартманей или другая жизненная ситуация предлагаю посмотреть отладчиком в сторону БСП, а точнее в общий модуль и его процедуру

ОбщегоНазначения.ПрочитатьДанныеИзБезопасногоХранилища(ИдентификаторПодсистемы, "Пароль");

И чуть глубже
 

Функция ДанныеИзБезопасногоХранилища(Владелец, ИмяБезопасноеХранилищеДанных, Ключ)
	
	Результат = Новый Структура(Ключ);
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	БезопасноеХранилищеДанных.Данные КАК Данные
	|ИЗ
	|	РегистрСведений." + ИмяБезопасноеХранилищеДанных + " КАК БезопасноеХранилищеДанных
	|ГДЕ
	|	БезопасноеХранилищеДанных.Владелец = &Владелец";
	
	Запрос.УстановитьПараметр("Владелец", Владелец);
	РезультатЗапроса = Запрос.Выполнить().Выбрать();
	
	Если РезультатЗапроса.Следующий() Тогда
		Если ЗначениеЗаполнено(РезультатЗапроса.Данные) Тогда
			СохраненныеДанные = РезультатЗапроса.Данные.Получить();
			Если ЗначениеЗаполнено(СохраненныеДанные) Тогда
				ЗаполнитьЗначенияСвойств(Результат, СохраненныеДанные);
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	
	Возврат Результат;
КонецФункции

За основу была взята именно эта Функция из БП 3.0

Разработка обработки выполнялось на платформе 8.3.18.1208 для Конфигурации Бухгалтерия предприятия 3.0

А также  Тестировалась на Платформе 8.3.16 в конфигурации Розница 2.2

Бонусом удалось увидеть данные для подключения к сервису Интернет поддержки, некоторые и их умудряются "забыть" :).

Скачать файлы

Наименование Файл Версия Размер
Как перенести Пароли сохраненные в базе 1С в другую базу 1С:

.epf 6,83Kb
41
.epf 1 6,83Kb 41 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. AnryMc 804 11.05.21 08:57 Сейчас в теме
Как в "той" басне Крылова: А Ларчик просто открывался. ©
rpgshnik; user803412; +2 Ответить
2. AnryMc 804 11.05.21 09:16 Сейчас в теме
В линейке решений BAS: Функция - есть, регистр - есть.
Паролей - нет!!!
user803412; Dementor; +2 Ответить
15. lepihin 48 12.05.21 17:36 Сейчас в теме
(2) Значит в BAS сложили пароли в другое место )
Смотреть отладчиком, в момент непосредственного использования пароля должно быть видно.
Ну а если решения BAS поставляются с закрытым кодом да еще и обфусцированы ... ну тогда нам с ними не по пути :)
(OpenSource foreva :)
26. Светлый ум 270 14.06.21 08:59 Сейчас в теме
3. Fril 11.05.21 09:48 Сейчас в теме
Наименование кнопочки на скриншоте "ПодглАДеть", это всё-таки подглЯДеть или подглАЗеть? ;-)
За публикацию спасибо!
user803412; +1 Ответить
13. lepihin 48 12.05.21 17:07 Сейчас в теме
(3)Это скрин с опечатеой :) в обработке уже поправлено
4. gigabyte_artur 11.05.21 18:41 Сейчас в теме
Откройте ИР-ами и посмотрите. Это обычный регистр сведений, зачем такие сложности?
Прикрепленные файлы:
shard; tormozit; Award; NoRazum; GutaGroup; itoptimum; +6 Ответить
5. user713552 12.05.21 10:09 Сейчас в теме
А где взять такую консоль? Что такое " открыть ИР-ами?
8. link_l 19 12.05.21 13:35 Сейчас в теме
(5) Посмотрите здесь https://infostart.ru/public/15126/
так же если погуглить есть свой сайт
20. user603532_fan_club_chelsea 13.05.21 10:41 Сейчас в теме
(5) Инструмент разработчика... на инфостарте была для УФ где-то...
6. SeiOkami 2136 12.05.21 10:39 Сейчас в теме
7. Dementor 784 12.05.21 11:32 Сейчас в теме
(6) ИР в толстом клиенте, хотя очень криво.
Я предпочитаю для просмотра паролей консоли запросов/отчетов.
24. tormozit 6347 01.06.21 17:53 Сейчас в теме
(7)
хотя очень криво

Что там очень криво?
Ради того, чтобы посмотреть пароль, находясь в тонком клиенте, запускать толстый клиент конечно неоправдано, т.к. есть куча инструментов на тонких управляемых формах, способных решить ту же задачу.
11. gigabyte_artur 12.05.21 16:20 Сейчас в теме
(6) Функциональность ИР в УФ, конечно, более ограничена... Но конкретно с этой задачей справляется (см. скриншот)
Прикрепленные файлы:
TimkoNzt; +1 Ответить
12. SeiOkami 2136 12.05.21 16:49 Сейчас в теме
16. gigabyte_artur 12.05.21 21:47 Сейчас в теме
(12) Ок... Пересниму скриншот. Вот так понятнее? Демка типовой ERP + ИР в форме расширения.
Прикрепленные файлы:
17. SeiOkami 2136 12.05.21 22:28 Сейчас в теме
(16) вы, видимо, путаете понятия "режим запуска Управляемое приложение" и "управляемые формы"
18. SerVer1C 391 13.05.21 09:08 Сейчас в теме
21. user603532_fan_club_chelsea 13.05.21 10:48 Сейчас в теме
25. tormozit 6347 05.06.21 11:43 Сейчас в теме
14. lepihin 48 12.05.21 17:11 Сейчас в теме
(4)Ну например если доступ к базе только через WEB публикацию то ИР-ами будет проблематично воспользоваться
Возможно я отстал, неужели появились портативные ИР запускаемые на УФ?
19. SerVer1C 391 13.05.21 09:09 Сейчас в теме
22. lepihin 48 14.05.21 15:42 Сейчас в теме
(19)Спасибо большое!
Не зря написал статью :)
теперь и у меня есть УИ
23. tormozit 6347 01.06.21 17:46 Сейчас в теме
(4) Еще в ИР можно открыть динамический список этого регистра и двойным кликом открыть строку нужной учетной записи в редакторе объекта БД, дальше двойным кликом уже открыть значение ресурса с хранилищем значения.
gigabyte_artur; +1 Ответить
9. Бэнни 138 12.05.21 14:00 Сейчас в теме
мда, я уж было подумал, что сохраненное значение пароля из базы вынули...
10. papami 43 12.05.21 15:06 Сейчас в теме
(9) Да основная масса паролей легко вынимается. Они там хранятся в "безобразном" виде.
27. Rustig 1835 22.07.21 15:30 Сейчас в теме
(0) через групповое изменение реквизитов можно попробовать - для ут 10.3 такое прокатывало
Оставьте свое сообщение

См. также

Управление записями безопасного хранилища базы (имена, пароли и т.п., сохранененные в ИБ)

Администрирование данных 1С Пароли v8 Розница УНФ ERP2 БП3.0 УТ11 Абонемент ($m)

Обработка позволяет просматривать и редактировать записи безопасного хранилища базы, которые обычно содержат информацию, предназначенную для безопасного хранения (аутентификация на различных сервисах - ИТС, почта, синхронизация с другими базами и т.п.).

2 стартмани

10.07.2021    647    4    denmax    0    

Запуск 1С под другим пользователем без пароля

Инструментарий разработчика Пароли v8 v8::УФ 1cv8.cf Абонемент ($m)

Данная обработка позволяет запускать 1С под другими пользователя без указания пароля. Обычная и управляемая форма.

2 стартмани

01.11.2015    37547    278    karpik666    48