Обновление наименований ключей аналитики

Публикация № 1702486 29.07.22

Пользовательские инструменты - Адаптация типовых решений

Зачастую работая в базе несколько лет, у контрагентов изначальные наименования приводятся к корректным, синхронизируясь с ЕГРЮЛ, или же у договора меняется имя на корректное. Но программистам / аналитикам или консультантам приходится видеть ключи аналитики со старыми наименованиями. Для этого есть такая маленькая обработка, обновляющая наименования ключей аналитики.

Зачастую работая в базе несколько лет, у контрагентов изначальные наименования приводятся к корректным, синхронизируясь с ЕГРЮЛ, или же у договора меняется имя на корректное. Или же вы объединяли дубли разных контрагентов, анализируя проводки документов, вам выводится именно ключ аналитики, это может сбивать вас с толку. Программистам / аналитикам или консультантам приходится видеть ключи аналитики со старыми наименованиями. Для этого есть такая маленькая обработка, обновляющая наименования ключей аналитики. 

Это внешняя обработка, которая работает как регламентное задание, её можно прикрепить в справочник дополнительных отчётов и обработок, она будет работать как регламентное задание. Или же можно ее использовать просто через "Файл - Открыть" при необходимости. 

Код обработки открытый, суть простая, сначала во всех справочниках выполняется поиск дублей с помощью типовых процедур, после корректируется наименование, используя стандартные принципы его формирования.

Обработка будет работать на ERP 2.4.ххх и ERP 2.5.7 - 2.5.8 гарантированно, имена процедур генерации имени оставлены оригинальные, так что даже при использовании поздней версии (когда ее выпустят) можно будет за пару минут модернизировать код.

Код:


Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды) Экспорт
	
	Справочники.КлючиАналитикиУчетаНаборов.ЗаменитьДублиКлючейАналитики();	
	Справочники.КлючиАналитикиУчетаНоменклатуры.ЗаменитьДублиКлючейАналитики();	
	Справочники.КлючиАналитикиУчетаПартий.ЗаменитьДублиКлючейАналитики();	
	Справочники.КлючиАналитикиУчетаПоПартнерам.ЗаменитьДублиКлючейАналитики();
	
	// Вернуть нормальные имена АналитикаУчетаПоПартнерам
	Запрос = Новый Запрос();
	Запрос.Текст = 	
	"ВЫБРАТЬ
	|	ДанныеСправочника.Ссылка КАК Ссылка,
	|	ДанныеСправочника.ПометкаУдаления КАК ПометкаУдаления,
	|	Аналитика.КлючАналитики КАК КлючАналитики,
	|	ДанныеРегистра.Партнер КАК Партнер,
	|	ДанныеРегистра.Организация КАК Организация,
	|	ДанныеРегистра.Контрагент КАК Контрагент,
	|	ДанныеРегистра.Договор КАК Договор,
	|	ДанныеРегистра.НаправлениеДеятельности КАК НаправлениеДеятельности
	|ИЗ
	|	Справочник.КлючиАналитикиУчетаПоПартнерам КАК ДанныеСправочника
	|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.АналитикаУчетаПоПартнерам КАК ДанныеРегистра
	|		ПО ДанныеСправочника.Ссылка = ДанныеРегистра.КлючАналитики
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.АналитикаУчетаПоПартнерам КАК Аналитика
	|		ПО ДанныеСправочника.Партнер = Аналитика.Партнер
	|			И ДанныеСправочника.Организация = Аналитика.Организация
	|			И ДанныеСправочника.Контрагент = Аналитика.Контрагент
	|			И ДанныеСправочника.Договор = Аналитика.Договор
	|			И ДанныеСправочника.НаправлениеДеятельности = Аналитика.НаправлениеДеятельности
	|ГДЕ
	|	НЕ ДанныеРегистра.КлючАналитики ЕСТЬ NULL";	
	Результат = Запрос.Выполнить().Выбрать();  
	Пока Результат.Следующий() Цикл
		СправочникОбъект = Результат.Ссылка.ПолучитьОбъект();
		СправочникОбъект.Наименование = ПолучитьПолноеНаименованиеКлючаАналитики_АналитикаУчетаПоПартнерам(Результат); 
		Если СправочникОбъект.Наименование <> Результат.Ссылка.Наименование Тогда	
			Сообщить("АналитикаУчетаПоПартнерам --< " + Результат.Ссылка.Наименование);	
			Сообщить("АналитикаУчетаПоПартнерам --> " + СправочникОбъект.Наименование);	      
			СправочникОбъект.Записать();
		КонецЕсли;
	КонецЦикла;     
	
	// АналитикаУчетаНоменклатуры
	Запрос = Новый Запрос();
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ДанныеСправочника.Ссылка КАК Ссылка,
	|	ДанныеСправочника.ПометкаУдаления КАК ПометкаУдаления,
	|	Аналитика.КлючАналитики КАК КлючАналитики,
	|	ДанныеРегистра.Номенклатура КАК Номенклатура,
	|	ДанныеРегистра.Характеристика КАК Характеристика,
	|	ДанныеРегистра.Серия КАК Серия,
	|	ДанныеРегистра.МестоХранения КАК МестоХранения,
	|	ДанныеРегистра.Назначение КАК Назначение,
	|	ДанныеРегистра.СтатьяКалькуляции КАК СтатьяКалькуляции
	|ИЗ
	|	Справочник.КлючиАналитикиУчетаНоменклатуры КАК ДанныеСправочника
	|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.АналитикаУчетаНоменклатуры КАК ДанныеРегистра
	|		ПО ДанныеСправочника.Ссылка = ДанныеРегистра.КлючАналитики
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.АналитикаУчетаНоменклатуры КАК Аналитика
	|		ПО ДанныеСправочника.Номенклатура = Аналитика.Номенклатура
	|			И ДанныеСправочника.Характеристика = Аналитика.Характеристика
	|			И ДанныеСправочника.Серия = Аналитика.Серия
	|			И ДанныеСправочника.МестоХранения = Аналитика.МестоХранения
	|			И ДанныеСправочника.Назначение = Аналитика.Назначение
	|			И ДанныеСправочника.СтатьяКалькуляции = Аналитика.СтатьяКалькуляции
	|ГДЕ
	|	НЕ ДанныеРегистра.КлючАналитики ЕСТЬ NULL";
	Результат = Запрос.Выполнить().Выбрать();  
	Пока Результат.Следующий() Цикл
		СправочникОбъект = Результат.Ссылка.ПолучитьОбъект();
		СправочникОбъект.Наименование = ПолучитьПолноеНаименованиеКлючаАналитики_АналитикаУчетаНоменклатуры(Результат); 
		Если СправочникОбъект.Наименование <> Результат.Ссылка.Наименование Тогда	
			Сообщить("АналитикаУчетаНоменклатуры --< " + Результат.Ссылка.Наименование);	
			Сообщить("АналитикаУчетаНоменклатуры --> " + СправочникОбъект.Наименование);	      
			СправочникОбъект.Записать();
		КонецЕсли;
	КонецЦикла;      
	
	
	// АналитикаУчетаПартий
	Запрос = Новый Запрос();
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ДанныеСправочника.Ссылка КАК Ссылка,
	|	ДанныеСправочника.ПометкаУдаления КАК ПометкаУдаления,
	|	Аналитика.КлючАналитики КАК КлючАналитики,
	|	ДанныеРегистра.ГруппаФинансовогоУчета КАК ГруппаФинансовогоУчета,
	|	ДанныеРегистра.Поставщик КАК Поставщик,
	|	ДанныеРегистра.Контрагент КАК Контрагент,
	|	ДанныеРегистра.НалогообложениеНДС КАК НалогообложениеНДС,
	|	ДанныеРегистра.УдалитьСтавкаНДС КАК УдалитьСтавкаНДС,
	|	ДанныеРегистра.СтавкаНДС КАК СтавкаНДС,
	|	ДанныеРегистра.ВидЦенности КАК ВидЦенности,
	|	ДанныеРегистра.КодСтроки КАК КодСтроки
	|ИЗ
	|	Справочник.КлючиАналитикиУчетаПартий КАК ДанныеСправочника
	|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.АналитикаУчетаПартий КАК ДанныеРегистра
	|		ПО ДанныеСправочника.Ссылка = ДанныеРегистра.КлючАналитики
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.АналитикаУчетаПартий КАК Аналитика
	|		ПО ДанныеСправочника.ГруппаФинансовогоУчета = Аналитика.ГруппаФинансовогоУчета
	|			И ДанныеСправочника.Поставщик = Аналитика.Поставщик
	|			И ДанныеСправочника.Контрагент = Аналитика.Контрагент
	|			И ДанныеСправочника.НалогообложениеНДС = Аналитика.НалогообложениеНДС
	|			И ДанныеСправочника.СтавкаНДС = Аналитика.СтавкаНДС
	|			И ДанныеСправочника.ВидЦенности = Аналитика.ВидЦенности
	|			И ДанныеСправочника.КодСтроки = Аналитика.КодСтроки
	|ГДЕ
	|	НЕ ДанныеРегистра.КлючАналитики ЕСТЬ NULL";
	Результат = Запрос.Выполнить().Выбрать();  
	Пока Результат.Следующий() Цикл
		СправочникОбъект = Результат.Ссылка.ПолучитьОбъект();
		СправочникОбъект.Наименование = НаименованиеКлючаАналитики_АналитикаУчетаПартий(Результат); 
		Если СправочникОбъект.Наименование <> Результат.Ссылка.Наименование Тогда	
			Сообщить("АналитикаУчетаПартий --< " + Результат.Ссылка.Наименование);	
			Сообщить("АналитикаУчетаПартий --> " + СправочникОбъект.Наименование);	      
			СправочникОбъект.Записать();
		КонецЕсли;
	КонецЦикла;    	     
	
	// АналитикаУчетаНаборов
	Запрос = Новый Запрос();
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ДанныеСправочника.Ссылка КАК Ссылка,
	|	ДанныеСправочника.ПометкаУдаления КАК ПометкаУдаления,
	|	Аналитика.КлючАналитики КАК КлючАналитики,
	|	ДанныеРегистра.НоменклатураНабора КАК НоменклатураНабора,
	|	ДанныеРегистра.ХарактеристикаНабора КАК ХарактеристикаНабора
	|ИЗ
	|	Справочник.КлючиАналитикиУчетаНаборов КАК ДанныеСправочника
	|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.АналитикаУчетаНаборов КАК ДанныеРегистра
	|		ПО ДанныеСправочника.Ссылка = ДанныеРегистра.КлючАналитики
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.АналитикаУчетаНаборов КАК Аналитика
	|		ПО ДанныеСправочника.НоменклатураНабора = Аналитика.НоменклатураНабора
	|			И ДанныеСправочника.ХарактеристикаНабора = Аналитика.ХарактеристикаНабора
	|ГДЕ
	|	НЕ ДанныеРегистра.КлючАналитики ЕСТЬ NULL";
	Результат = Запрос.Выполнить().Выбрать();  
	Пока Результат.Следующий() Цикл
		СправочникОбъект = Результат.Ссылка.ПолучитьОбъект();
		СправочникОбъект.Наименование = ПолучитьПолноеНаименованиеКлючаАналитики_АналитикаУчетаНаборов(Результат); 
		Если СправочникОбъект.Наименование <> Результат.Ссылка.Наименование Тогда	
			Сообщить("АналитикаУчетаНаборов --< " + Результат.Ссылка.Наименование);	
			Сообщить("АналитикаУчетаНаборов --> " + СправочникОбъект.Наименование);	      
			СправочникОбъект.Записать();
		КонецЕсли;
	КонецЦикла; 
	
КонецПроцедуры  
	
Функция ПолучитьПолноеНаименованиеКлючаАналитики_АналитикаУчетаПоПартнерам(МенеджерЗаписи)
	
	Наименование = "";
	
	МетаданныеИзмерения = Метаданные.РегистрыСведений.АналитикаУчетаПоПартнерам.Измерения;
	Для Каждого Измерение Из МетаданныеИзмерения Цикл
		
		// Получим представление значения, которое указано в измерении регистра сведений.
		ТекстЗначения = Строка(МенеджерЗаписи[Измерение.Имя]);
		Если Не ПустаяСтрока(ТекстЗначения) Тогда
			Наименование = Наименование + ТекстЗначения + "; ";
		КонецЕсли;
		
	КонецЦикла;
	
	Если Прав(Наименование, 2) = "; " Тогда
		Наименование = Лев(Наименование, СтрДлина(Наименование) - 2);
	КонецЕсли;
	
	Возврат Наименование;
	
КонецФункции          

Функция ПолучитьПолноеНаименованиеКлючаАналитики_АналитикаУчетаНоменклатуры(МенеджерЗаписи)

	Возврат СокрЛП(МенеджерЗаписи.Номенклатура) + "; " 
		+ ?(ЗначениеЗаполнено(МенеджерЗаписи.Характеристика), СокрЛП(МенеджерЗаписи.Характеристика) + "; ", "")
		+ ?(ЗначениеЗаполнено(МенеджерЗаписи.Серия), СокрЛП(МенеджерЗаписи.Серия) + "; ", "")
		+ ?(ЗначениеЗаполнено(МенеджерЗаписи.Назначение), СокрЛП(МенеджерЗаписи.Назначение) + "; ", "")
		+ ?(ЗначениеЗаполнено(МенеджерЗаписи.СтатьяКалькуляции), СокрЛП(МенеджерЗаписи.СтатьяКалькуляции) + "; ", "")
		+ СокрЛП(МенеджерЗаписи.МестоХранения);

КонецФункции

Функция НаименованиеКлючаАналитики_АналитикаУчетаПартий(СтруктураРеквизитовКлюча)
	
	Наименование = "";
		
	Если ЗначениеЗаполнено(СтруктураРеквизитовКлюча.ГруппаФинансовогоУчета) Тогда
		Наименование = Наименование + НСтр("ru = 'Группа';
											|en = 'Group'") + ": " + СтруктураРеквизитовКлюча.ГруппаФинансовогоУчета + "; ";
	КонецЕсли;
	
	Если ЗначениеЗаполнено(СтруктураРеквизитовКлюча.Поставщик) Тогда
		Наименование = Наименование + НСтр("ru = 'Поставщик';
											|en = 'Vendor'") + ": " + СтруктураРеквизитовКлюча.Поставщик + "; ";
	КонецЕсли;
	
	Если ЗначениеЗаполнено(СтруктураРеквизитовКлюча.Контрагент) Тогда
		Наименование = Наименование + НСтр("ru = 'Контрагент';
											|en = 'Counterparty'") + ": " + СтруктураРеквизитовКлюча.Контрагент + "; ";
	КонецЕсли;
	
	Если ЗначениеЗаполнено(СтруктураРеквизитовКлюча.НалогообложениеНДС) Тогда
		Наименование = Наименование + НСтр("ru = 'Налогообложение НДС';
											|en = 'VAT taxation'") + ": " + СтруктураРеквизитовКлюча.НалогообложениеНДС + "; ";
	КонецЕсли;
		
	Если ЗначениеЗаполнено(СтруктураРеквизитовКлюча.СтавкаНДС) Тогда
		Наименование = Наименование + НСтр("ru = 'Ставка НДС';
											|en = 'VAT rate'") + ": " + СтруктураРеквизитовКлюча.СтавкаНДС + "; ";
	КонецЕсли;  	
   		
	Если ЗначениеЗаполнено(СтруктураРеквизитовКлюча.ВидЦенности) Тогда
		Наименование = Наименование + НСтр("ru = 'Вид ценности';
											|en = 'Asset tax class'") + ": " + СтруктураРеквизитовКлюча.ВидЦенности + "; ";
	КонецЕсли;  	
	
	Если ЗначениеЗаполнено(СтруктураРеквизитовКлюча.КодСтроки) Тогда
		Наименование = Наименование + НСтр("ru = 'Код строки (продукция)';
											|en = 'Line code (manufactured products)'") + ": " + СтруктураРеквизитовКлюча.КодСтроки;
	КонецЕсли;
	
	Наименование = СокрЛП(Наименование);
	
	Если Прав(Наименование, 1) = ";" Тогда
		Наименование = СокрЛП(Сред(Наименование, 1, СтрДлина(Наименование) - 1));
	КонецЕсли;
	
	Если НЕ ЗначениеЗаполнено(Наименование) Тогда
		Наименование = "<>";
	КонецЕсли;
	
	Возврат Наименование;
	
КонецФункции
	
Функция ПолучитьПолноеНаименованиеКлючаАналитики_АналитикаУчетаНаборов(МенеджерЗаписи)

	Возврат СокрЛП(МенеджерЗаписи.НоменклатураНабора) + "; " 
		+ ?(ЗначениеЗаполнено(МенеджерЗаписи.ХарактеристикаНабора), СокрЛП(МенеджерЗаписи.ХарактеристикаНабора), "");

КонецФункции

Чтобы было понимание, насколько это актуально, вот, например, из демоверсии ERP 2.5.8 часть результата выполнения обработки, видно, что было и что стало.

 

 

 

Изначально, разумеется, рекомендуется посмотреть на результат на тестовой базе. Но обработка работает по типовым принципам, и шанс сбоя ничтожен. 

Скачать файлы

Наименование Файл Версия Размер
Обновление наименований ключей аналитки. :

.epf 8,96Kb
3
.epf 8,96Kb 3 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Хранение файлов в томах на диске (для УПП 1.3) Промо

Адаптация типовых решений Платформа 1С v8.3 1С:Управление производственным предприятием Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    75750    20    wowik    33    

Физлицо сотрудника и список сотрудников по физлицу

Адаптация типовых решений Кадровый учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Абонемент ($m)

О том как быстро сделать расширение, отображающее взаимосвязь физлиц и сотрудников. И мой вариант (протестирован на 8.3.22.1368, Зарплата и управление персоналом, редакция 3.1 (3.1.23.68) и (3.1.18.616)).

1 стартмани

17.09.2022    562    0    niko11s    0    

Множественные дополнительные реквизиты для УТ 11

Адаптация типовых решений Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Готовое расширение для множественного дополнительного реквизита в УТ 11.

3 стартмани

06.09.2022    506    3    nemec    0    

Присоединенные файлы в 1С:Бухгалтерии в расширении

Адаптация типовых решений Платформа 1С v8.3 1С:Бухгалтерия 3.0 Россия Абонемент ($m)

Столкнулся с необходимостью добавить возможность прикреплять файлы в конфигурации 1С:Бухгалтерия предприятия, находящейся на поддержке. Разработал расширение, которое можно подключить к конфигурации не снимая ее с поддержки, и реализовать функционал присоединенных файлов к любому документу системы.

5 стартмани

05.09.2022    506    4    NightBreez    5    

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11) Промо

Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11)

1 стартмани

28.03.2013    162820    548    Stradivari    31    

Параметризация печатных форм под контрагентов (подключаемое расширение)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Расширение добавляет возможности параметризации печати для контрагентов. Подробнее описано здесь https://infostart.ru/1c/articles/1510459/

10 стартмани

05.08.2022    4159    4    sapervodichka    4    

Загрузка банка (дополнительный парсинг)

Обмен с интернет-банком Адаптация типовых решений Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Данное расширение позволяет производить дополнительное изменение при загрузке банковских документов. Изменение конфигурации - не требуется.

5 стартмани

02.08.2022    955    1    sulig    6    

Просмотр объектов очереди сообщений в 1С:Документооборот

Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В базах с бесшовной интеграцией с 1С:Документооборот есть Регистр сведений "Очередь сообщений в 1С:Документооборот". Для пользователя он мало информативен. Расширение позволяет просматривать сообщение в человеческом виде. И понимать проблему до объекта.

1 стартмани

02.08.2022    4044    13    sapervodichka    4    

Отправка сообщений пользователям Промо

Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 10 Россия Абонемент ($m)

Предполагаю, что в организациях, где работает больше 10-15 человек, сложно звонить каждому и сообщать пользователям какую-либо информацию. Я обыскал на всех ресурсах, так того, что требуется, не нашел.

1 стартмани

13.01.2012    19554    374    kojinandrej    54    

Cчет на оплату выводит шапку "Банковские реквизиты / BANK INFORMATION"

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 Абонемент ($m)

При печати счета на оплату выводит шапку "ОбразецЗаполненияРеквизитыБанка", причины и пути решения.

1 стартмани

11.07.2022    662    1    osa92    0    

Видимость переключателя Без закрывающих документов

Адаптация типовых решений Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

В 1С:Бухгалтерии в банковских выписках в документах поступление на расчетный счет есть переключатель - Учет без закрывающих документов. Его удобно использовать для УСН доходы или патента. Однако при определённых настройках он не виден на форме. Расширение включает видимость этого переключателя для любых СНО.

1 стартмани

07.07.2022    982    4    de0nis    0    

Исправление ошибки РДИК_0333

Адаптация типовых решений Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Исправление ошибки РДИК_0333 при выгрузке документов в ЕИС.

1 стартмани

05.07.2022    1968    31    oleg-x    6    

Добавление строк в регистрации обязательств по договорам с разными ИФО. БГУ 2.0

Адаптация типовых решений Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия государственного учреждения Государственные, бюджетные структуры Бухгалтерский учет Бюджетный учет Абонемент ($m)

Иногда нужно и очень хочется добавить принимаемые обязательства по одному договору, но по нескольким ИФО, но БГУ 2.0 не дает это сделать, а жаль! В результате приходится заводить одинаковые договоры или создавать бухгалтерскую операцию, ну или корректировать проводки вручную - плохо! С помощью расширения решим это и сможем добавлять строки с разными ИФО.

3 стартмани

30.06.2022    904    6    VID1234    0    

Выгрузка документов в формате XML для загрузки в ЭДО операторов СБИС, Диадок и т.п.

Адаптация типовых решений Файловые протоколы обмена (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 Россия Абонемент ($m)

Расширение для добавления дополнительного функционала в библиотеку БЭД , добавляет команду для выгрузки данных в формате XML для загрузки в ЭДО из 1С.

3 стартмани

30.06.2022    1327    13    osa92    7    

Исправление обработки Подбор номенклатуры в Бухгалтерии для Беларуси, редакция 2.1.42.8

Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Беларусь Бухгалтерский учет Абонемент ($m)

В версии 1С 8.3 Бухгалтерия для Беларуси 2.1.42.8 обнаружена ошибка в подборе номенклатуры (из любого документа): независимо от выбранного количества номенклатуры в форму попадает единица.

1 стартмани

15.06.2022    895    1    1v7    2    

Критерии отбора в расширении. 16+

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Связываем критерии отбора расширения с типовой структурой подчиненности в универсальных решениях 1С.

3 стартмани

09.06.2022    2598    14    Ankare    10    

Обезжиривание шрифта в печатной форме (экономим тонер)

Печатные формы Адаптация типовых решений Платформа 1С v8.3 1С:Бухгалтерия 3.0 Абонемент ($m)

Код, который убирает полужирное начертание у шрифтов в печатной форме. Тестировалось на конфигурации Бухгалтерия Предприятия 3.0.111.16. Но должно работать на любых конфигурациях с БСП.

1 стартмани

24.05.2022    1294    1    q_i    4    

Присоединение внешней печатной формы в виде файла к объекту-основанию

Печатные формы Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В данной публикации речь пойдёт о том, как можно присоединить сформированную внешнюю печатную форму в виде файла к тому объекту (справочнику, документу и т.п.), на основании которого она была сформирована.

1 стартмани

20.05.2022    1766    1    delta    0    

Шаблон этикетки для УНФ (1С:Фреш)

Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Описан механизм создания этикетки для термопринтера ТSC TDP-225 в подробностях. Приложен XML-файл с самим шаблоном.

1 стартмани

01.05.2022    2330    0    zemskov    0    

ЗУП: История изменения контактной информации для организации

Адаптация типовых решений Платформа 1С v8.3 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Абонемент ($m)

История изменения контактной информации для организации в конфигурации ЗУП.

1 стартмани

23.03.2022    2039    1    MaxxiMiliSan    0    

Внутренний оборот тары при перемещениях. УТ 11.4

Оптовая торговля Розничная торговля Склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Внутренний оборот тары при перемещениях для Управления торговлей 11.4, которого почему-то нет в конфигурации из коробки.

2 стартмани

16.03.2022    2151    0    13D    0    

Отключение системных команд "Печать, Предварительный просмотр, Сохранить", которые по умолчанию отображаются с релиза 8.3.15

Универсальные функции Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

В УТ 11 возникла необходимо при печати чека отключить системные команды Печать, Предварительный просмотр, Сохранить. Задача: отключить возможность у пользователя (кассира) печатать документы реализации (Товарный чек или Реализацию) в количестве более 1 экземпляра.

1 стартмани

16.02.2022    2858    1    whitevolta    0    

Моментальный поиск документов при сканировании штрих-кода, замена штрих-кода на QR код, QR-кодирование печатных форм в 1С: Управление нашей фирмой (УНФ)

Адаптация типовых решений Обработка документов Поиск данных Платформа 1С v8.3 1С:Управление нашей фирмой Россия Абонемент ($m)

Моментальный поиск документов при сканировании штрих-кода, замена штрих-кода на QR код, QR-кодирование печатных форм в 1С: Управление нашей фирмой (УНФ) для мобильного приложения.

1 стартмани

11.02.2022    2212    2    1c-krund    2    

БСП 3.1.5 Форма отчета. Быстрый вызов редактирования варианта

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В последних релизах современных конфигураций, основанных на БСП версии 3.1.5, спрятали кнопку настройки варианта в дебри вложенных форм. Вернём всё как было, и даже лучше.

1 стартмани

20.12.2021    4042    1    the1    0    

Доработка документа для формирования проводок в регламентированном учете ERP

Адаптация типовых решений Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Бухгалтерский учет Абонемент ($m)

Статья о том, как включить разработанный документ в подсистему формирования проводок в конфигурации ERP

1 стартмани

17.12.2021    5962    5    maraty    6    

Отображение ОГРН в карточке контрагента. УТ 11

Обработка справочников Адаптация типовых решений Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Возможность заполнения и отображения уже заполненного ОГРН из сервиса 1С:Контрагенты (расширение).

1 стартмани

11.11.2021    2204    5    pridecom    0    

Настраиваемый комплект документов по Грузополучателю/Контрагенту Расходной накладной. 1С: УНФ 1.6

Адаптация типовых решений Пакетная печать Платформа 1С v8.3 1С:Управление нашей фирмой Россия Абонемент ($m)

Расширение сохраняет настройки "Настраиваемого комплекта документов" по Грузополучателю или Контрагенту Расходной накладной.

1 стартмани

08.11.2021    3070    2    DimanZ    0    

Удаление подчиненных документов, по структуре подчиненности 1С 8.3. Расширение.

Адаптация типовых решений Чистка данных Обработка документов Платформа 1С v8.3 Конфигурации 1cv8 1С:Розница 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Абонемент ($m)

При удалении документов в 1С документы, которые были подчинены удаляемому документу, остаются проведенными, что не всегда удобно.

2 стартмани

22.10.2021    3294    6    ClickUp    0    

Автоматическая установка времени в документах

Обработка документов Адаптация типовых решений Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Расширение позволяет настроить, чтобы тот или иной документ записывался в базе строго с определённым временем. Более того, имеется возможность настроить несколько условий для одного типа документов.

3 стартмани

22.10.2021    3009    5    RSConsulting    0    

Заполнение реализации и поступления из Excel

Загрузка и выгрузка в Excel Адаптация типовых решений Платформа 1С v8.3 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Расширение конфигурации позволяет заполнять документы: реализация товаров и поступление товаров данными из файла Excel, а также убирает рекламу от 1С при начале работы. Тестировалось на платформе 1С:Предприятие 8.3 (8.3.16.1814) / Конфигурация: Бухгалтерия предприятия, редакция 3.0 (3.0.95.29)

1 стартмани

01.09.2021    2792    7    Adept1C    2    

1С УНФ 1.6 Рабочая дата

Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой Россия Абонемент ($m)

Расширение добавляет в настройки пользователя 1С УНФ параметр Рабочая дата, действующий при создании новых документов.

1 стартмани

31.08.2021    3820    15    DimanZ    4    

Загрузка данных из внешних файлов для управляемых форм

Загрузка и выгрузка в Excel Адаптация типовых решений Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Простая и удобная обработка загрузки из файлов формата Excel, dbf и csv для конфигураций на управляемых формах (без модальности). Встраивается в любую конфигурацию (на управляемых формах) в любое место, где нужна загрузка из файлов.

2 стартмани

29.08.2021    4034    19    ALBA2009    2    

Где баланс между производительностью и возможностями программы ? Исправление автоподбора контрагента в УНФ

Рефакторинг и качество кода HighLoad оптимизация Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой Россия Управленческий учет Абонемент ($m)

Как и у многих ко мне стали поступать обращения от менеджеров о медленной работе 1с (эта ваша один с не дает нормально работать), и чтоб быть объективным, и не основываться на человеческом, субъективном восприятии решил вооружиться цифрами, а именно произвести анализ медленных запросов, и проблема была найдена, где я ее не ожидал.

1 стартмани

27.08.2021    4385    0    con-men    0