Групповая замена основного менеджера по группе доступа

Публикация № 1702785 29.07.22

Системное администрирование - Роли и права

Менеджеры группа доступа групповая обработка партнер клиент

Для корректной работы должно быть включено ограничение на уровне записей и группы доступа партнеров. Обработка позволяет изменить основного менеджера сразу у всех партнеров с определенной группой доступа. Пригодится, если вам нужно передать всех партнеров уволившегося менеджера новому сотруднику, или просто перераспределить клиентов между менеджерами.

Замена основного менеджера по группе доступа

 

 

Отбор партнеров производится по реквизиту «Группа доступа». Если группа не выбрана, тогда партнеры подобраны не будут. При изменении группы доступа таблица с партнерами очищается.

По кнопке «Подобрать клиентов» заполняется таблица всеми партнерами выбранной группы. В колонке «Новый менеджер» устанавливается значение из поля «Менеджер по умолчанию».

Если выбран менеджер в поле «Дополнительный отбор», тогда будут подобраны только те клиенты, у которых выбранный сотрудник указан в качестве основного менеджера.

В полях «По менеджеру» и «Менеджер по умолчанию» доступны для выбора только те сотрудники, для которых разрешена работа с выбранной группой доступа по партнерам.

При нажатии кнопки «Выполнить замену» обрабатываются только те строки, в которых стоит отметка в колонке «Изменить». Если колонка «Новый менеджер» в строке заполнена, тогда в карточку партнера будет записан указанный новый менеджер. Если значение колонки пустое, тогда в карточку партнера будет записан менеджер по умолчанию из шапки формы.

Заполнение списка выбора менеджеров:

Запрос = Новый Запрос;
	
	Запрос.Текст =    
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	ГруппыДоступаПользователи.Пользователь КАК Ссылка
	|ИЗ
	|	Справочник.ГруппыДоступа.ЗначенияДоступа КАК ГруппыДоступаЗначенияДоступа
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.ГруппыДоступа.Пользователи КАК ГруппыДоступаПользователи
	|		ПО ГруппыДоступаЗначенияДоступа.Ссылка = ГруппыДоступаПользователи.Ссылка
	|ГДЕ
	|	ГруппыДоступаЗначенияДоступа.ЗначениеДоступа = &ГруппаДоступа
	|	";
	
	Запрос.УстановитьПараметр("ГруппаДоступа", Объект.ГруппаДоступа);
	
	РезультатЗапроса = Запрос.Выполнить().Выгрузить();
	Объект.ДоступныеМенеджеры.ЗагрузитьЗначения(РезультатЗапроса.ВыгрузитьКолонку("Ссылка"));
	
	СписокАктуальных = Новый Массив;
	Для Каждого Стр Из РезультатЗапроса Цикл
		Если Стр.Ссылка.Недействителен Тогда
			//пропуск
		Иначе
			СписокАктуальных.Добавить(Стр.Ссылка);
		КонецЕсли;
	КонецЦикла;

Запрос по партнерам:

Запрос.Текст = 
	"ВЫБРАТЬ
	|	Партнеры.Ссылка КАК Партнер,
	|	Партнеры.ОсновнойМенеджер КАК Менеджер,
	|	Партнеры.ОсновнойМенеджер.Недействителен КАК Недействителен,
	|	&НовыйМенеджер КАК НовыйМенеджер
	|ИЗ
	|	Справочник.Партнеры КАК Партнеры
	|ГДЕ
	|	Партнеры.ОсновнойМенеджер В(&Менеджеры)
	|	И ВЫБОР
	|			КОГДА &ПоМ
	|				ТОГДА Партнеры.ОсновнойМенеджер = &ПоМенеджеру
	|			ИНАЧЕ ИСТИНА
	|		КОНЕЦ
	|	И Партнеры.ГруппаДоступа = &ГруппаДоступа";

Изменение основного менеджера:

&НаСервере
Процедура ПоменятьОсновногоМенеджераНаСервере()
	
	СколькоИзменили = 0;
	
	Для Каждого Стр Из Объект.Клиенты Цикл
		Если Стр.Изменить Тогда
			
			Если ЗначениеЗаполнено(Стр.НовыйМенеджер) Тогда
				СпрОбъект = Стр.Партнер.ПолучитьОбъект();
				СпрОбъект.ОсновнойМенеджер = Стр.НовыйМенеджер;
				СпрОбъект.Записать();
			ИначеЕсли ЗначениеЗаполнено(Объект.МенеджерПоУмолчанию) Тогда
				СпрОбъект = Стр.Партнер.ПолучитьОбъект();
				СпрОбъект.ОсновнойМенеджер = Объект.МенеджерПоУмолчанию;
				СпрОбъект.Записать();
			КонецЕсли;	
			
		КонецЕсли;
	КонецЦикла;
	
	ЗаполнитьДоступныхКлиентов();
	
КонецПроцедуры

Протестировано на Управление торговлей, редакция 11 (11.4.13.227) и 1С:ERP Управление предприятием 2 (2.5.7.324), платформа 1С:Предприятие 8.3 (8.3.20.1789).

Подключается как дополнительная внешняя обработка через БСП.

Скачать файлы

Наименование Файл Версия Размер
Групповая замена основного менеджера по группе доступа:

.epf 12,83Kb
0
.epf 12,83Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

История ролей пользователей

Роли и права Email рассылки Платформа 1С v8.3 1С:ERP Управление предприятием 2 Россия Абонемент ($m)

Расширение позволяет записывать историю ролей назначенных пользователям, а также делать рассылки изменений этих ролей по почте.

1 стартмани

31.08.2022    636    2    Silenser    0    

Фильтр документов по автору документа для УНФ

Адаптация типовых решений Роли и права Платформа 1С v8.3 1С:Управление нашей фирмой Россия Абонемент ($m)

Расширение для ограничения видимости документов по пользователям.

1 стартмани

31.05.2022    1063    5    shira84    1    

Универсальный анализ и управление ролями

Инструменты администратора БД БСП (Библиотека стандартных подсистем) Роли и права Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Универсальный анализ прав доступа (без RLS) по ролям конфигурации. Работает с конфигурациями на библиотеке стандартных подсистем.

1 стартмани

27.04.2022    1660    15    denmp    0    

Авторизация в мобильном приложении 1С

Роли и права Мобильная разработка Платформа 1С v8.3 Мобильная платформа Конфигурации 1cv8 Абонемент ($m)

Реализация входа по паролю (личному коду) в мобильном приложении 1С.

10 стартмани

23.02.2021    9431    6    kaiman_fedor_yandex    0    

Создание новых пользователей копированием существующих с копированием настроек. Управляемая форма

Роли и права Универсальные обработки Управляемые формы Управление правами Конфигурации 1cv8 Абонемент ($m)

Обработка в помощь администраторам. Позволяет осуществлять быстрое создание новых пользователей путем копирования старых, с копированием настроек и дополнительных прав.

1 стартмани

30.10.2020    5050    5    iCortezik    0    

Отражение зарплаты в бухгалтерском учете: права старшего расчетчика

Зарплата Обработка документов Роли и права Сложные периодические расчеты Управление правами 1С:Зарплата и Управление Персоналом 3.x Бухгалтерский учет Абонемент ($m)

В ЗУП 3.1.14.208 пользователь с правами старшего расчетчика не может заполнить документ "Отражение зарплаты в бухучете". Проблему можно решить с помощью расширения.

1 стартмани

07.10.2020    4828    0    Hla    0    

Расширение для запрета изменений в документе "Регистрация трудовой деятельности" по дате запрета.

Адаптация типовых решений Роли и права Платформа 1С v8.3 1С:Зарплата и Управление Персоналом 3.x Россия Абонемент ($m)

В ЗУП 3.1.14.183 оставлена возможность отменить проведение и провести заново для документа "Регистрация трудовой деятельности" из списка документов, чем сотрудники отдела кадров успешно пользуются. Позже они возмущаются, что появляется несколько одинаковых записей отмены и такая же для отправки по сотруднику в "мероприятиях" при заполнении документа "Сведения о трудовой деятельности работников, СЗВ-ТД". Расширение устанавливает запрет на изменения по общей дате запрета, если нет отдельно по пользователю. Никакие изменения в основную конфигурацию вносить не нужно, просто добавляете расширение.

1 стартмани

07.09.2020    4870    1    Svetlanka_sv    0    

Ограничение доступа по контрагентам для Бухгалтерии (RLS) 3.0.121.23 - менеджер видит продажи и взаиморасчеты только своих контрагентов,

Адаптация типовых решений Роли и права Платформа 1С v8.3 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Расширение предназначено для Бухгалтерии 8 ред. 3.0. Типовая конфигурация остается на поддержке (с замком). Решает оно следующую задачу: Менеджеры по продажам должны видеть документы и отчеты только по контрагентам, которых они ведут. (через группу доступа).

5 стартмани

27.02.2020    14545    77    teyana    52    

Установка даты запрета на любое число дней

Инструменты администратора БД Роли и права Платформа 1С v8.3 1С:Управление торговлей 11 Абонемент ($m)

Примитивная обработка для установки даты запрета на произвольное число дней от текущей даты для всех пользователей

1 стартмани

29.10.2019    6059    4    Kutuzov    0    

Оптимизация прав ролей

HighLoad оптимизация Роли и права Управляемые формы Управление правами Конфигурации 1cv8 Россия Абонемент ($m)

Решение вопроса по неоптимальной настройке (избыточной) ролей, влияющей на производительность системы (потребление оперативной памяти). Алгоритм работы следующий: Выгрузка конфигурации в файлы - Обработка (изменение) файлов прав ролей - Загрузка измененных прав в конфигурацию. Проверено на платформе начиная с 8.3.12.

1 стартмани

09.09.2019    50209    12    toxilamer    11    

Конфигурация: Управление базами данных 1.2 (Групповое добавление пользователя в ИБ, Групповое обновление типовых конфигураций) для 8.2, 8.3

Инструменты администратора БД Роли и права Платформа 1С v8.3 Управляемые формы Управление правами Конфигурации 1cv8 Абонемент ($m)

Возможности: 1. Позволяет получить информацию о версии, количестве активных пользователей, список активных пользователей. 2. Имеет функцию группового добавления/удаления пользователей в любые конфигурации 3. Имеет функцию группового обновления типовых конфигураций(только файлы 1cv8.cfu, в новой версии можно и по выбору файла *.cf), умеет искать нужное обновление. Пакетное обновление до актуальной версии. 4. Групповое выполнение произвольного алгоритма 5. Групповая загрузка файлов *xml, выгруженных через стандартную обработку ВыгрузкаЗагрузкаДанныхXML.epf (Тестировалась только в 8.2) 6. Групповая выгрузка в *.dt, *.cf 7. Групповой запуск в режиме 1С: Предприятие, Конфигуратор. 8. Установка и снятие блокировки регламентных заданий (только в клиент-серверных ИБ) 9. Групповая загрузка из *.dt 10. Добавление баз из файла ibases.v8i

3 стартмани

09.03.2016    17566    100    Andruykha    30    

Чистка хранилища настроек пользователей (для управляемых форм)

Чистка данных Роли и права Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Обработка для чистки стандартного хранилища настроек пользователей в управляемом интерфейсе

1 стартмани

05.05.2015    5931    84    welder    6    

Проверка шаблонов ограничений (RLS для 1С 8.2-8.3)

Инструментарий разработчика Роли и права Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Теперь, чтобы получить конечный запрос на таблицу, которую пользователь сможет получить после отработки RLS ограничений, вам ничего не надо придумывать.

2 стартмани

15.03.2014    41721    613    frutty    40