БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Публикация № 525648 18.05.16

Разработка - Инструментарий разработчика

фоновое выполнение внешняя обработка длительная операция БСП

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

Не секрет, что после запуска "тяжелой" обработки хочется продолжать работать в программе, а также "видеть" время от времени сам процесс выполнения. Для простого пояснения, как это реализовано, и предназначена эта статья. Если ваша конфигурация не на БСП 2.3.2, можно сразу перейти, например, на эту статью //develop.iservice.ru/public/157706/ 

Важно! Обработка должна использоваться только через штатный механизм БСП "Дополнительные отчеты и обработки".

Код модуля обработки

Примечание: обработку можно запустить как из формы (см. представление команды "Открыть форму и выполнить в фоне с индикацией") так и сразу на сервере (см представление команды "Выполняем на сервере"). Запуск непосредственно на сервере можно сделать по расписанию.

// Возвращает сведения о внешней обработке.
Функция СведенияОВнешнейОбработке() Экспорт
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
	ПараметрыРегистрации.Версия = "2.1";
	ПараметрыРегистрации.БезопасныйРежим = Истина;
	
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Выполняем на сервере'");
	НоваяКоманда.Идентификатор = "ВыполнениеНаСервереОбработку";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Открыть форму и выполнить в фоне с индикацией'");
	НоваяКоманда.Идентификатор = "ОткрытьФормуОбработку";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
	НоваяКоманда.ПоказыватьОповещение = Ложь;
	
	Возврат ПараметрыРегистрации;
КонецФункции

// Интерфейс для выполнения команд обработки.
Процедура ВыполнитьКоманду(ИмяКоманды,ПараметрыВыполнения) Экспорт
	ДатаЗавершенияВМиллисекундах = ТекущаяУниверсальнаяДатаВМиллисекундах() + 1000*10;
	
	Попытка
		СтандартныеПодсистемыКлиентСервер.ВывестиОповещение(
		ПараметрыВыполнения.РезультатВыполнения,
		НСтр("ru = 'Выполнена длит. операция!'"),,
		БиблиотекаКартинок.Успешно32);
	Исключение
		СтандартныеПодсистемыКлиентСервер.ВывестиИнформациюОбОшибке(
		ПараметрыВыполнения.РезультатВыполнения,
		СтрШаблон(НСтр("ru = 'Ошибка выполнения команды ""%1""'"), ИмяКоманды),
		ИнформацияОбОшибке());
		Возврат;
	КонецПопытки;
	
	 //Имитация длительной операции - вместо этого вставте свой код который будет выполняться на сервере в фоне
	Пока ТекущаяУниверсальнаяДатаВМиллисекундах() < ДатаЗавершенияВМиллисекундах Цикл
	КонецЦикла;
КонецПроцедуры

Код модуля формы обработки

Важно добавить в форму эти параметры:

  • ДополнительнаяОбработкаСсылка (тип "СправочникСсылка.ДополнительныеОтчетыИОбработки").
  • ИдентификаторКоманды (тип "Строка")

.. и эти реквизиты:

  • ОбъектСсылка (тип "СправочникСсылка.ДополнительныеОтчетыИОбработки")
  • ИдентификаторКоманды (тип "Строка")
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ОбъектСсылка = Параметры.ДополнительнаяОбработкаСсылка;
	ИдентификаторКоманды = Параметры.ИдентификаторКоманды;
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
	Если ИсточникВыбора.ИмяФормы = ДополнительныеОтчетыИОбработкиКлиент.ИмяФормыДлительнойОперации() Тогда
		ЗагрузитьРезультат(ВыбранноеЗначение);
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура Фигачить(Команда)
	ПараметрыКоманды = Новый Структура("ДополнительнаяОбработкаСсылка, СопровождающийТекст");
	ПараметрыКоманды.ДополнительнаяОбработкаСсылка = ОбъектСсылка;
	ПараметрыКоманды.СопровождающийТекст = НСтр("ru = 'Выполняем из формы в фоне...'");
	Состояние(ПараметрыКоманды.СопровождающийТекст);
	ДополнительныеОтчетыИОбработкиКлиент.ВыполнитьКомандуВФоне(ИдентификаторКоманды, ПараметрыКоманды, ЭтаФорма);	
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьРезультат(РезультатВыполнения)
	Если Открыта() Тогда
	   Закрыть();
	КонецЕсли;
	ДополнительныеОтчетыИОбработкиКлиент.ПоказатьРезультатВыполненияКоманды(ВладелецФормы, РезультатВыполнения);
КонецПроцедуры

&НаСервере
Функция ВыполнитьКомандуНапрямую(ИдентификаторКоманды, ПараметрыКоманды)
	Возврат ДополнительныеОтчетыИОбработки.ВыполнитьКомандуИзФормыВнешнегоОбъекта(ИдентификаторКоманды, ПараметрыКоманды, ЭтаФорма);
КонецФункции

Примечание: для формы нужно назначить обработчики событий для процедур "ПриСозданииНаСервере" и "ОбработкаВыбора".

Вот, собственно, и все...

З.Ы. Для тех, кому недостаточно "простого" описания и кто хочет подробно разобраться в предмете - см. описание с ИТС

 

UPDATE 20/09/19: добавил вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

Немного тут подсмотрел

Модуль обработки:

Процедура ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения) Экспорт
	
	Если ИмяКоманды = "ОткрытьФормуОбработку" Тогда
		
		ВремяФиниша = ТекущаяДатаСеанса() + 100;
		Пока ТекущаяДатаСеанса() < ВремяФиниша Цикл
			Процент = 100 - (ВремяФиниша - ТекущаяДатаСеанса());
			Если НЕ (Процент % 10)  Тогда
				ДлительныеОперации.СообщитьПрогресс(Процент, СтрШаблон("Выполнено %1 процентов: пример параметра команды = %2", Процент,ПараметрыВыполнения.СвойПараметр));
			КонецЕсли;
		КонецЦикла; 
		
	КонецЕсли;
	
КонецПроцедуры

Модуль формы:

  &НаСервере
Функция ФигачитьВФоне(ВыполняемаяКоманда, УникальныйИдентификатор)
	
	ПараметрыПроцедуры = Новый Структура("ДополнительнаяОбработкаСсылка, ИдентификаторКоманды, СвойПараметр");
	ПараметрыПроцедуры.ДополнительнаяОбработкаСсылка = ВыполняемаяКоманда.Ссылка;
	ПараметрыПроцедуры.ИдентификаторКоманды          = ВыполняемаяКоманда.Идентификатор;
	ПараметрыПроцедуры.СвойПараметр                  = ВыполняемаяКоманда.СвойПараметр;
	
	ПараметрыВыполнения = ДлительныеОперации.ПараметрыВыполненияВФоне(УникальныйИдентификатор);
	
	Возврат ДлительныеОперации.ВыполнитьВФоне("ДополнительныеОтчетыИОбработки.ВыполнитьКоманду", ПараметрыПроцедуры, ПараметрыВыполнения);
	
КонецФункции

&НаКлиенте
Процедура Фигачить(Команда)
	
	СопровождающийТекст = НСтр("ru = 'Выполняется обработка данных'");
	Обработчик = Новый ОписаниеОповещения("ПослеЗавершенияДлительнойОперации", ЭтотОбъект, СопровождающийТекст);

	Если ЗначениеЗаполнено(Параметры.ДополнительнаяОбработкаСсылка) Тогда
		НастройкиОжидания = ДлительныеОперацииКлиент.ПараметрыОжидания(ЭтаФорма);
		НастройкиОжидания.ВыводитьПрогрессВыполнения = Истина;
		НастройкиОжидания.ВыводитьСообщения = Истина;
		НастройкиОжидания.ТекстСообщения = НСтр("ru = 'Выполняется обработка данных...'");
		
		ВыполняемаяКоманда = Новый Структура("Ссылка, Идентификатор, СвойПараметр", Параметры.ДополнительнаяОбработкаСсылка, Параметры.ИдентификаторКоманды, "это мой параметр (фоновое)");
		
		ОперацияВФоне = ФигачитьВФоне(ВыполняемаяКоманда, УникальныйИдентификатор);
		ДлительныеОперацииКлиент.ОжидатьЗавершение(ОперацияВФоне, Обработчик, НастройкиОжидания);
		
	Иначе
		Параметры.ИдентификаторКоманды = "ОткрытьФормуОбработку";
		ПараметрыКоманды = ДополнительныеОтчетыИОбработкиКлиент.ПараметрыВыполненияКомандыВФоне(Параметры.ДополнительнаяОбработкаСсылка);
		ПараметрыКоманды.СопровождающийТекст = СопровождающийТекст + "...";
		ПараметрыКоманды.Вставить("СвойПараметр","это мой параметр");
		Операция = ВыполнитьКомандуНапрямую(ПараметрыКоманды);
		ВыполнитьОбработкуОповещения(Обработчик, Операция);
	КонецЕсли;

КонецПроцедуры

#Область СлужебныеПроцедурыИФункции

&НаСервере
Функция ВыполнитьКомандуНапрямую(ПараметрыКоманды)
	Операция = Новый Структура("Статус, КраткоеПредставлениеОшибки, ПодробноеПредставлениеОшибки");
	Попытка
		ДополнительныеОтчетыИОбработки.ВыполнитьКомандуИзФормыВнешнегоОбъекта(
			Параметры.ИдентификаторКоманды,
			ПараметрыКоманды,
			ЭтотОбъект);
		Операция.Статус = "Выполнено";
	Исключение
		Операция.КраткоеПредставлениеОшибки   = КраткоеПредставлениеОшибки(ИнформацияОбОшибке());
		Операция.ПодробноеПредставлениеОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке());
	КонецПопытки;
	Возврат Операция;
КонецФункции

&НаКлиенте
Процедура ПослеЗавершенияДлительнойОперации(Операция, СопровождающийТекст) Экспорт
	Если Операция.Статус = "Выполнено" Тогда
		ПоказатьОповещениеПользователя(НСтр("ru = 'Успешное завершение'"), , СопровождающийТекст, БиблиотекаКартинок.Успешно32);
	Иначе
		ПоказатьПредупреждение(, Операция.КраткоеПредставлениеОшибки);
	КонецЕсли;
КонецПроцедуры

#КонецОбласти

 

Скачать файлы

Наименование Файл Версия Размер
старый вариант для БСП 2.3

.epf 7,86Kb
140
.epf 7,86Kb 140 Скачать
новый вариант для БСП 3.0

.epf 7,80Kb
78
.epf 7,80Kb 78 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Fragster 1071 19.05.16 11:50 Сейчас в теме
Добавьте в пример вывод прогресс-бара
2. rozer 292 19.05.16 17:22 Сейчас в теме
(1) Fragster, можно конечно как тут http://infostart.ru/public/458778/ но пришлось бы снимать с поддержки для добавления своей общей формы. Другого способа более легкого не знаю )
3. Fragster 1071 19.05.16 17:38 Сейчас в теме
(2) Зачем? есть же "ДлительныеОперации.СообщитьПрогресс" и ".ПрочитатьПрогресс", а отображать прогресс можно в своей форме с обработчиком ожидания? Или в данном случае это неприменимо?
Дмитрий74Чел; +1 Ответить
4. rozer 292 19.05.16 19:22 Сейчас в теме
(3) хм, посмотрю на досуге...
6. rozer 292 21.05.16 16:03 Сейчас в теме
(3) Fragster, у меня не получилось с индикатором в этом случае.
Дело в том что нет возможности получить "ИдентификаторЗадания" для использования
ДлительныеОперации.ПрочитатьПрогресс(ФоновоеЗаданиеИдентификатор)
.

Вот если используется "ДлительныеОперации.ЗапуститьВыполнениеВФоне" тогда да это получиться:

РезультатФоновогоЗадания = ДлительныеОперации.ЗапуститьВыполнениеВФоне(
				УникальныйИдентификатор,
				"МойМодуль.МояФоноваяПроцедура",
				ПараметрыЗадания,
				ПараметрыЗадания.НаименованиеЗадания);
			
ФоновоеЗаданиеИдентификатор  = РезультатФоновогоЗадания.ИдентификаторЗадания;


Но это не для внешних обработок - остается только как в http://infostart.ru/public/159607/ самому запускать фоновое оповещать через "СообщениеПользователю" и "ловить" в форме в "обработчике ожидания".
5. rozer 292 20.05.16 10:37 Сейчас в теме
если запустить эту обработку в последней версии БП 3.0 то вместо "крутящегося колесика" - этот
веселый котэ )))
Настоящий подарок бухгалтерам )
Atori-kun; TeMochkiN; invertex; +3 Ответить
9. 1vasia1 15 27.05.16 15:35 Сейчас в теме
(5) И правда котэ в картинки "ДлительнаяОперация48" добавили :)
10. config 133 27.05.16 15:41 Сейчас в теме
(5) бухгалтерия ЛИЧНО звонила и благодарила за "такого замечательного котика"
7. aldor188 6 25.05.16 08:48 Сейчас в теме
А что за процедура Фигачить()? Она не используется по коду.
8. rozer 292 25.05.16 10:30 Сейчас в теме
(7) это обработчик команды формы обработки
11. aaudin90 02.06.16 10:58 Сейчас в теме
(8) есть опыт работы с длительными операциями для внешних отчетов? Делаем через набор данных "объект" и стандартная обработка в процедуре ПриКомпоновкеРезультата = ложь, поэтому стандартное скдшное фоновое задание не работает.
12. rozer 292 02.06.16 12:40 Сейчас в теме
(11) aaudin90,
внешних отчетов



а зачем - отчет сервер смотрит ? ))
13. aaudin90 02.06.16 12:52 Сейчас в теме
Отчет делается около 60 секунд, хотелось бы его каким то образом перевести в фон.
14. rozer 292 02.06.16 13:48 Сейчас в теме
(13) aaudin90, примерно так: сделайте на сервере программный вывод из ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент в табл документ, заполните в РезультатВыполнения табл.документ и на клиенте "ловите" этот РезультатВыполнения и демонстрируете его пользователю...
15. aaudin90 03.06.16 05:35 Сейчас в теме
(14) спасибо за совет, но все таки отказались от идеи использования набора данных объект)
16. user595572_katigugu 02.08.16 20:04 Сейчас в теме
Здравствуйте! Что-то не могу допереть, как передать параметры в серверную экспортную процедуру ВыполнитьКоманду. Т.е., если длительная операция содержит выполнение запроса к базе, значения параметров вводятся через форму, как их подтянуть в процедуру? День протупил. :) Буду очень признателен за помощь. Заранее спасибо.
17. rozer 292 03.08.16 10:29 Сейчас в теме
(16) user595572_katigugu, поместить в "ПараметрыКоманды " в Фигачить()
например:
ПараметрыКоманды .Вставить("струкНастроек", РеквизитФормыВЗначение("Объект").ПолучитьСтруктуруНастроекСервер());


и получать в ВыполнитьКоманду(ИмяКоманды,ПараметрыВыполнения)
например:
ПараметрыНастроекВФорме=ПараметрыВыполненияКоманды.струкНастроек;

vasiliy_b; Дмитрий74Чел; +2 Ответить
18. user595572_katigugu 09.08.16 13:49 Сейчас в теме
25. vasiliy_b 282 01.12.17 12:43 Сейчас в теме
А есть идеи как передать ТЧ в фоновое задание?

Пробовал передать данные через ПоместитьВоВременноеХранилище. Но именно при фоновом запуске данные уже не получить.
PS: Пробовал использовать все три Варианта помещения данных, но ни один не заработал. Т.е на сервере ПолучитьИзВременногоХранилища всегда получается значение = неопределено.
26. rozer 292 02.12.17 12:39 Сейчас в теме
(25) ну не знаю, может не серилизуемые данные и если не по идентификатору формы то один серв вызов живет ВХ. Попробуй параметр сеанса...
27. vasiliy_b 282 02.12.17 17:31 Сейчас в теме
(26), точно не сериализуемые данные, пока выкрутился функцией ЗначениеВСтрокуВнутр и обратно, но данное решение мне не очень нравится.
А можешь поподробней про способ через параметр сеанса? типа помещать в какой-то из параметров данные и потом их оттуда забирать?
28. rozer 292 02.12.17 21:49 Сейчас в теме
19. Yackov 97 15.11.16 09:57 Сейчас в теме
На новом релизе бухгалтерии обработка перестала работать
20. rozer 292 13.02.17 08:24 Сейчас в теме
(19) ну видимо БСП поменяли как обычно...
21. Дмитрий74Чел 204 02.03.17 16:40 Сейчас в теме
Вопрос: а как отлаживать фоновое? Отладчик не хочет заходить в созданный объект-обработку. Останавливается на Объект.Выполнить(ИмяКоманды,ПараметрыВыполнения)
23. zarankony 02.03.17 17:27 Сейчас в теме
(21)Отладку к сожалению можно делать только поставив галку на форме для отладки и по ней запускать процедуру непосредственно, не через фоновое задание. Если кто знает другой способ- мне и самому будет интересно узнать.
55. Xershi 1257 23.01.20 12:27 Сейчас в теме
(23) открываем форму и кнопкой запускаем то что 1С запустить регламентом. Опять же эмуляция вызова.
22. zarankony 02.03.17 17:07 Сейчас в теме
Рассказываю рабочий способ: запускаем фоновое задание
Результат = ВыполнитьЗапускВФонеНаСервере();	
ИдентификаторЗадания = Результат.ИдентификаторЗадания;


И
Функция ВыполнитьЗапускВФонеНаСервере()
	НаименованиеЗадания = "Любое название";
	ПараметрыЗапуска = Новый Структура;
	ПараметрыЗапуска.Вставить("Режим", Объект.Режим);
	//тут еще параметры	
        Результат = ДлительныеОперации.ЗапуститьВыполнениеВФоне(
															Новый УникальныйИдентификатор, 
															"Модуль.Процедура", 
															ПараметрыЗапуска, 
															НаименованиеЗадания);
	Лог="";
	Возврат Результат;
															
КонецФункции
Показать

Дальше для прогресс бара нам понадобится из запущенного сеанса выводить сообщения нужного нам формата, например "Прогресс=32". в основной обработке получаем эти сообщения и интерпретируем(парсим) через ПолучитьСообщенияПользователю() так:
ПодключитьОбработчикОжидания("ВыводСообщений",1,Ложь);

И
&НаКлиенте
Процедура ВыводСообщений()
	Рез=ВыводСообщенийНаСервере();
	Если Рез=Ложь Тогда
		ОтключитьОбработчикОжидания("ВыводСообщений");
		ПоказатьПредупреждение(,"Процесс завершен");
	КонецЕсли;
	Состояние("Наш процесс",Прогресс);
КонецПроцедуры

&НаСервере
Функция ВыводСообщенийНаСервере()
	ДлинаЛога = 50000;
	Задание=ФоновыеЗадания.НайтиПоУникальномуИдентификатору(ИдентификаторЗадания);
	Если Задание=Неопределено Тогда
		Возврат Ложь;
	КонецЕсли;
	Сообщения=Задание.ПолучитьСообщенияПользователю(Истина);
		Для Каждого Сообщение ИЗ Сообщения Цикл
			Если Лев(Сообщение.Текст,8)="Прогресс" Тогда
				Прогресс=Число(Сообщение.Текст,2);
								
			Иначе
				
				Лог=Строка(ТекущаяДата())+": "+Сообщение.Текст+Символы.ПС+Лев(Лог,ДлинаЛога);
			КонецЕсли;
			
			
		КонецЦикла;
	Если Задание.Состояние=СостояниеФоновогоЗадания.Активно Тогда
		
		Возврат Истина;
	Иначе
		
		Возврат Ложь;
	КонецЕсли;
КонецФункции
Показать

На форме у меня Переменные ИдентификаторЗадания, Прогресс и Лог(многострочное текстовое поле для вывода прочих служебных сообщений).
29. Xershi 1257 12.06.18 17:27 Сейчас в теме
(22) это хорошо написали. Сейчас переписывал обработку, которая использует ключ ОткрытиеФормы, на ВызовСерверногоМетода.
И похоже чтобы регламентное задание разделило процедуру на куски нужна "Модуль.Процедура". Если нет модуля и процедуры, то ничего не выйдет я так понял!
30. zarankony 18.06.18 13:00 Сейчас в теме
(29) есть немного извращенный метод получать модули и процедуры из внешней обработки, но это надо передавать её целиком на сервер и сохранять там.
31. Xershi 1257 18.06.18 13:15 Сейчас в теме
(30) а вот это уже интересно.
Речь идет именно о подключенной обработке?
Что за метод там используется, БСП?
32. zarankony 03.09.18 10:50 Сейчас в теме
(31) Да, БСП. ДлительныеОперации.ВыполнитьПроцедуруМодуляОбъектаОбработки я тут описывал как делать: https://infostart.ru/public/842660/
33. Xershi 1257 03.09.18 12:11 Сейчас в теме
(32) публикация не активна!
34. zarankony 03.09.18 14:08 Сейчас в теме
40. Xershi 1257 07.10.18 15:17 Сейчас в теме
(34) написал вам комментарий по статье, сыровата и тема не раскрыта, если сможете показать, что не так и дополнить статью, то будет отлично!
41. zarankony 08.10.18 09:41 Сейчас в теме
(40)ответил Вам там, метод рабочий и используется, думаю дополнить статью можно
24. Xershi 1257 21.08.17 19:30 Сейчас в теме
Отличная статья!
Попытка
		СтандартныеПодсистемыКлиентСервер.ВывестиОповещение(
		ПараметрыВыполнения.РезультатВыполнения,
		НСтр("ru = 'Выполнена длит. операция!'"),,
		БиблиотекаКартинок.Успешно32);
	Исключение
		СтандартныеПодсистемыКлиентСервер.ВывестиИнформациюОбОшибке(
		ПараметрыВыполнения.РезультатВыполнения,
		СтрШаблон(НСтр("ru = 'Ошибка выполнения команды ""%1""'"), ИмяКоманды),
		ИнформацияОбОшибке());
		Возврат;
	КонецПопытки;
Показать

Этот код в версии БСП 2.3.5.65 не работает, просто его удалил!
И дописал свой код выполнения задания:
УдалитьДокументыНаСервере(ПараметрыВыполнения.СписокДокументов);

Передав в параметры выполнения список значения интеграция прошла на ура!
А в форме распараллеливание потоков написал:
&НаКлиенте
Процедура УдалитьДокументыВПотоке(Команда)
	
	УдалитьДокументыВПотокеНаСервере();
	
	Кратность = Цел(Объект.ТаблицаПисем.Количество() / Объект.КоличествоПотоков);
	
	СписокДокументов = Новый СписокЗначений;
	
	Счетчик = 1;
	
	Для Каждого Строка Из Объект.ТаблицаПисем Цикл 		
		
		СписокДокументов.Добавить(Строка.Документ); 
		
		Если СписокДокументов.Количество() % Кратность = 0 Тогда
			
			ПараметрыКоманды = Новый Структура();
			ПараметрыКоманды.Вставить("ДополнительнаяОбработкаСсылка", Объект.ОбъектСсылка);
			ПараметрыКоманды.Вставить("СопровождающийТекст", НСтр("ru = 'Регламентное удаление входящих электронных писем в фоне потока " + Счетчик + "...'"));
			ПараметрыКоманды.Вставить("СписокДокументов", СписокДокументов);
			
			ДополнительныеОтчетыИОбработкиКлиент.ВыполнитьКомандуВФоне(Объект.ИдентификаторКоманды, ПараметрыКоманды, ЭтаФорма);
			
			СписокДокументов.Очистить();
			
			Счетчик = Счетчик + 1;
			
		КонецЕсли;                                   					
		
	КонецЦикла;
	
	//Состояние(ПараметрыКоманды.СопровождающийТекст); 
	
КонецПроцедуры
Показать

Правда такой метод делает при не целом делении на 1 поток больше, но зато результат на лицо!
53. platonov.e 118 23.01.20 07:58 Сейчас в теме
(24)
ВыполнитьКомандуВФоне
а это будет работать только если обрабботка подключена в справочнике, если открыть через файл - открыть - то не будет работать?
54. Xershi 1257 23.01.20 09:27 Сейчас в теме
(53) там придётся извратиться. Проще через дополнительные сделать.
56. Xershi 1257 23.01.20 13:04 Сейчас в теме
(53) в своих наработках у меня работает, если обработка подключена. А копия которую я запускаю через файл вызывает эту подключенную обработку, отлаживать так проще.
А если без подключения, то вам придется сохранить обработку, передать на сервер и вызвать метод из переданной обработки, что согласитесь треш! Но если очень нужно, то можно.
57. platonov.e 118 23.01.20 13:28 Сейчас в теме
(56) ну да я тоже уже вызываю из спраочника)
58. platonov.e 118 23.01.20 16:08 Сейчас в теме
(56) так, а можно сделать чтобы при фоновым выполнении никакое окошко, не статус бар не вылазило? выполнялось себе и ладно.
59. Xershi 1257 23.01.20 16:25 Сейчас в теме
(58) да, если запустить на сервере, как любое фоновое задание. Тут же суть в прогрессе, а это клиент.
60. platonov.e 118 10.02.20 14:46 Сейчас в теме
(59) блин, а я не могу на сервере вызвать, есть оповещение...
61. Xershi 1257 10.02.20 14:50 Сейчас в теме
(60) для этого запускают второе фоновое задание, которое и выводит результат после завершения первого.
62. platonov.e 118 11.02.20 13:28 Сейчас в теме
(61) а как отследить выполнилось оно или нет, чтобы повторно еще одно не запустить?
63. Xershi 1257 11.02.20 13:32 Сейчас в теме
(62) ну код поковыряйте. Там же все уже предусмотрели.
35. login1020 97 20.09.18 11:50 Сейчас в теме
А как вернуть значение из
Процедура ВыполнитьКоманду(ИмяКоманды,ПараметрыВыполнения) Экспорт

или заполнить реквизит обработки/табличную часть?

Выполняю запрос, и через Сообщить() видно что запрос отрабатывает и идёт обход выборки, но заполнение не происходит

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
стр = тч.Добавить();
Сообщить(ВыборкаДетальныеЗаписи.Партнер);
ЗаполнитьЗначенияСвойств(Стр,ВыборкаДетальныеЗаписи);
КонецЦикла;
36. rozer 292 25.09.18 20:17 Сейчас в теме
(35) тч - табчасть объекта ? да все должно ИМХО норм отрабатывать
37. login1020 97 26.09.18 10:40 Сейчас в теме
ТЧ - таб часть объекта, командой "Открыть форму и выполнить в фоне с индикацией"
В фоне отрабатывает запрос, все партнеры через сообщить выводятся, но таб часть
на форме остается пустой
Процедура ВыполнитьКоманду(ИмяКоманды,ПараметрыВыполнения) Экспорт
	ДатаЗавершенияВМиллисекундах = ТекущаяУниверсальнаяДатаВМиллисекундах() + 1000*10;
	
	Попытка
		Сообщить("Успешно");
	Исключение
		Сообщить(ОписаниеОшибки());
		Возврат;
	КонецПопытки;
	
	 //Имитация длительной операции - вместо этого вставте свой код который будет выполняться на сервере в фоне
	Пока ТекущаяУниверсальнаяДатаВМиллисекундах() < ДатаЗавершенияВМиллисекундах Цикл
	КонецЦикла;
	
		Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	Партнеры.Ссылка КАК Партнер,
	|	Партнеры.ДатаРождения КАК ДатаРождения
	|ИЗ
	|	Справочник.Партнеры КАК Партнеры
	|ГДЕ
	|	Партнеры.Ссылка = &ссылка";
	Запрос.УстановитьПараметр("Ссылка",ПараметрыВыполнения.ПараметрПартнёр);

	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		стр  = тч.Добавить();
		стр.Партнер  =  ВыборкаДетальныеЗаписи.Партнер;
		стр.ДатаРождения  = Дата("20180101");
	 	Сообщить(ВыборкаДетальныеЗаписи.Партнер);
	КонецЦикла;
	
КонецПроцедуры
Показать
38. rozer 292 26.09.18 11:01 Сейчас в теме
(37)
на форме остается пустой


ах на форме )
ага это точно так форму тут обновлять намного сложнее чем использовать РеквизитФормыВЗначение() или ДанныеФормыВзначение()
39. kassbar 144 04.10.18 14:41 Сейчас в теме
Процедура ВыполнитьКомандуВФоне(Знач ИдентификаторКоманды, Знач ПараметрыКоманды, Знач Обработчик)
третий параметр это описание оповещения.
почему в него передается "ЭтаФорма" ?
42. Xershi 1257 08.10.18 13:35 Сейчас в теме
(0) в своей логике не использовал передачу ТЗ с клиента в фоновое задание. Сейчас это понадобилось.
На форме есть данные формы коллекция. Через серверный вызов преобразовываю в ТЗ и помещаю во временное хранилище.
Как получить потом ТЗ в фоновом задании?
У меня не получилось! Передал адрес ТЗ на клиенте, а когда к нему обратилось фоновое задание, то там ничего не было.
Я так понимаю это особенность работы 1С. Был ли опыт такой работы?
43. kassbar 144 20.10.18 17:13 Сейчас в теме
(42)
Временное хранилище, сформированное в одном сеансе, недоступно из другого сеанса.
Фоновое задание - это и есть другой сеанс. А ТЗ осталась во ВХ клиентского сеанса.
Я сохранял данные во временном файле и передавал в фоновое путь к временному файлу на сервере.
44. Xershi 1257 20.10.18 20:09 Сейчас в теме
(43) про это я написал. Решение вопроса, то есть?
45. kassbar 144 20.10.18 20:20 Сейчас в теме
(44) сохраняй в любом хранилище, не связанном с текущим сеансом. Например в хранилище внешней обработки (если это форма внешней обработки), в хранилище настроек конфигурации, в любом регистре сведений где есть ресурс с типом ХранилищеЗначения (например Версии объектов), сохраняй в файл в каталоге темп (если нужно передать файл)
46. Xershi 1257 20.10.18 20:23 Сейчас в теме
(45) каким методом?
ПоместитьВоВременноеХранилище(ТекущийСписокВалют, Новый УникальныйИдентификатор())

Я так понимаю этот метод только на сеанс.
47. kassbar 144 20.10.18 20:47 Сейчас в теме
(46) например
ХранилищеОбщихНастроек.Сохранить();
ХранилищеОбщихНастроек.Загрузить();
или
Новый хранилищеЗначения()
48. Xershi 1257 20.10.18 21:49 Сейчас в теме
(47)
Новый ХранилищеЗначения()

Отличный вариант! Как раз на клиенте вызываю серверную функцию, которая возвращает тип "ХранилищеЗначения", а далее передаю параметром в клиентский фоновый вызов!
49. kaliuzhnyi 22.08.19 09:57 Сейчас в теме
Не забывайте в СведенияОВнешнейОбработке() указывать версию БСП.

ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");


Интересно какая минимальная версия для работы этого метода?
50. rozer 292 20.09.19 15:39 Сейчас в теме
добавил вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0
51. Eret1k 27.09.19 11:48 Сейчас в теме
52. rozer 292 27.09.19 13:23 Сейчас в теме
(51) Да, помогла ваша публикация о чем я собственно и написал )

>>Немного тут подсмотрел

но в дополнение показал как доп. параметры передавать ну и использовал типовые приемы из внешней обработки "ЗаполнениеКонтрагентов" из БСП 3.0.3.
64. burgomister 39 09.04.20 19:01 Сейчас в теме
Полный код для фонового задания... что-то это мне напоминает:
#include
class string
{ private:
int size;
char *ptr;
public:
string() : size(0), ptr(new char('*')) {}
string(const string &s) : size(s.size)
{
ptr = new char[size + 1];
strcpy(ptr, s.ptr);
}
~string()
{
delete [] ptr;
}
friend ostream &operator << (ostream &, const string &);
string &operator = (const char *);
};
ostream &operator << (ostream &stream, const tring &s)
{
return(stream << s.ptr);
}
string &string::operator = (const char *chrs)
{
if(this != &chr)
{
delete [] ptr;
size = strlen(chrs);
ptr = new char[size + 1];
strcpy(ptr, chr);
}
return(*this);
}
int main()
{
string str;
str = 'Hello World';
cout << str << endl;
return(0);
}
Показать
65. zels 172 13.10.20 10:13 Сейчас в теме
Скачал версию для БСП3, запустил в БП3 - ничего не индицируется...
66. zabaluev 443 03.02.21 00:03 Сейчас в теме
(65) Что бы была индикация, надо подключить, как внешнюю обработку в программу.
67. HAMMER_59 223 27.04.21 19:43 Сейчас в теме
Спасибо за статью.

Для себя сделал несколько изменений.
1. Параметр ДополнительнаяОбработкаСсылка отметил как ключевой, ИдентификаторКоманды так и не понял зачем нужен. Событие ПриСозданииНаСервере убрал.
2. Не понял зачем сначала создавать структуру ВыполняемаяКоманда, передавать её на сервер. С таким же успехом можно прямо в серверной функции получить все то же самое. С ИдентификаторомКоманды совсем ничего не понял, у меня заполняется в зависимости от того какую кнопку на форме нажму.
68. a_inves 27.09.21 20:33 Сейчас в теме
"Запуск непосредственно на сервере можно сделать по расписанию."
------------------
А мне программа говорит, что Расписание Непременимо для команд с вариантом запуска "Открытие формы"
(
69. rozer 292 27.09.21 21:57 Сейчас в теме
(68) да, расписание только если не "открытие формы" )
Оставьте свое сообщение

См. также

Универсальный редактор данных (УРД) Промо

Инструментарий разработчика Администрирование данных 1С v8 Абонемент ($m)

Универсальный редактор данных (УРД) - это лучший инструмент в своем классе, который позволяет редактировать реквизиты и движения объектов

1 стартмани

27.08.2021    5285    116    Adeptus    51    

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    9642    27    huxuxuya    11    

Загрузка номенклатуры и изображений в Управление торговлей 11.4 и УНФ из файлов прайс-листов формата YML (Yandex Market Format) или XML

Обработка справочников Обмен через XML v8 УТ11 Россия Абонемент ($m)

Обработка предназначена для загрузки каталога номенклатуры и изображений из файлов прайс-листов формата YML (Yandex Market Format) или XML или по ссылке из Интернет в справочник "Номенклатура".

3 стартмани

20.11.2020    2927    13    Victor29reg    8    

CF & SQL : конструктор прямых запросов к БД 1С

Инструментарий разработчика Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Программа для чтения и анализа внутренней структуры данных 1С V8.х, Содержит конструктор прямых SQL запросов, позволяет обрабатывать и редактировать тексты SQL-запросов, выполнять прямые запросы к базе данных 1С и обрабатывать полученные результаты.

1 стартмани

02.10.2019    30068    296    dmitrydemenew    63    

Faster - многофункциональный ускоритель работы программиста 1С и других языков программирования Промо

Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Программа Faster 9.4 позволяет ускорить процесс работы программиста (работает в любом текстовом редакторе). Подсказка при вводе текста на основе ранее введенного текста и настроенных шаблонов. Программа Faster позволяет делится кодом с другими программистами в два клика или передать ссылку через QR Код. Исправление введенных фраз двойным Shift (с помощью speller.yandex). Переводчик текста. Переворачивает текст случайно набранный на другой раскладке. Полезная утилита для тех, кто печатает много однотипного текста, кодирует в среде Windows на разных языках программирования. Через некоторое время работы с программой у вас соберется своя база часто используемых словосочетаний и кусков кода. Настройка любых шорткатов под себя с помощью скриптов. Никаких установок и лицензий, все бесплатно.

1 стартмани

24.05.2012    84443    965    moolex    157    

Работа с релизами 1С и договорами ИТС

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    20986    61    RocKeR_13    37    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    28137    7    m-rv    91    

Модель объекта

Инструментарий разработчика v8 Абонемент ($m)

Подсистема позволяет описать модель данных объекта, где описана зависимость между реквизитами, и затем использовать эту модель в разных сценариях работы с объектом. Версия платформы: 8.3.6 и выше. С небольшими доработками будет работать на 8.2.

1 стартмани

30.06.2019    16349    1    vadim1980    5    

Установка предопределенных элементов: просмотр, исправление и поиск ошибок (задвоенных и отсутствующих) Промо

Инструментарий разработчика Универсальные обработки v8 1cv8.cf Абонемент ($m)

Простая обработка для просмотра и установки значений предопределенных элементов. Позволяет заменить значение предопределенного элемента с одного элемента справочника на другой, удалить предопределенный элемент (снять пометку предопределенности), установить пометку переопределенного элемента. Проверяет предопределенные данные на наличие задвоений и отсутствующих. Работает со справочниками, планами счетов, планами видов характеристик, планами видов расчетов.

2 стартмани

06.10.2014    169032    2754    ekaruk    170    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    61848    266    informa1555    234    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    28885    14    RocKeR_13    16    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    36650    31    informa1555    30    

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    54484    170    ekaruk    32    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    67559    25    kalyaka    17    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    37036    96    m-rv    58    

Выполнение внешней обработки в фоне на базе БСП

Инструментарий разработчика v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Выполнение внешней обработки в фоне с выводом прогресса. Работает как для обработок в дополнительных отчетах и обработках, так и для внешней обработки запускаемой через Файл/Открыть. Так же работает если встроить обработку в конфигурацию или в расширение. Показан пример как стандартного БСП прогресса, так и пример нестандартного прогресса. Показана передача параметров в фоновое задание и возврат результата.

1 стартмани

22.03.2018    12274    67    Wern03    4    

Регистры правил [Расширение]

Инструментарий разработчика Информационная безопасность v8 v8::Права УТ11 Абонемент ($m)

Регистры правил - права доступа, запрет редактирования, автоподстановка реквизитов и т.д.

10 стартмани

15.03.2018    22966    30    33lab    5    

Заполняем по шаблону (по умолчанию)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    35001    20    mvxyz    17    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    33363    60    kwazi    6    

[x1c.ru] 1CDBin: Работа с файлами *.1CD на низком уровне средствами языка 1С с возможностью чтения таблиц (поддерживается формат 8.3.8.0) Промо

Тестирование и исправление Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Обработка позволяет просматривать файловые базы 1CD на низком уровне средствами встроенного языка. Реализована часть функциональности Tool_1CD, но на языке 1С Предприятия. Показываются таблицы, параметры таблиц, поля таблиц, записи таблиц, значения полей BLOB, есть 16-ричный просмотр страниц базы и консоль кода. Можно использовать для изучения структуры файлов 1CD, просмотра баз 1CD для выявления повреждений, создания своих обработок для выгрузки данных без открытия исследуемой базы в 1С:Предприятии.

1 стартмани

07.10.2014    62632    392    GusevNA    78    

Программное формирование форматированной строки в стиле html+inline CSS

Работа с интерфейсом Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    42719    45    bonv    13    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    167115    13    signum2009    49    

Набор подсистем "Умные таблицы"

Инструментарий разработчика v8 Беларусь Россия Казахстан Абонемент ($m)

Данный набор подсистем – прикладная библиотека, призванная помочь программисту 1С быстрее решать ряд типовых задач бизнес-логики, таких как: ведение статусов объектов, отправка почтовых сообщений в определенное время, ведение произвольных таблиц с возможностью редактирования, сохранения и группировки, ориентированные на расчет бюджетных таблиц (план продаж, ретробонусы B2C, проценты по договорам B2B и договорные условия по КАМ), расчет коммерческой политики для бюджетных таблиц, исполнение произвольных алгоритмов с хранением кода в информационной базе, определение рабочих баз, хранение файлов во внешних СУБД (Postgre SQL, MS SQL и MongoDB) и выполнение произвольного кода после изменений ссылочного объекта вне транзакции изменения.

1 стартмани

22.05.2017    37554    105    Silenser    34    

Конструктор-тестер http запросов в 1С

WEB Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Данная обработка позволяет в несколько кликов конструировать http запросы на языке 1С и просматривать результаты их выполнения.

3 стартмани

19.08.2016    48381    316    hlopik    19    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    55168    36    Demanoidos    60    

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен)

Внешние источники данных WEB Инструментарий разработчика v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    38248    20    c1nil    4    

Навигатор по структуре и данным баз 1С 8

Инструментарий разработчика v8 v8::УФ 1cv8.cf Абонемент ($m)

Просмотр структуры и данных информационных баз 1С:Предприятие 8.2, 8.3. Состав, типы объектов, табличных частей, движений. Размер, структура хранения объекта. Для администраторов и разработчиков. Версия 1 - на обычных формах, версия 2 - на управляемых.

1 стартмани

11.07.2016    33341    138    o.nikolaev    17    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    68108    12    wowik    32    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    77716    21    arakelyan    25    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    96033    172    igo1    61    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    23164    2    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    59519    56    yuraos    18    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    28535    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    46948    21    milkers    4    

Нечеткий поиск одним запросом

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    34842    74    vasvl123    9